Some minor fixups.

This commit is contained in:
dholland 2012-12-27 00:20:56 +00:00
parent 29ecbe422e
commit 2a2f0cd6ed
4 changed files with 47 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.14 2012/12/26 22:31:31 dholland Exp $
$NetBSD: distinfo,v 1.15 2012/12/27 00:20:56 dholland Exp $
SHA1 (rad3R6P1.tar.gz) = 71f46abd1c30be282a93237fa0c162d3bf0b1f99
RMD160 (rad3R6P1.tar.gz) = 3bcf40518a57cdb5455264c83a3e206b67b3d1fa
@ -29,5 +29,8 @@ SHA1 (patch-at) = 34bf252c122727308ebaa47177afabbc888a4f6a
SHA1 (patch-au) = 35660480163fb7444ebbdb1fee4ad1cebf866ef4
SHA1 (patch-av) = 0bfd2ec0fb16f3c106a285b49f1cf48a29274fbb
SHA1 (patch-aw) = 6b57d85e4c4ef4a3501f4a0263ef8a47fbac8958
SHA1 (patch-src_common_readmesh.c) = a186fdb5a3bde532ed3ea50c295a0a0aaa1a36c9
SHA1 (patch-src_meta_plot.h) = b6959e2d349dc25abbde816f4b128a2fb0218200
SHA1 (patch-src_meta_xmeta.c) = 360c282bd9adf376ea86140d6c63af523114618d
SHA1 (patch-src_ot_writemesh.c) = 109266d289720ed6760f430ab7a7637312ac9c3d
SHA1 (patch-src_ot_writeoct.c) = b6f6426ef6abf731cd5c9735e6012c07f5e9ff35

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_common_readmesh.c,v 1.1 2012/12/27 00:20:56 dholland Exp $
Don't abuse NULL.
--- src/common/readmesh.c~ 2004-09-14 02:53:50.000000000 +0000
+++ src/common/readmesh.c
@@ -97,7 +97,7 @@ gettree() /* get a pre-ordered octree
default:
mesherror(USER, "damaged mesh octree");
}
- return (OCTREE)NULL; /* pro forma return */
+ return (OCTREE)0; /* pro forma return */
}

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_ot_writemesh.c,v 1.1 2012/12/27 00:20:56 dholland Exp $
Use cpp in a valid fashion.
--- src/ot/writemesh.c~ 2004-04-29 14:36:49.000000000 +0000
+++ src/ot/writemesh.c
@@ -11,6 +11,7 @@ static const char RCSid[] = "$Id: writem
#include "mesh.h"
#ifdef putc_unlocked /* avoid horrendous overhead of flockfile */
+#undef putc
#define putc putc_unlocked
#endif

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_ot_writeoct.c,v 1.1 2012/12/27 00:20:56 dholland Exp $
Use cpp in a valid fashion.
--- src/ot/writeoct.c~ 2004-04-29 14:36:49.000000000 +0000
+++ src/ot/writeoct.c
@@ -14,6 +14,7 @@ static const char RCSid[] = "$Id: writeo
#include "oconv.h"
#ifdef putc_unlocked /* avoid horrendous overhead of flockfile */
+#undef putc
#define putc putc_unlocked
#endif