Updated net/sslh to version 1.18.
Pkgsrc changes : - taking over maintainership ; - updated patch for getopt_long because of the update. Upstream changes : - Added USELIBPCRE to make use of regex engine optional ; - Added support for RFC4366 SNI and RFC7301 ALPN (Travis Burtrum) ; - Changed connection log to include the name of the probe that triggered ; - Changed configuration file format: 'probe' field is no longer required, 'name' field can now contain 'tls' or 'regex', with corresponding options (see example.cfg) ; - Added 'log_level' option to each protocol, which allows to turn off generation of log at each connection ; - Added 'keepalive' option.
This commit is contained in:
parent
4c82838126
commit
2a8458793b
3 changed files with 16 additions and 17 deletions
|
@ -1,12 +1,11 @@
|
||||||
# $NetBSD: Makefile,v 1.9 2015/06/10 09:15:48 wiz Exp $
|
# $NetBSD: Makefile,v 1.10 2016/08/07 13:19:24 nils Exp $
|
||||||
|
|
||||||
DISTNAME= sslh-1.17
|
DISTNAME= sslh-1.18
|
||||||
PKGREVISION= 1
|
|
||||||
CATEGORIES= net
|
CATEGORIES= net
|
||||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=yrutschle/}
|
MASTER_SITES= ${MASTER_SITE_GITHUB:=yrutschle/}
|
||||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||||
|
|
||||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
MAINTAINER= nils@NetBSD.org
|
||||||
HOMEPAGE= http://www.rutschle.net/tech/sslh.shtml
|
HOMEPAGE= http://www.rutschle.net/tech/sslh.shtml
|
||||||
COMMENT= Multiplex ssl, ssh, and other connections on the same port
|
COMMENT= Multiplex ssl, ssh, and other connections on the same port
|
||||||
LICENSE= gnu-gpl-v2
|
LICENSE= gnu-gpl-v2
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
$NetBSD: distinfo,v 1.5 2015/11/04 00:35:38 agc Exp $
|
$NetBSD: distinfo,v 1.6 2016/08/07 13:19:24 nils Exp $
|
||||||
|
|
||||||
SHA1 (sslh-1.17.tar.gz) = d892e26204ec5b26f0f2a87eb388bbbf3f2bf91e
|
SHA1 (sslh-1.18.tar.gz) = dacf6250e26250513deeaa310c78591d5b3e77f4
|
||||||
RMD160 (sslh-1.17.tar.gz) = dec321368951b0c93d28595df806300adce07459
|
RMD160 (sslh-1.18.tar.gz) = 49e83f975f7e8df8358bdd1d7afeabdbe6269a82
|
||||||
SHA512 (sslh-1.17.tar.gz) = e66a295b645c24e7829ee0da6c654e496054a18ea889201da2959a134f7e12f0b1e0e59ef03e7702b5aee632329f46b99a6ccd5ec2142fe179521593ccff3662
|
SHA512 (sslh-1.18.tar.gz) = 859ad65a258534fde68295a2880c077a00205d96a6aafeb525abce836850b9deea7b39daa2dc74a0dc18d2b198884958a39fbe758d61c93b257676f3a7d4f7bc
|
||||||
Size (sslh-1.17.tar.gz) = 45451 bytes
|
Size (sslh-1.18.tar.gz) = 53175 bytes
|
||||||
SHA1 (patch-echosrv.c) = 611044fd7ed1fd52c44e2d8ff393091c35478e17
|
SHA1 (patch-echosrv.c) = 611044fd7ed1fd52c44e2d8ff393091c35478e17
|
||||||
SHA1 (patch-sslh-main.c) = 43c88799534a6562a92aa174eb6aff6de53865a2
|
SHA1 (patch-sslh-main.c) = a74502a087b11c4d8f32791ac86c45c7a38923d9
|
||||||
|
|
|
@ -1,19 +1,19 @@
|
||||||
$NetBSD: patch-sslh-main.c,v 1.3 2015/04/19 19:02:35 wiz Exp $
|
$NetBSD: patch-sslh-main.c,v 1.4 2016/08/07 13:19:24 nils Exp $
|
||||||
|
|
||||||
* getopt_long_only does not exist on NetBSD getopt.
|
* getopt_long_only does not exist on NetBSD getopt.
|
||||||
|
|
||||||
--- sslh-main.c.orig 2015-03-09 20:51:39.000000000 +0000
|
--- sslh-main.c.orig 2016-03-29 19:19:05.000000000 +0000
|
||||||
+++ sslh-main.c
|
+++ sslh-main.c
|
||||||
@@ -362,7 +362,7 @@ static void cmdline_config(int argc, cha
|
@@ -443,7 +443,7 @@ static void cmdline_config(int argc, cha
|
||||||
#ifdef LIBCONFIG
|
#ifdef LIBCONFIG
|
||||||
optind = 1;
|
optind = 1;
|
||||||
opterr = 0; /* we're missing protocol options at this stage so don't output errors */
|
opterr = 0; /* we're missing protocol options at this stage so don't output errors */
|
||||||
- while ((c = getopt_long_only(argc, argv, optstr, all_options, NULL)) != -1) {
|
- while ((c = getopt_long_only(argc, argv, optstr, all_options, NULL)) != -1) {
|
||||||
+ while ((c = getopt_long(argc, argv, optstr, all_options, NULL)) != -1) {
|
+ while ((c = getopt_long(argc, argv, optstr, all_options, NULL)) != -1) {
|
||||||
if (c == 'F') {
|
if (c == 'v') {
|
||||||
config_filename = optarg;
|
verbose++;
|
||||||
if (config_filename) {
|
}
|
||||||
@@ -397,7 +397,7 @@ static void parse_cmdline(int argc, char
|
@@ -480,7 +480,7 @@ static void parse_cmdline(int argc, char
|
||||||
optind = 1;
|
optind = 1;
|
||||||
opterr = 1;
|
opterr = 1;
|
||||||
next_arg:
|
next_arg:
|
||||||
|
|
Loading…
Reference in a new issue