ditto ifdefry for DragonFly. PR pkg/43641

This commit is contained in:
tnn 2010-07-19 14:14:13 +00:00
parent 99d5570828
commit 2a874de62d
2 changed files with 24 additions and 9 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.20 2010/07/15 09:08:28 tnn Exp $
$NetBSD: distinfo,v 1.21 2010/07/19 14:14:13 tnn Exp $
SHA1 (mDNSResponder-214.3.2.tar.gz) = bd59e0e3008ba797a30360dd8e59beb7152d9872
RMD160 (mDNSResponder-214.3.2.tar.gz) = f9670f661083dae5529422b19655ba9c473960c7
@ -7,4 +7,4 @@ SHA1 (patch-aa) = 9900768a7e3af94f2965320923ecf9d71ae8422b
SHA1 (patch-ab) = 712e3999854215b9ea14f6d444262beef8c545b1
SHA1 (patch-ac) = 60fd50c011dc086b6763fef617ab5f78c8ecc6b5
SHA1 (patch-ad) = fa77b934a63bd07f9b0a4697a3c1a59d242fca19
SHA1 (patch-ae) = ff7897253de50ac9afd1c1fd15fe73d99c4be47d
SHA1 (patch-ae) = f124201460929b86300664ff9ee31c0d845759c9

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.1 2010/07/15 09:08:28 tnn Exp $
$NetBSD: patch-ae,v 1.2 2010/07/19 14:14:14 tnn Exp $
--- mDNSShared/CommonServices.h.orig 2009-03-30 19:51:29.000000000 +0000
+++ mDNSShared/CommonServices.h
@@ -102,6 +102,16 @@ Common Services and portability support
@@ -102,6 +102,24 @@ Common Services and portability support
#endif
#endif
@ -15,20 +15,28 @@ $NetBSD: patch-ae,v 1.1 2010/07/15 09:08:28 tnn Exp $
+ #define TARGET_OS_NETBSD 0
+ #endif
+#endif
+
+#if( !defined( TARGET_OS_DRAGONFLY ) )
+ #if( defined( __DragonFly__ ) )
+ #define TARGET_OS_DRAGONFLY 1
+ #else
+ #define TARGET_OS_DRAGONFLY 0
+ #endif
+#endif
+
// Solaris
#if( !defined( TARGET_OS_SOLARIS ) )
@@ -128,7 +138,7 @@ Common Services and portability support
@@ -128,7 +146,7 @@ Common Services and portability support
// No predefined macro for VxWorks so just assume VxWorks if nothing else is set.
- #if( !macintosh && !__MACH__ && !defined( __linux__ ) && !defined ( __SVR4 ) && !defined ( __sun ) && !defined( __PALMOS_TRAPS__ ) && !defined( __PALMOS_ARMLET__ ) && !defined( _WIN32 ) )
+ #if( !macintosh && !__MACH__ && !defined( __linux__ ) && !defined ( __SVR4 ) && !defined ( __sun ) && !defined( __PALMOS_TRAPS__ ) && !defined( __PALMOS_ARMLET__ ) && !defined( _WIN32 ) && !defined(__NetBSD__))
+ #if( !macintosh && !__MACH__ && !defined( __linux__ ) && !defined ( __SVR4 ) && !defined ( __sun ) && !defined( __PALMOS_TRAPS__ ) && !defined( __PALMOS_ARMLET__ ) && !defined( _WIN32 ) && !defined(__NetBSD__) && !defined(__DragonFly__))
#define TARGET_OS_VXWORKS 1
#else
#define TARGET_OS_VXWORKS 0
@@ -224,6 +234,12 @@ Common Services and portability support
@@ -224,6 +242,19 @@ Common Services and portability support
#include <stdint.h>
#include <arpa/inet.h>
@ -37,16 +45,23 @@ $NetBSD: patch-ae,v 1.1 2010/07/15 09:08:28 tnn Exp $
+ // NetBSD
+
+ #include <arpa/inet.h>
+
+#elif ( TARGET_OS_DRAGONFLY )
+
+ // DragonFly
+
+ #include <arpa/inet.h>
+ #include <sys/socket.h> // for AF_INET6 definition
+
#elif( TARGET_OS_SOLARIS )
// Solaris
@@ -493,7 +509,7 @@ Common Services and portability support
@@ -493,7 +524,7 @@ Common Services and portability support
// - Windows
#if( TARGET_LANGUAGE_C_LIKE )
- #if( !defined(_SSIZE_T) && ( TARGET_OS_WIN32 || !defined( _BSD_SSIZE_T_DEFINED_ ) ) && !TARGET_OS_LINUX && !TARGET_OS_VXWORKS && !TARGET_OS_MAC)
+ #if( !defined(_SSIZE_T) && ( TARGET_OS_WIN32 || !defined( _BSD_SSIZE_T_DEFINED_ ) ) && !TARGET_OS_LINUX && !TARGET_OS_VXWORKS && !TARGET_OS_MAC && !TARGET_OS_NETBSD)
+ #if( !defined(_SSIZE_T) && ( TARGET_OS_WIN32 || !defined( _BSD_SSIZE_T_DEFINED_ ) ) && !TARGET_OS_LINUX && !TARGET_OS_VXWORKS && !TARGET_OS_MAC && !TARGET_OS_NETBSD && !TARGET_OS_DRAGONFLY)
typedef int ssize_t;
#endif
#endif