remove most of the hacks which were only to make the selftest

succeed, now that EBCDIC support in NetBSD-current was improved
(see PR lib/42209)
This commit is contained in:
drochner 2009-11-15 12:48:24 +00:00
parent 3a66064eea
commit 2aca9ca082
2 changed files with 4 additions and 13 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.74 2009/10/25 17:19:44 sno Exp $
$NetBSD: distinfo,v 1.75 2009/11/15 12:48:24 drochner Exp $
SHA1 (libxml2-2.7.6.tar.gz) = b0f6bf8408e759ac4b8b9650005ee8adea911e1d
RMD160 (libxml2-2.7.6.tar.gz) = 849ded7b61f88e75ef0dacf0e5647ce8ad951261
@ -8,5 +8,5 @@ SHA1 (patch-ab) = df7c8f1e0301d46b2ac905735b9985be58f782a2
SHA1 (patch-ac) = 264c75cf9fff5319105b971c122cdf5fc103c04e
SHA1 (patch-ad) = cd45da492b02cce9983c46762839f68b8b1e0177
SHA1 (patch-ae) = b9176919edbf3582cb24aff53f7c4f291e2b78c8
SHA1 (patch-ag) = e3848c7871e4da90c2c190d35b5396998a2bb143
SHA1 (patch-ag) = 30ec5c8daece4aba75a02bbc13db5373542dea7b
SHA1 (patch-ah) = 5cdb10502f7d41cbe2570d2cbd1c46d6a25f0394

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ag,v 1.7 2009/10/21 14:55:32 drochner Exp $
$NetBSD: patch-ag,v 1.8 2009/11/15 12:48:25 drochner Exp $
--- encoding.c.orig 2009-09-24 17:31:59.000000000 +0200
+++ encoding.c
@ -7,17 +7,8 @@ $NetBSD: patch-ag,v 1.7 2009/10/21 14:55:32 drochner Exp $
#endif
#endif
+#ifdef __NetBSD__ /* XXX needed by selftest */
+ xmlAddEncodingAlias("IBM273", "IBM-1141");
+ xmlAddEncodingAlias("CP1141", "IBM-1141");
+#endif
}
@@ -1454,6 +1457,8 @@ xmlGetCharEncodingHandler(xmlCharEncodin
case XML_CHAR_ENCODING_UTF16BE:
return(xmlUTF16BEHandler);
case XML_CHAR_ENCODING_EBCDIC:
+ handler = xmlFindCharEncodingHandler("IBM500");
+ if (handler != NULL) return(handler);
handler = xmlFindCharEncodingHandler("EBCDIC");
if (handler != NULL) return(handler);
handler = xmlFindCharEncodingHandler("ebcdic");