cftp is a dead project with major bugs. Remove.

This commit is contained in:
wiz 2017-08-01 17:12:49 +00:00
parent 908f082c71
commit 2afb7b28ce
7 changed files with 1 additions and 75 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1169 2017/07/28 21:15:33 wiz Exp $
# $NetBSD: Makefile,v 1.1170 2017/08/01 17:12:49 wiz Exp $
#
COMMENT= Networking tools
@ -62,7 +62,6 @@ SUBDIR+= calypso
SUBDIR+= cclive
SUBDIR+= ccrtp
SUBDIR+= cdpd
SUBDIR+= cftp
SUBDIR+= chimera
SUBDIR+= chksniff
SUBDIR+= choparp

View file

@ -1,5 +0,0 @@
CFTP is used to transfer files from one computer to another via
the FTP or SFTP (via ssh) protocol. Its advantages over most
standard ftp clients is its termcap-based fullscreen representation
of the remote directory tree, providing a compact overview of the
remote server's contents.

View file

@ -1,28 +0,0 @@
# $NetBSD: Makefile,v 1.21 2017/01/19 18:52:19 agc Exp $
#
DISTNAME= cftp-0.12
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.giga.or.at/pub/nih/cftp/
MASTER_SITES+= ftp://ftp.giga.or.at/pub/nih/cftp/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ftp.giga.or.at/pub/nih/cftp/
COMMENT= Comfortable FTP, a full screen ftp client
# bin/cftp
CONFLICTS= py[0-9]*-twisted-[0-9]*
GNU_CONFIGURE= YES
INFO_FILES= YES
BUILD_DEFS+= IPV6_READY
post-install:
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/cftp
cd ${WRKSRC} && ${INSTALL_MAN} README bindings.desc \
${DESTDIR}${PREFIX}/share/doc/cftp
.include "../../mk/termcap.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +0,0 @@
@comment $NetBSD: PLIST,v 1.6 2009/06/14 18:09:23 joerg Exp $
bin/cftp
info/cftp.info
share/doc/cftp/README
share/doc/cftp/bindings.desc

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.9 2015/11/04 00:34:55 agc Exp $
SHA1 (cftp-0.12.tar.gz) = ba583541be4bce2125849a677054d290140d0880
RMD160 (cftp-0.12.tar.gz) = 9dfd1d3a03efd5d724bc0ed4c0dafbe19c47670d
SHA512 (cftp-0.12.tar.gz) = 452c96134bae002cdef73278e383b5d8bb8b29f83018572e1aff6b5b28b2c540965a14204d8ac41f46bdf9718f6302fa5a3d765743009f3aa7bf70f02c69e21f
Size (cftp-0.12.tar.gz) = 182043 bytes
SHA1 (patch-aa) = 7d691241fa45821a0e5aa56337ebccc6df21567a
SHA1 (patch-ab) = 94841bf054059292552ed4c45e73b4c5a9624716

View file

@ -1,12 +0,0 @@
$NetBSD: patch-aa,v 1.3 2005/11/08 15:40:28 tv Exp $
--- sftp.c.orig 2002-09-16 08:42:42.000000000 -0400
+++ sftp.c
@@ -28,6 +28,7 @@
#ifdef USE_SFTP
#include <sys/types.h>
+#include <sys/time.h>
#include <sys/uio.h>
#include <sys/stat.h>
#include <sys/wait.h>

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1 2008/04/13 12:20:18 dillo Exp $
Fix for local buffer overflow, from cftp mercurial repository (r574).
--- readrc.c Wed Jul 04 18:18:41 2007 +0200
+++ readrc.c Sun Apr 13 14:10:51 2008 +0200
@@ -57,7 +55,7 @@ readrc(char **userp, char **passp, char
char b[8192], *p, *tok, *q, *home;
char *user, *pass, *host, *port, *wdir;
- if ((home=getenv("HOME")) == NULL)
+ if ((home=getenv("HOME")) == NULL || strlen(home) > sizeof(b)-9)
home = "";
sprintf(b, "%s/.cftprc", home);