Redirecting stdout and stderr with &> is not portable, fix this.

Issue raised by Koh-ichi Ito on nsd-users.
This commit is contained in:
joerg 2009-07-24 07:08:10 +00:00
parent 5386a38a9d
commit 2b01085a06
3 changed files with 22 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.46 2009/05/20 01:55:55 joerg Exp $
# $NetBSD: Makefile,v 1.47 2009/07/24 07:08:10 joerg Exp $
DISTNAME= nsd-3.2.2
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.25 2009/05/20 01:55:55 joerg Exp $
$NetBSD: distinfo,v 1.26 2009/07/24 07:08:10 joerg Exp $
SHA1 (nsd-3.2.2.tar.gz) = 23fc0be5d447ea852acd49f64743c96403a091fa
RMD160 (nsd-3.2.2.tar.gz) = 740b81386488d3f45b82e9ae26dbd7a2bfc85aa9
Size (nsd-3.2.2.tar.gz) = 840917 bytes
SHA1 (patch-aa) = 81b820eb4f2056ab85cad16b7dc526f1ba2737aa
SHA1 (patch-ab) = 53fad0fe0fec84da8f06909070f1d60bb8c74f85

18
net/nsd/patches/patch-ab Normal file
View file

@ -0,0 +1,18 @@
$NetBSD: patch-ab,v 1.3 2009/07/24 07:08:10 joerg Exp $
--- nsdc.sh.in.orig 2009-07-24 09:04:04.000000000 +0200
+++ nsdc.sh.in
@@ -195,11 +195,11 @@ controlled_stop() {
if [ $try -eq 1 ]; then
kill -TERM ${pid}
else
- kill -TERM ${pid} &>/dev/null
+ kill -TERM ${pid} > /dev/null 2>&1
fi
# really stopped?
- kill -0 ${pid} &>/dev/null
+ kill -0 ${pid} > /dev/null 2>&1
if [ $? -eq 0 ]; then
controlled_sleep ${try}
try=`expr ${try} + 1`