Always return a value from !void functions.

This commit is contained in:
joerg 2013-02-26 11:09:46 +00:00
parent 2f1d8f60ea
commit 2b099aba48
3 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2011/12/15 18:53:50 marino Exp $
$NetBSD: distinfo,v 1.7 2013/02/26 11:09:46 joerg Exp $
SHA1 (gcin-1.1.7.tar.bz2) = 0dd2cf64703d276fca3e5492e4ad1aaaed6fe290
RMD160 (gcin-1.1.7.tar.bz2) = 2c89f8a879e2ada52fb576bb6f91ac83e909a675
@ -11,3 +11,5 @@ SHA1 (patch-ae) = f7718fbb9a6a788a51c0d4198e2ba67048e59315
SHA1 (patch-af) = e66965a840e67afe007c4ddaa55cba572cf49e6f
SHA1 (patch-ag) = d3e16fd690f132bd687ceda2d13041e447147f6e
SHA1 (patch-ah) = 9edfc9e2df42fe0f9b7817a679b5727a86571fe4
SHA1 (patch-gcin-setup-list.c) = ef6d7ebe9e277aab42098bdeb4b7043743b3709f
SHA1 (patch-gtk-im_gtkimcontextgcin.c) = 52aa90dba9fb80786bce3bc662b3471b829d19f6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-gcin-setup-list.c,v 1.1 2013/02/26 11:09:46 joerg Exp $
--- gcin-setup-list.c.orig 2013-02-25 17:59:05.000000000 +0000
+++ gcin-setup-list.c
@@ -184,7 +184,7 @@ static gboolean toggled (GtkCellRenderer
int in_no = gcin_switch_keys_lookup(key[0]);
if (in_no < 0)
- return;
+ return FALSE;
gcin_flags_im_enabled ^= 1 << in_no;
value ^= 1;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-gtk-im_gtkimcontextgcin.c,v 1.1 2013/02/26 11:09:46 joerg Exp $
--- gtk-im/gtkimcontextgcin.c.orig 2013-02-25 18:00:04.000000000 +0000
+++ gtk-im/gtkimcontextgcin.c
@@ -321,7 +321,7 @@ gtk_im_context_xim_new (void)
static gboolean update_cursor_position(gpointer data)
{
if (!context_xim_queued)
- return;
+ return FALSE;
g_signal_emit_by_name(context_xim_queued, "preedit_changed");
context_xim_queued = NULL;