Initial import of jftpgw-0.13.4, packaged by David Ferlier in PR
pkg/24414, with minor changes by me. jftpgw is an FTP proxy/gateway that uses the FTP protocol (unlike those FTP proxies that fetch an FTP file but work as an http proxy). You can use it to make servers behind a firewall/NAT server (masquerading server) accessible or to allow users behind such solutions to transfer files to and from the outside of the LAN.
This commit is contained in:
parent
75a77df5ff
commit
2b4f1fcc01
6 changed files with 85 additions and 0 deletions
5
net/jftpgw/DESCR
Normal file
5
net/jftpgw/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
jftpgw is an FTP proxy/gateway that uses the FTP protocol (unlike
|
||||
those FTP proxies that fetch an FTP file but work as an http proxy).
|
||||
You can use it to make servers behind a firewall/NAT server
|
||||
(masquerading server) accessible or to allow users behind such
|
||||
solutions to transfer files to and from the outside of the LAN.
|
28
net/jftpgw/Makefile
Normal file
28
net/jftpgw/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/02/23 01:32:33 xtraeme Exp $
|
||||
|
||||
DISTNAME= jftpgw-0.13.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.mcknight.de/jftpgw/
|
||||
|
||||
MAINTAINER= david@netbsd-fr.org
|
||||
HOMEPAGE= http://www.mcknight.de/jftpgw/
|
||||
COMMENT= FTP gateway/proxy
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGINSTALL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-logpath=/var/log
|
||||
CONFIGURE_ARGS+= --enable-crypt
|
||||
CONFIGURE_ARGS+= --enable-sftp
|
||||
|
||||
RCD_SCRIPTS= jftpgw
|
||||
EGDIR= ${PREFIX}/share/examples/jftpgw
|
||||
CONF_FILES= ${EGDIR}/jftpgw.conf ${PKG_SYSCONFDIR}/jftpgw.conf
|
||||
|
||||
SUBST_CLASSES+= config
|
||||
SUBST_STAGE.config= post-build
|
||||
SUBST_FILES.config= ${WRKSRC}/jftpgw.conf.sample
|
||||
SUBST_SED.config= -e "s/nobody/root/"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
net/jftpgw/PLIST
Normal file
6
net/jftpgw/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/02/23 01:32:34 xtraeme Exp $
|
||||
etc/rc.d/jftpgw
|
||||
man/man1/jftpgw.1
|
||||
sbin/jftpgw
|
||||
share/examples/jftpgw/jftpgw.conf
|
||||
@dirrm share/examples/jftpgw
|
5
net/jftpgw/distinfo
Normal file
5
net/jftpgw/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/02/23 01:32:33 xtraeme Exp $
|
||||
|
||||
SHA1 (jftpgw-0.13.4.tar.gz) = 9bc043bafc2be73b29a446429b76b58345ae55e8
|
||||
Size (jftpgw-0.13.4.tar.gz) = 255160 bytes
|
||||
SHA1 (patch-aa) = 8af643cbdd2e6c4f620cd8f7a0d51419ce7f6769
|
20
net/jftpgw/files/jftpgw.sh
Executable file
20
net/jftpgw/files/jftpgw.sh
Executable file
|
@ -0,0 +1,20 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
#
|
||||
# $NetBSD: jftpgw.sh,v 1.1.1.1 2004/02/23 01:32:34 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: jftpgw
|
||||
# REQUIRE: DAEMON LOGIN
|
||||
# KEYWORD: shutdown
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="jftpgw"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
pidfile="/var/run/${name}.pid"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.conf"
|
||||
extra_commands="reload"
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
21
net/jftpgw/patches/patch-aa
Normal file
21
net/jftpgw/patches/patch-aa
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/02/23 01:32:34 xtraeme Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-02-23 02:20:31.000000000 +0100
|
||||
+++ Makefile.in 2004-02-23 02:23:09.000000000 +0100
|
||||
@@ -528,11 +528,12 @@
|
||||
# use mkinstalldirs, not "install -d"
|
||||
# don't install a list of file. Just one file per install.
|
||||
# if you have more of them, create a subdirectory with an extra Makefile
|
||||
+examplesdir=$(datadir)/examples/jftpgw
|
||||
+
|
||||
install-data-local:
|
||||
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
|
||||
- if test -f $(DESTDIR)$(sysconfdir)/jftpgw.conf; then echo -e "\n\nMoving $(DESTDIR)$(sysconfdir)/jftpgw.conf to $(DESTDIR)$(sysconfdir)/jftpgw.conf.old\n\n"; mv $(DESTDIR)$(sysconfdir)/jftpgw.conf $(DESTDIR)$(sysconfdir)/jftpgw.conf.old; fi
|
||||
- $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(sysconfdir)/jftpgw.conf
|
||||
- $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(sysconfdir)/jftpgw.conf.sample
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(examplesdir)
|
||||
+ if test -f $(DESTDIR)$(sysconfdir)/jftpgw.conf; then echo -e "\n\nMoving $(DESTDIR)$(examplesdir)/jftpgw.conf to $(DESTDIR)$(examplesdir)/jftpgw.conf.old\n\n"; mv $(DESTDIR)$(examplesdir)/jftpgw.conf $(DESTDIR)$(examplesdir)/jftpgw.conf.old; fi
|
||||
+ $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(examplesdir)/jftpgw.conf
|
||||
|
||||
# remove ALL you have installed in install-data-local or install-exec-local
|
||||
uninstall-local:
|
Loading…
Reference in a new issue