Add an explicit cast from streampos to size_t, GCC 3.4 follows the
standard by considering it ambigous. Override ltmain.sh with pkgsrc version to avoid linkage problem on DragonFly. The old ltmain.sh is confused by -pthread.
This commit is contained in:
parent
ddf867e458
commit
2b753b2ace
3 changed files with 19 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.34 2005/12/05 23:55:02 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.35 2005/12/07 18:59:26 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xsidplay-1.6.5.1a
|
||||
|
@ -23,6 +23,9 @@ CONFIGURE_ENV+= DISABLE_ARTSD_TEST=yes
|
|||
|
||||
INSTALLATION_DIRS= bin
|
||||
|
||||
pre-configure:
|
||||
rm ${WRKSRC}/scripts/ltmain.sh && ${LN} -s ${PREFIX}/share/libtool/ltmain.sh ${WRKSRC}/scripts/ltmain.sh
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.7 2005/10/03 20:48:42 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2005/12/07 18:59:26 joerg Exp $
|
||||
|
||||
SHA1 (xsidplay-1.6.5.1a.tgz) = 60f2262a8dd79b276272d49eff9a07277dc6c9aa
|
||||
RMD160 (xsidplay-1.6.5.1a.tgz) = 9a0529c7b76e7659feddc35c04aaf81ae2002984
|
||||
Size (xsidplay-1.6.5.1a.tgz) = 355698 bytes
|
||||
SHA1 (patch-aa) = f5a6065735aa1b925c6b9f912a85b72741b94a87
|
||||
SHA1 (patch-ab) = 188ab597250e8a444d33f0813fba157a3469872e
|
||||
|
|
13
audio/xsidplay/patches/patch-ab
Normal file
13
audio/xsidplay/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.8 2005/12/07 18:59:26 joerg Exp $
|
||||
|
||||
--- src/songlendb/File.cpp.orig 2005-12-07 16:56:52.000000000 +0000
|
||||
+++ src/songlendb/File.cpp
|
||||
@@ -126,7 +126,7 @@ bool SongLengthFile::init(const char* fi
|
||||
streampos fileLen = myIn.tellg();
|
||||
#endif
|
||||
#ifdef XSID_HAVE_NOTHROW
|
||||
- pDB = new(std::nothrow) char[fileLen+1L];
|
||||
+ pDB = new(std::nothrow) char[(size_t)fileLen+1L];
|
||||
#else
|
||||
pDB = new char[fileLen+1L];
|
||||
#endif
|
Loading…
Reference in a new issue