openal-soft: updated to 1.21.1

openal-soft-1.21.1:

Improved alext.h's detection of standard types.

Improved slightly the local source position when the listener and source
are near each other.

Improved click/pop prevention for sounds that stop prematurely.

Fixed compilation for Windows ARM targets with MSVC.

Fixed ARM NEON detection on Windows.

Fixed CoreAudio capture when the requested sample rate doesn't match the
system configuration.

Fixed OpenSL capture desyncing from the internal capture buffer.

Fixed sources missing a batch update when applied after quickly restarting
the source.

Fixed missing source stop events when stopping a paused source.

Added capture support to the experimental Oboe backend.


openal-soft-1.21.0:

Updated library codebase to C++14.

Implemented the AL_SOFT_effect_target extension.

Implemented the AL_SOFT_events extension.

Implemented the ALC_SOFT_loopback_bformat extension.

Improved memory use for mixing voices.

Improved detection of NEON capabilities.

Improved handling of PulseAudio devices that lack manual start control.

Improved mixing performance with PulseAudio.

Improved high-frequency scaling quality for the HRTF B-Format decoder.

Improved makemhr's HRIR delay calculation.

Improved WASAPI capture of mono formats with multichannel input.

Reimplemented the modulation stage for reverb.

Enabled real-time mixing priority by default, for backends that use the
setting. It can still be disabled in the config file.

Enabled dual-band processing for the built-in quad and 7.1 output decoders.

Fixed a potential crash when deleting an effect slot immediately after the
last source using it stops.

Fixed building with the static runtime on MSVC.

Fixed using source stereo angles outside of -pi...+pi.

Fixed the buffer processed event count for sources that start with empty
buffers.

Fixed trying to open an unopenable WASAPI device causing all devices to
stop working.

Fixed stale devices when re-enumerating WASAPI devices.

Fixed using unicode paths with the log file on Windows.

Fixed DirectSound capture reporting bad sample counts or erroring when
reading samples.

Added an in-progress extension for a callback-driven buffer type.

Added an in-progress extension for higher-order B-Format buffers.

Added an in-progress extension for convolution reverb.

Added an experimental Oboe backend for Android playback. This requires the
Oboe sources at build time, so that it's built as a static library included
in libopenal.

Added an option for auto-connecting JACK ports.

Added greater-than-stereo support to the SoundIO backend.

Modified the mixer to be fully asynchronous with the external API, and
should now be real-time safe. Although alcRenderSamplesSOFT is not due to
locking to check the device handle validity.

Modified the UHJ encoder to use an all-pass FIR filter that's less harmful
to non-filtered signal phase.

Converted examples from SDL_sound to libsndfile. To avoid issues when
combining SDL2 and SDL_sound.

Worked around a 32-bit GCC/MinGW bug with TLS destructors. See:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=83562

Reduced the maximum number of source sends from 16 to 6.

Removed the QSA backend. It's been broken for who knows how long.

Got rid of the compile-time native-tools targets, using cmake and global
initialization instead. This should make cross-compiling less troublesome.
This commit is contained in:
adam 2021-03-21 20:05:17 +00:00
parent 94d9e5b1d3
commit 2b9d13c03c
4 changed files with 38 additions and 21 deletions

View file

@ -1,25 +1,23 @@
# $NetBSD: Makefile,v 1.18 2021/02/07 06:30:14 ryoon Exp $
# $NetBSD: Makefile,v 1.19 2021/03/21 20:05:17 adam Exp $
DISTNAME= openal-soft-1.20.1
PKGREVISION= 5
DISTNAME= openal-soft-1.21.1
CATEGORIES= audio
MASTER_SITES= https://kcat.strangesoft.net/openal-releases/
MASTER_SITES= https://openal-soft.org/openal-releases/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://kcat.strangesoft.net/openal.html
HOMEPAGE= https://openal-soft.org/
COMMENT= Software implementation of the OpenAL 3D audio API
LICENSE= gnu-lgpl-v2
USE_CMAKE= yes
USE_LANGUAGES= c c++11
USE_LANGUAGES= c c++14
USE_TOOLS+= pkg-config gmake
# https://github.com/kcat/openal-soft/issues/347
GCC_REQD+= 5
MAKE_JOBS_SAFE= no
PKGCONFIG_OVERRIDE+= openal.pc.in
PKG_SYSCONFSUBDIR= openal
CMAKE_ARGS+= -DALSOFT_EXAMPLES=OFF
@ -34,8 +32,8 @@ CONF_FILES+= ${PREFIX}/share/openal/alsoftrc.sample ${PKG_SYSCONFDIR}/alsoft.con
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS" || ${OPSYS} == "NetBSD"
CMAKE_ARGS+= -DALSOFT_BACKEND_SOLARIS=ON
CMAKE_ARGS+= -DALSOFT_REQUIRE_SOLARIS=ON
CMAKE_ARGS+= -DALSOFT_BACKEND_SOLARIS=ON
CMAKE_ARGS+= -DALSOFT_REQUIRE_SOLARIS=ON
.endif
.include "../../mk/oss.buildlink3.mk"
@ -50,10 +48,11 @@ SUBST_FILES.oss= alc/backends/oss.cpp
SUBST_SED.oss= -e 's,/dev/dsp,${DEVOSSAUDIO},'
.endif
PKGCONFIG_OVERRIDE+= openal.pc.in
.include "options.mk"
post-install:
${RM} ${DESTDIR}${PREFIX}/include/AL/al.h.orig
.include "../../audio/libmysofa/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

View file

@ -1,5 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2020/01/25 14:58:13 nia Exp $
bin/altonegen
@comment $NetBSD: PLIST,v 1.6 2021/03/21 20:05:17 adam Exp $
bin/makemhr
bin/openal-info
include/AL/al.h
@ -11,8 +10,8 @@ include/AL/efx.h
lib/cmake/OpenAL/OpenALConfig-relwithdebinfo.cmake
lib/cmake/OpenAL/OpenALConfig.cmake
lib/libopenal.so
lib/libopenal.so.1
lib/libopenal.so.${PKGVERSION}
lib/libopenal.so.1
lib/pkgconfig/openal.pc
share/openal/alsoftrc.sample
share/openal/hrtf/Default HRTF.mhr

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.7 2020/04/09 13:35:21 jperkin Exp $
$NetBSD: distinfo,v 1.8 2021/03/21 20:05:17 adam Exp $
SHA1 (openal-soft-1.20.1.tar.bz2) = 77c3d2736adf4058ec3e19f26e51fac9b5412ac1
RMD160 (openal-soft-1.20.1.tar.bz2) = dd53b9aac8710db7344f16fb49c93f9f73af8b6d
SHA512 (openal-soft-1.20.1.tar.bz2) = a8a03a2162b5d35e66adc079e81d7fa075b83a3ee1cec3412cb40f7789263ed8bd005beefb7ef995f464dfa43aac22ea0f547b752dfc7533ed9120a95fb92513
Size (openal-soft-1.20.1.tar.bz2) = 512971 bytes
SHA1 (openal-soft-1.21.1.tar.bz2) = f39b81a9ce22419e106259cf424405291520b8f3
RMD160 (openal-soft-1.21.1.tar.bz2) = b5b96f0e36d4a29303d62a484d7c6c1fe0798de6
SHA512 (openal-soft-1.21.1.tar.bz2) = 420eec18149a9b784daaabe8a2865de3b87d5550cf2e8e06569464d0b5ba6e51d904c18f1461af08676bf8c8b76ef270e860008d79545a5f85131299e89bffd4
Size (openal-soft-1.21.1.tar.bz2) = 524787 bytes
SHA1 (patch-CMakeLists.txt) = 5469748347d548838b8e4650e1ecbabacae1f30a
SHA1 (patch-alc_alconfig.cpp) = 0539016dadf1827e5a86700c2db5a96479a8b70d
SHA1 (patch-alc_backends_alsa.cpp) = 3ee7f86e544d9b33ccbe9422eb87b9540623053a
SHA1 (patch-alc_backends_solaris.cpp) = 62e7a5bddb5c4ed7f7e4c4889b2234dd778be960

View file

@ -0,0 +1,18 @@
$NetBSD: patch-CMakeLists.txt,v 1.3 2021/03/21 20:05:17 adam Exp $
Fix building.
--- CMakeLists.txt.orig 2021-03-21 19:49:33.000000000 +0000
+++ CMakeLists.txt
@@ -1136,9 +1136,9 @@ if(ALSOFT_EMBED_HRTF_DATA)
add_custom_command(OUTPUT "${outfile}"
COMMAND ${CMAKE_COMMAND} -D "INPUT_FILE=${infile}" -D "OUTPUT_FILE=${outfile}"
- -D "VARIABLE_NAME=${VARNAME}" -P "${CMAKE_MODULE_PATH}/bin2h.script.cmake"
+ -D "VARIABLE_NAME=${VARNAME}" -P "${OpenAL_SOURCE_DIR}/cmake/bin2h.script.cmake"
WORKING_DIRECTORY "${OpenAL_SOURCE_DIR}"
- DEPENDS "${infile}" "${CMAKE_MODULE_PATH}/bin2h.script.cmake"
+ DEPENDS "${infile}" "${OpenAL_SOURCE_DIR}/cmake/bin2h.script.cmake"
VERBATIM
)
set(ALC_OBJS ${ALC_OBJS} "${outfile}")