Updated to 2.0.0

This commit is contained in:
xtraeme 2004-01-08 20:49:39 +00:00
parent 576f38585f
commit 2c42d083d1
7 changed files with 151 additions and 140 deletions

View file

@ -1,4 +1,6 @@
Icecast is an Internet based broadcasting system based on the Mpeg
Layer III streaming technology. It is, however, not limited to
streaming mp3 files. It was originally inspired by Nullsoft's
Shoutcast and also mp3serv by Scott Man ley.
Icecast is a streaming media server which currently supports Ogg
Vorbis and MP3 audio streams. It can be used to create an Internet
radio station or a privately running jukebox and many things in
between. It is very versatile in that new formats can be added
relatively easily and supports open standards for commuincation and
interaction.

View file

@ -1,49 +1,65 @@
# $NetBSD: Makefile,v 1.17 2004/01/08 19:58:34 jmmv Exp $
# $NetBSD: Makefile,v 1.18 2004/01/08 20:49:39 xtraeme Exp $
#
DISTNAME= icecast-1.3.12
PKGREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.icecast.org/releases/
DISTNAME= icecast-2.0.0
CATEGORIES= audio
MASTER_SITES= http://www.icecast.org/files/
MAINTAINER= hubertf@NetBSD.org
HOMEPAGE= http://www.icecast.org/
COMMENT= Internet broadcasting system using Mpeg Layer III streaming
MAINTAINER= pancake@phreaker.net
HOMEPAGE= http://www.icecast.org/
COMMENT= Live streaming audio server
USE_BUILDLINK2= # defined
GNU_CONFIGURE= # defined
USE_BUILDLINK2= yes
USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
USE_PKGINSTALL= yes
GNU_CONFIGURE= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
BUILD_DEFS+= ICECAST_CHROOTDIR
RCD_SCRIPTS= icecast
PKG_SYSCONFSUBDIR= icecast
RCD_SCRIPTS= icecast
CONFIGURE_ARGS+= --with-readline \
--with-libwrap \
--with-python \
--sysconfdir=${PKG_SYSCONFDIR}
CPPFLAGS+= -I${BUILDLINK_PREFIX.readline}/include/readline
CPPFLAGS+= ${BUILDLINK_CPPFLAGS.${PYPACKAGE}}
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LDFLAGS}
LDFLAGS+= ${BUILDLINK_LDFLAGS.${PYPACKAGE}}
LIBS+= -lutil
PTHREAD_OPTS+= native
ICECAST_LOGDIR?= ${ICECAST_CHROOTDIR}/log
ICECAST_USER?= icecast
ICECAST_GROUP?= icecast
PKG_GROUPS= ${ICECAST_GROUP}
PKG_USERS= ${ICECAST_USER}:${ICECAST_GROUP}::Icecast2\\ user
EGDIR= ${PREFIX}/share/examples/icecast
EGFILES= groups.aut mounts.aut users.aut icecast.conf
CONF_FILES= ${EGDIR}/icecast.xml ${PKG_SYSCONFDIR}/icecast.xml
.for f in ${EGFILES}
CONF_FILES+= ${EGDIR}/${f}.dist ${PKG_SYSCONFDIR}/${f}
.for D in ${ICECAST_CHROOTDIR} ${ICECAST_LOGDIR}
OWN_DIRS_PERMS+= ${D} ${ICECAST_USER} ${ICECAST_GROUP} 770
.endfor
.undef f
.undef D
post-extract:
@${MV} ${WRKSRC}/conf/icecast.xml.in ${WRKSRC}/conf/icecast.fixme
post-install:
@( \
${SED} \
-e "s,@BASEDIR@,${ICECAST_CHROOTDIR},g" \
-e "s,@LOGDIR@,log/,g" \
-e "s,@WEBROOT@,${PREFIX}/share/icecast/web,g" \
-e "s,@ADMINROOT@,${PREFIX}/share/icecast/admin,g" \
-e "s,@PIDDIR@,${ICECAST_CHROOTDIR},g" \
-e "s,@ICECAST_USER@,${ICECAST_USER},g" \
-e "s,@ICECAST_GROUP@,${ICECAST_GROUP},g" \
${WRKSRC}/conf/icecast.fixme > ${WRKSRC}/conf/icecast.xml; \
${INSTALL_DATA_DIR} ${EGDIR}; \
${INSTALL_DATA} ${WRKSRC}/conf/icecast.xml ${EGDIR} \
)
.include "../../audio/libvorbis/buildlink2.mk"
.include "../../converters/libiconv/buildlink2.mk"
.include "../../textproc/libxslt/buildlink2.mk"
.include "../../www/curl/buildlink2.mk"
.include "../../devel/readline/buildlink2.mk"
.include "../../lang/python/application.mk"
.include "../../security/tcp_wrappers/buildlink2.mk"
.include "../../mk/pthread.buildlink2.mk"
.if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "none")
. include "../../devel/unproven-pthreads/buildlink2.mk"
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,32 +1,33 @@
@comment $NetBSD: PLIST,v 1.5 2003/09/30 15:00:17 jmmv Exp $
@comment $NetBSD: PLIST,v 1.6 2004/01/08 20:49:39 xtraeme Exp $
bin/icecast
etc/rc.d/icecast
share/doc/icecast/manual.html
share/examples/icecast/groups.aut.dist
share/examples/icecast/icecast.conf.dist
share/examples/icecast/mounts.aut.dist
share/examples/icecast/users.aut.dist
share/icecast/templates/306.html
share/icecast/templates/400.html
share/icecast/templates/403.html
share/icecast/templates/404.html
share/icecast/templates/504.html
share/icecast/templates/admin.html
share/icecast/templates/admin_change.html
share/icecast/templates/admin_describe.html
share/icecast/templates/alias_add.html
share/icecast/templates/alias_del.html
share/icecast/templates/bodytag.html
share/icecast/templates/footer.html
share/icecast/templates/header.html
share/icecast/templates/info.html
share/icecast/templates/list_directory.html
share/icecast/templates/manual.html
share/icecast/templates/mountlist.html
share/icecast/templates/statistics.html
@dirrm share/icecast/templates
@exec ${MKDIR} %D/share/icecast/static
@dirrm share/icecast/static
share/doc/icecast/AUTHORS
share/doc/icecast/COPYING
share/doc/icecast/NEWS
share/doc/icecast/README
share/doc/icecast/TODO
share/doc/icecast/icecast2_admin.html
share/doc/icecast/icecast2_basicsetup.html
share/doc/icecast/icecast2_config_file.html
share/doc/icecast/icecast2_faq.html
share/doc/icecast/icecast2_glossary.html
share/doc/icecast/icecast2_introduction.html
share/doc/icecast/icecast2_relay.html
share/doc/icecast/icecast2_stats.html
share/doc/icecast/icecast2_win32.html
share/doc/icecast/icecast2_yp.html
share/doc/icecast/index.html
share/examples/icecast/icecast.xml
share/icecast/admin/listclients.xsl
share/icecast/admin/listmounts.xsl
share/icecast/admin/moveclients.xsl
share/icecast/admin/response.xsl
share/icecast/admin/stats.xsl
share/icecast/web/status.xsl
share/icecast/web/status2.xsl
@dirrm share/icecast/web
@dirrm share/icecast/doc
@dirrm share/icecast/admin
@dirrm share/icecast
@dirrm share/examples/icecast
@dirrm share/doc/icecast
@dirrm share/examples/icecast

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.8 2003/09/30 14:57:25 jmmv Exp $
$NetBSD: distinfo,v 1.9 2004/01/08 20:49:39 xtraeme Exp $
SHA1 (icecast-1.3.12.tar.gz) = bacb760390453718de536b85979ff3a9a73c7710
Size (icecast-1.3.12.tar.gz) = 269822 bytes
SHA1 (patch-aa) = 169202f563e4e2812d8d532264dcdb4f9ffc8df2
SHA1 (patch-ab) = de33a89e6078721a7e9c3a09515846752e76680e
SHA1 (icecast-2.0.0.tar.gz) = 76f41f807bdff5dfb50d5b67075fc401de7e270a
Size (icecast-2.0.0.tar.gz) = 684624 bytes
SHA1 (patch-aa) = fa92a4a704a3f471a0669c9933b36a3586425dc5
SHA1 (patch-ab) = 39cf0ed1e9da8c7d90fa192731307817e91496c9

View file

@ -1,29 +1,18 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: icecast.sh,v 1.2 2003/09/30 10:36:46 xtraeme Exp $
# $NetBSD: icecast.sh,v 1.3 2004/01/08 20:49:39 xtraeme Exp $
#
# PROVIDE: icecast
# REQUIRE: DAEMON LOGIN network
name="icecast"
command="@PREFIX@/bin/${name}"
mainconfigfile="@PKG_SYSCONFDIR@/${name}.conf"
icecast_flags="-c ${mainconfigfile} -d @PKG_SYSCONFDIR@ -b"
sig_stop="KILL"
# REQUIRE: DAEMON LOGIN
. /etc/rc.subr
pidfile="/var/run/${name}.pid"
required_files="${mainconfigfile}"
name="icecast"
rcvar=$name
command="@PREFIX@/bin/${name}"
command_args="-b -c @PKG_SYSCONFDIR@/$name.xml 1>2& >/dev/null"
required_files="@PKG_SYSCONFDIR@/$name.xml"
load_rc_config $name
run_rc_command "$1"
if [ "$1" != "stop" ]; then
echo $(check_process $command) > $pidfile
fi

View file

@ -1,20 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/11/21 06:02:28 hubertf Exp $
$NetBSD: patch-aa,v 1.2 2004/01/08 20:49:39 xtraeme Exp $
--- src/definitions.h.orig Tue Nov 21 02:26:07 2000
+++ src/definitions.h
@@ -31,6 +31,7 @@
# define __USE_BSD
#endif
+#ifndef __NetBSD__
#ifndef __EXTENSIONS__
# define __EXTENSIONS__
#endif
@@ -62,6 +63,7 @@
# endif
#endif
+#endif /* __NetBSD__ */
--- Makefile.in.orig 2004-01-08 18:59:21.000000000 +0100
+++ Makefile.in 2004-01-08 18:59:45.000000000 +0100
@@ -112,7 +112,7 @@
AUTOMAKE_OPTIONS = 1.6 foreign dist-zip
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src conf debian doc web admin win32
+SUBDIRS = src doc web admin
EXTRA_DIST = HACKING m4/acx_pthread.m4 m4/ogg.m4 m4/vorbis.m4 \
m4/xiph_compiler.m4 m4/xiph_curl.m4 m4/xiph_net.m4 \

View file

@ -1,36 +1,46 @@
$NetBSD: patch-ab,v 1.4 2003/09/30 14:57:25 jmmv Exp $
$NetBSD: patch-ab,v 1.5 2004/01/08 20:49:39 xtraeme Exp $
--- configure.orig 2002-04-11 00:50:20.000000000 +0200
+++ configure
@@ -876,16 +876,16 @@ if test "x$enable_fsstd" = "xyes"; then
else
ICECAST_BINDIR=${prefix}/bin
ICECAST_SBINDIR=${prefix}/bin
- ICECAST_ETCDIR=conf
- ICECAST_ETCDIR_INST=${prefix}/conf
+ ICECAST_ETCDIR=${sysconfdir}
+ ICECAST_ETCDIR_INST=${prefix}/share/examples/icecast
ICECAST_SHAREDIR=${prefix}
ICECAST_LOGDIR=logs
- ICECAST_LOGDIR_INST=${prefix}/logs
+ ICECAST_LOGDIR_INST=/var/log/icecast
ICECAST_TEMPLATEDIR=templates
- ICECAST_TEMPLATEDIR_INST=${prefix}/templates
+ ICECAST_TEMPLATEDIR_INST=${prefix}/share/icecast/templates
ICECAST_STATICDIR=static
- ICECAST_STATICDIR_INST=${prefix}/static
- ICECAST_DOCDIR=${prefix}/doc
+ ICECAST_STATICDIR_INST=${prefix}/share/icecast/static
+ ICECAST_DOCDIR=${prefix}/share/doc/icecast
USE_FSSTD=no
fi
--- conf/icecast.fixme.orig 2004-01-08 19:10:14.000000000 +0100
+++ conf/icecast.fixme 2004-01-08 19:14:15.000000000 +0100
@@ -82,14 +82,15 @@
@@ -1540,7 +1540,7 @@ EOF
<paths>
<!-- basedir is only used if chroot is enabled -->
- <basedir>@pkgdatadir@</basedir>
+ <basedir>@BASEDIR@</basedir>
echo "$ac_t""BSD/OS" 1>&6
;;
- *BSD*)
+ unused)
__SOMEBSD__=yes
cat >> confdefs.h <<\EOF
#define __SOMEBSD__ 1
<!-- Note that if <chroot> is turned on below, these paths must both
be relative to the new root, not the original root -->
- <logdir>@localstatedir@/log/@PACKAGE@</logdir>
- <webroot>@pkgdatadir@/web</webroot>
- <adminroot>@pkgdatadir@/admin</adminroot>
- <!-- <pidfile>@pkgdatadir@/icecast.pid</pidfile> -->
+
+ <logdir>@LOGDIR@/</logdir>
+ <webroot>@WEBROOT@</webroot>
+ <adminroot>@ADMINROOT@</adminroot>
+ <pidfile>@PIDDIR@/icecast.pid</pidfile>
<!-- Aliases: treat requests for 'source' path as being for 'dest' path
May be made specific to a port or bound address using the "port"
@@ -103,16 +104,14 @@
<logging>
<accesslog>access.log</accesslog>
<errorlog>error.log</errorlog>
- <loglevel>4</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
+ <loglevel>2</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
</logging>
<security>
- <chroot>0</chroot>
- <!--
+ <chroot>1</chroot>
<changeowner>
- <user>nobody</user>
- <group>nogroup</group>
+ <user>@ICECAST_USER@</user>
+ <group>@ICECAST_GROUP@</group>
</changeowner>
- -->
</security>
</icecast>