Initial import of Acrobat Reader 5 into the NetBSD packages collection.
Acrobat Reader is part of the Adobe Acrobat family of software, which lets you view, distribute, and print documents in Portable Document Format (PDF)--regardless of the computer, operating system, fonts, or application used to create the original file. PDF files retain all the formatting, fonts, and graphics of the original document, and virtually any PostScript(TM) document can be converted into a PDF file. Tested on NetBSD/i386 and Solaris/sparc. Problems were found on NetBSD/sparc, so this is marked ONLY_FOR_PLATFORM *-*-i386 and SunOS-*-sparc for now.
This commit is contained in:
parent
1cb4641e1a
commit
2c4711e93e
8 changed files with 262 additions and 0 deletions
6
print/acroread5/DESCR
Normal file
6
print/acroread5/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Acrobat Reader is part of the Adobe Acrobat family of software, which lets
|
||||
you view, distribute, and print documents in Portable Document Format
|
||||
(PDF)--regardless of the computer, operating system, fonts, or application
|
||||
used to create the original file. PDF files retain all the formatting,
|
||||
fonts, and graphics of the original document, and virtually any
|
||||
PostScript(TM) document can be converted into a PDF file.
|
76
print/acroread5/Makefile
Normal file
76
print/acroread5/Makefile
Normal file
|
@ -0,0 +1,76 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/08/01 11:59:09 grant Exp $
|
||||
|
||||
PKGNAME= acroread-5.06
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://ftp-pac.adobe.com/pub/adobe/acrobatreader/unix/5.x/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.adobe.com/prodindex/acrobat/readstep.html
|
||||
COMMENT= View, distribute and print PDF documents
|
||||
|
||||
RESTRICTED= "Original installer required to redistribute."
|
||||
NO_SRC_ON_CDROM= ${RESTRICTED}
|
||||
NO_BIN_ON_CDROM= ${RESTRICTED}
|
||||
NO_BIN_ON_FTP= ${RESTRICTED}
|
||||
NO_SRC_ON_FTP= ${RESTRICTED}
|
||||
LICENSE= adobe-acrobat-license
|
||||
|
||||
CHECK_SHLIBS= NO
|
||||
NO_BUILD= YES
|
||||
SHLIB_HANDLING= NO
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
ONLY_FOR_PLATFORM= *-*-i386 SunOS-*-sparc
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
. if (${MACHINE_ARCH} == "i386")
|
||||
DEPENDS= suse_x11>=6.1:../../emulators/${SUSE_DIR_PREFIX}_x11
|
||||
DISTNAME= linux-506
|
||||
PLATFORM= intellinux
|
||||
. elif (${MACHINE_ARCH} == "sparc")
|
||||
. if !exists(/emul/svr4/usr/lib/ld.so)
|
||||
IGNORE= '${PKGNAME} requires Solaris libraries - see compat_svr4(8)'
|
||||
. endif
|
||||
DISTNAME= solaris-506
|
||||
PLATFORM= sparcsolaris
|
||||
. else
|
||||
DISTNAME= ${PKGNAME}
|
||||
PLATFORM= unknown
|
||||
. endif
|
||||
.elif ${OPSYS} == "SunOS"
|
||||
DISTNAME= solaris-506
|
||||
PLATFORM= sparcsolaris
|
||||
.endif
|
||||
|
||||
PLIST_SUBST+= PLATFORM=${PLATFORM}
|
||||
|
||||
PLIST_SRC= ${PKGDIR}/PLIST.pre
|
||||
.if ${MACHINE_ARCH} == "sparc"
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.${MACHINE_ARCH}
|
||||
.endif
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.post
|
||||
|
||||
NS_PLUGINS_DIR= ${PREFIX}/lib/netscape/plugins
|
||||
|
||||
BIN_PATCH= ${PATCH} --quiet ${_PATCH_BACKUP_ARG} .orig
|
||||
|
||||
do-install:
|
||||
@${INSTALL_DATA_DIR} ${PREFIX}/Acrobat5
|
||||
@( ${ECHO} accept ) | PAGER=${CAT} ReadInstallDir=${PREFIX}/Acrobat5 ${WRKSRC}/INSTALL
|
||||
|
||||
post-install:
|
||||
@cd ${PREFIX}/Acrobat5/bin && \
|
||||
${BIN_PATCH} <${FILESDIR}/acroread.diff && \
|
||||
${INSTALL_SCRIPT} ${PREFIX}/Acrobat5/bin/acroread \
|
||||
${PREFIX}/bin/acroread5 && ${RM} -f acroread.orig
|
||||
${CHMOD} +x ${PREFIX}/bin/acroread5
|
||||
${INSTALL_DATA_DIR} ${NS_PLUGINS_DIR}
|
||||
${INSTALL_DATA} ${PREFIX}/Acrobat5/Browsers/${PLATFORM}/nppdf.so \
|
||||
${NS_PLUGINS_DIR}
|
||||
@${ECHO_MSG} "Be sure to read the license agreement in"
|
||||
@${ECHO_MSG} "${PREFIX}/Acrobat5/Reader/license.txt"
|
||||
|
||||
.include "../../emulators/suse_linux/Makefile.application"
|
23
print/acroread5/PLIST.post
Normal file
23
print/acroread5/PLIST.post
Normal file
|
@ -0,0 +1,23 @@
|
|||
@comment $NetBSD: PLIST.post,v 1.1.1.1 2002/08/01 11:59:08 grant Exp $
|
||||
@exec ${MKDIR} %D/lib/netscape/plugins
|
||||
@unexec ${RMDIR} %D/lib/netscape/plugins 2>/dev/null || true
|
||||
@unexec ${RMDIR} %D/lib/netscape 2>/dev/null || true
|
||||
@exec ln -sf ../../Resource/Font %D/Acrobat5/Reader/${PLATFORM}/fonts
|
||||
@unexec ${RM} -f %D/Acrobat5/Reader/${PLATFORM}/fonts
|
||||
@exec ln -sf ../res %D/Acrobat5/Reader/${PLATFORM}/res
|
||||
@unexec ${RM} -f %D/Acrobat5/Reader/${PLATFORM}/res
|
||||
@dirrm Acrobat5/Browsers/${PLATFORM}
|
||||
@dirrm Acrobat5/Browsers
|
||||
@dirrm Acrobat5/Reader/res
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/plug_ins/JavaScripts
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/plug_ins
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/lib
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/bin
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/app-defaults
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}
|
||||
@dirrm Acrobat5/Reader/help
|
||||
@dirrm Acrobat5/Reader
|
||||
@dirrm Acrobat5/Resource/Font
|
||||
@dirrm Acrobat5/Resource
|
||||
@dirrm Acrobat5/bin
|
||||
@dirrm Acrobat5
|
53
print/acroread5/PLIST.pre
Normal file
53
print/acroread5/PLIST.pre
Normal file
|
@ -0,0 +1,53 @@
|
|||
@comment $NetBSD: PLIST.pre,v 1.1.1.1 2002/08/01 11:59:09 grant Exp $
|
||||
Acrobat5/Browsers/netscape
|
||||
Acrobat5/Browsers/${PLATFORM}/nppdf.so
|
||||
Acrobat5/Reader/AcroVersion
|
||||
Acrobat5/Reader/MapTypes.pdf
|
||||
Acrobat5/Reader/help/acrobat.pdf
|
||||
Acrobat5/Reader/help/reader.pdf
|
||||
Acrobat5/Reader/license.txt
|
||||
Acrobat5/Reader/res/ENUtxt.pdf
|
||||
Acrobat5/Reader/res/splashScreen11R.xbm
|
||||
Acrobat5/Reader/res/splashScreen18R.xpm
|
||||
Acrobat5/Reader/${PLATFORM}/app-defaults/AcroRead
|
||||
Acrobat5/Reader/${PLATFORM}/bin/acroread
|
||||
Acrobat5/Reader/${PLATFORM}/lib/XKeysymDB
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libACE.so
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libACE.so.2.02
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libBIB.so
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libBIB.so.1.1
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libAGM.so
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libAGM.so.4.08
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libCoolType.so
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libCoolType.so.4.10
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libOPP.so
|
||||
Acrobat5/Reader/${PLATFORM}/lib/libOPP.so.1.02
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/AcroForm.api
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/EScript.api
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/Highlight.api
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/JavaScripts/AFStrENU.js
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/JavaScripts/AForm.js
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/ewh.api
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/wwwlink.api
|
||||
Acrobat5/Resource/Font/AdobeSansMM
|
||||
Acrobat5/Resource/Font/AdobeSansMM.MMM
|
||||
Acrobat5/Resource/Font/AdobeSerifMM
|
||||
Acrobat5/Resource/Font/AdobeSerifMM.MMM
|
||||
Acrobat5/Resource/Font/Arial
|
||||
Acrobat5/Resource/Font/Arial-Bold
|
||||
Acrobat5/Resource/Font/Arial-BoldItalic
|
||||
Acrobat5/Resource/Font/Arial-Italic
|
||||
Acrobat5/Resource/Font/Courier
|
||||
Acrobat5/Resource/Font/Courier-Bold
|
||||
Acrobat5/Resource/Font/Courier-BoldOblique
|
||||
Acrobat5/Resource/Font/Courier-Oblique
|
||||
Acrobat5/Resource/Font/Fonts14.upr
|
||||
Acrobat5/Resource/Font/Symbol
|
||||
Acrobat5/Resource/Font/TimesNewRoman
|
||||
Acrobat5/Resource/Font/TimesNewRoman-Bold
|
||||
Acrobat5/Resource/Font/TimesNewRoman-BoldItalic
|
||||
Acrobat5/Resource/Font/TimesNewRoman-Italic
|
||||
Acrobat5/Resource/Font/ZapfDingbats
|
||||
Acrobat5/Resource/LICFONT.TXT
|
||||
Acrobat5/bin/acroread
|
||||
bin/acroread5
|
21
print/acroread5/PLIST.sparc
Normal file
21
print/acroread5/PLIST.sparc
Normal file
|
@ -0,0 +1,21 @@
|
|||
@comment $NetBSD: PLIST.sparc,v 1.1.1.1 2002/08/01 11:59:09 grant Exp $
|
||||
lib/netscape/plugins/nppdf.so
|
||||
Acrobat5/Reader/help/search.pdf
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/search.api
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/acrosrch.uid
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/vdk10.cmp
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/vdk10.lic
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/vdk10.std
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/vdk10.syx
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/language/vdk10.lng
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/language/vdk10.rsd
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/language/vdk10.rst
|
||||
Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/language/vdk10.syd
|
||||
Acrobat5/desktop/olwm/acroread.cetable
|
||||
Acrobat5/desktop/olwm/acroread.deskinstall
|
||||
Acrobat5/desktop/olwm/acroread.prog.icon
|
||||
Acrobat5/desktop/olwm/pdf.icon
|
||||
@dirrm Acrobat5/desktop/olwm
|
||||
@dirrm Acrobat5/desktop
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome/language
|
||||
@dirrm Acrobat5/Reader/${PLATFORM}/plug_ins/vdkHome
|
7
print/acroread5/distinfo
Normal file
7
print/acroread5/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/08/01 11:59:09 grant Exp $
|
||||
|
||||
SHA1 (linux-506.tar.gz) = 6629b759a9e1565bc431edece24847dcb25ed6c6
|
||||
Size (linux-506.tar.gz) = 9281557 bytes
|
||||
SHA1 (solaris-506.tar.gz) = 8b799014285328daf0919287cbe34b00ce2b086b
|
||||
Size (solaris-506.tar.gz) = 9939810 bytes
|
||||
SHA1 (patch-aa) = 635cfe39ca34ebc83cdb4633282f2fb667c452c3
|
24
print/acroread5/files/acroread.diff
Normal file
24
print/acroread5/files/acroread.diff
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: acroread.diff,v 1.1.1.1 2002/08/01 11:59:10 grant Exp $
|
||||
|
||||
--- acroread.orig Tue Jul 2 08:08:00 2002
|
||||
+++ acroread Thu Aug 1 21:50:23 2002
|
||||
@@ -191,6 +191,19 @@
|
||||
ACRO_CONFIG=intellinux
|
||||
export ACRO_CONFIG
|
||||
;;
|
||||
+ NetBSD)
|
||||
+ machine_type=`uname -p`
|
||||
+ case "$machine_type" in
|
||||
+ i386)
|
||||
+ ACRO_CONFIG=intellinux
|
||||
+ export ACRO_CONFIG
|
||||
+ ;;
|
||||
+ sparc)
|
||||
+ ACRO_CONFIG=sparcsolaris
|
||||
+ export ACRO_CONFIG
|
||||
+ ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
if [ -z "$ACRO_CONFIG" ] ; then
|
52
print/acroread5/patches/patch-aa
Normal file
52
print/acroread5/patches/patch-aa
Normal file
|
@ -0,0 +1,52 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/08/01 11:59:10 grant Exp $
|
||||
|
||||
--- INSTALL.orig Tue Jul 2 08:09:57 2002
|
||||
+++ INSTALL
|
||||
@@ -82,7 +82,7 @@ OutputLicense ()
|
||||
fi
|
||||
|
||||
TypeCheck $PAGER
|
||||
- if [ $? -ne 0 ] || [ -z "$PAGER" ] ; then
|
||||
+ if [ $? -eq 0 ] || [ -z "$PAGER" ] ; then
|
||||
command=cat
|
||||
TypeCheck pg
|
||||
if [ $? -eq 0 ] ; then
|
||||
@@ -135,6 +135,8 @@ PrintRequiredFree()
|
||||
if [ "$i" -a -f "$i" ] ; then
|
||||
if [ `uname -s` = "Linux" ] ; then
|
||||
size=`ls -lLn "$i" | ( read perm links owner group size date ; echo $size )`
|
||||
+ elif [ `uname -s|sed -e 's|.*\(...\)|\\1|'` = "BSD" ] ; then
|
||||
+ size=`ls -lL "$i" | ( read perm links owner group size date ; echo $size )`
|
||||
else
|
||||
size=`ls -lLon "$i" | ( read perm links owner size date ; echo $size )`
|
||||
fi
|
||||
@@ -276,6 +278,8 @@ GetInstallDirectory ()
|
||||
AIX)
|
||||
defdir="/usr/lpp/Acrobat5"
|
||||
;;
|
||||
+ NetBSD)
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
while [ -z "$InstallDir" ] ; do
|
||||
@@ -528,6 +532,20 @@ case "$OSname" in
|
||||
ReadDefaultNum="$ReadIntelLinuxNum"
|
||||
DefaultName="Intel/Linux"
|
||||
;;
|
||||
+ NetBSD)
|
||||
+ MachArch=`uname -p`
|
||||
+ case "$MachArch" in
|
||||
+ i386)
|
||||
+ ReadDefaultNum="$ReadIntelLinuxNum"
|
||||
+ DefaultName="Intel/Linux"
|
||||
+ ;;
|
||||
+ sparc)
|
||||
+ ReadDefaultNum="$ReadSparcSolarisNum"
|
||||
+ DefaultName="SPARC/Solaris 2.x"
|
||||
+ ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
+
|
||||
esac
|
||||
|
||||
if [ -z "$ReadDefaultNum" ] ; then
|
Loading…
Reference in a new issue