libssh: Leave pkgsrc to handle security features.

This commit is contained in:
jperkin 2018-02-02 09:31:29 +00:00
parent 6341286b8e
commit 2c66eee1cd
2 changed files with 24 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.11 2016/02/23 15:49:42 wiz Exp $
$NetBSD: distinfo,v 1.12 2018/02/02 09:31:29 jperkin Exp $
SHA1 (security/libssh-0.7.3.tar.xz) = 9de2a8fde51aa7b7855008fafd5bf47ebb01289f
RMD160 (security/libssh-0.7.3.tar.xz) = af73d82dad552233791aea8ac1198232e0fb0f68
SHA512 (security/libssh-0.7.3.tar.xz) = 6797ea9492c9d07e0169163e6559a7880dd368ee763eff297b3cbddda5e892703cf32506f9513e7d9b5135984e1e888c4893b342df07da1b7ee30968c9185869
Size (security/libssh-0.7.3.tar.xz) = 350464 bytes
SHA1 (patch-aa) = 2f9a7c8a629188f40f3c94d4304b1e44720e45ae
SHA1 (patch-cmake_Modules_DefineCompilerFlags.cmake) = 9f140ad664363953e4c7ff4e3bede74c693da993

View file

@ -0,0 +1,22 @@
$NetBSD: patch-cmake_Modules_DefineCompilerFlags.cmake,v 1.1 2018/02/02 09:31:29 jperkin Exp $
Leave pkgsrc to handle security features.
--- cmake/Modules/DefineCompilerFlags.cmake.orig 2016-02-15 12:42:53.000000000 +0000
+++ cmake/Modules/DefineCompilerFlags.cmake
@@ -21,6 +21,7 @@ if (UNIX AND NOT WIN32)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
endif (WITH_FPIC)
+ if(0)
check_c_compiler_flag_ssp("-fstack-protector" WITH_STACK_PROTECTOR)
if (WITH_STACK_PROTECTOR)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector")
@@ -35,6 +36,7 @@ if (UNIX AND NOT WIN32)
endif (WITH_FORTIFY_SOURCE)
endif()
endif()
+ endif(0)
endif (${CMAKE_C_COMPILER_ID} MATCHES "(GNU|Clang)")
#