py-flake8: Backport patches from upstream for py-codestyle-2.4.0 update

Adjust py-flake8 after py-codestyle-2.4.0 update. Backport all
relevant commits from upstream to address that.
(They will not be needed for next stable version of py-flake8)

PKGREVISION++
This commit is contained in:
leot 2018-05-14 07:39:55 +00:00
parent 318b2efae8
commit 2c98f9ffc7
5 changed files with 77 additions and 3 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.13 2018/03/23 21:09:11 joerg Exp $
# $NetBSD: Makefile,v 1.14 2018/05/14 07:39:55 leot Exp $
DISTNAME= flake8-3.5.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=f/flake8/}
@ -12,7 +13,7 @@ LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-flakes>=1.5.0:../../devel/py-flakes
DEPENDS+= ${PYPKGPREFIX}-mccabe>=0.6.0:../../devel/py-mccabe
DEPENDS+= ${PYPKGPREFIX}-codestyle>=2.0.0:../../devel/py-codestyle
DEPENDS+= ${PYPKGPREFIX}-codestyle>=2.4.0:../../devel/py-codestyle
.include "../../lang/python/pyversion.mk"
.if "${PYPKGPREFIX}" == "py27"
DEPENDS+= ${PYPKGPREFIX}-configparser-[0-9]*:../../devel/py-configparser

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.11 2017/11/08 08:39:04 wiz Exp $
$NetBSD: distinfo,v 1.12 2018/05/14 07:39:55 leot Exp $
SHA1 (flake8-3.5.0.tar.gz) = 302f39432917f57bb4f0f1c1573c96074913b46f
RMD160 (flake8-3.5.0.tar.gz) = 4533c09c33394ca31ab081ed09f370dfac415882
SHA512 (flake8-3.5.0.tar.gz) = ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
Size (flake8-3.5.0.tar.gz) = 140608 bytes
SHA1 (patch-setup.cfg) = 227164e8c9e0287227fadc13f522b84d6781acca
SHA1 (patch-setup.py) = 2027b7f24cc5f99e5f77a45c97338d0cc6d69404
SHA1 (patch-tox.ini) = ff417d4d05a5846db467015f19fba095e368ef70

View file

@ -0,0 +1,17 @@
$NetBSD: patch-setup.cfg,v 1.3 2018/05/14 07:39:55 leot Exp $
Add support for pycodestyle-2.4.0.
From upstream commits 0273ca56, 85c503de, 68782675, e61d9d24, ef1d5cee.
--- setup.cfg.orig 2017-10-23 11:16:02.000000000 +0000
+++ setup.cfg
@@ -9,7 +9,7 @@ requires-dist =
enum34; python_version<"3.4"
configparser; python_version<"3.2"
pyflakes >= 1.5.0, < 1.7.0
- pycodestyle >= 2.0.0, < 2.4.0
+ pycodestyle >= 2.4.0, < 2.5.0
mccabe >= 0.6.0, < 0.7.0
[egg_info]

View file

@ -0,0 +1,36 @@
$NetBSD: patch-setup.py,v 1.3 2018/05/14 07:39:55 leot Exp $
Add support for pycodestyle-2.4.0.
From upstream commits 0273ca56, 85c503de, 68782675, e61d9d24, ef1d5cee.
--- setup.py.orig 2017-08-08 00:31:43.000000000 +0000
+++ setup.py
@@ -22,7 +22,7 @@ requires = [
# And in which releases we will update those ranges here:
# http://flake8.pycqa.org/en/latest/internal/releases.html#releasing-flake8
"pyflakes >= 1.5.0, < 1.7.0",
- "pycodestyle >= 2.0.0, < 2.4.0",
+ "pycodestyle >= 2.4.0, < 2.5.0",
"mccabe >= 0.6.0, < 0.7.0",
"setuptools >= 30",
]
@@ -108,7 +108,8 @@ setuptools.setup(
PEP8_PLUGIN('module_imports_on_top_of_file'),
PEP8_PLUGIN('compound_statements'),
PEP8_PLUGIN('explicit_line_join'),
- PEP8_PLUGIN('break_around_binary_operator'),
+ PEP8_PLUGIN('break_after_binary_operator'),
+ PEP8_PLUGIN('break_before_binary_operator'),
PEP8_PLUGIN('comparison_to_singleton'),
PEP8_PLUGIN('comparison_negative'),
PEP8_PLUGIN('comparison_type'),
@@ -118,6 +119,8 @@ setuptools.setup(
PEP8_PLUGIN('python_3000_raise_comma'),
PEP8_PLUGIN('python_3000_not_equal'),
PEP8_PLUGIN('python_3000_backticks'),
+ PEP8_PLUGIN('python_3000_invalid_escape_sequence'),
+ PEP8_PLUGIN('python_3000_async_await_keywords'),
],
'flake8.report': [
'default = flake8.formatting.default:Default',

View file

@ -0,0 +1,17 @@
$NetBSD: patch-tox.ini,v 1.1 2018/05/14 07:39:55 leot Exp $
Add support for pycodestyle-2.4.0.
From upstream commits 0273ca56, 85c503de, 68782675, e61d9d24, ef1d5cee.
--- tox.ini.orig 2017-05-28 13:15:48.000000000 +0000
+++ tox.ini
@@ -141,7 +141,7 @@ commands =
# defaults to selecting all other errors so we do not need select=E,F,W,I,D
# Once Flake8 3.0 is released and in a good state, we can use both and it will
# work well \o/
-ignore = D203
+ignore = D203, W504
exclude =
.tox,
.git,