Update to 2.010501 (in line with math/pari 2.1.5)
Changes since 2.001804: Too many to list here, see file "Changes".
This commit is contained in:
parent
c941156cf5
commit
2cd1b3f491
4 changed files with 41 additions and 46 deletions
|
@ -1,29 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.11 2003/07/21 16:57:14 martti Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2004/02/22 22:04:54 heinz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Math-Pari-2.001804
|
||||
DISTNAME= Math-Pari-2.010501
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= # empty
|
||||
SVR4_PKGNAME= p5mpa
|
||||
CATEGORIES= math perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Math/}
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
#HOMEPAGE=
|
||||
HOMEPAGE= http://search.cpan.org/dist/Math-Pari/
|
||||
COMMENT= Perl5 interface to the pari math library
|
||||
|
||||
DEPENDS+= pari-[0-9]*:../../math/pari
|
||||
# XXX: to use or not to use...
|
||||
#DEPENDS+= gnuplot-[0-9]*:../../graphics/gnuplot
|
||||
|
||||
GCC_REQD= 2.95
|
||||
MAKE_ENV+= MP_NOGNUPLOT=1
|
||||
USE_BUILDLINK2= YES
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Math/Pari/.packlist
|
||||
TEST_TARGET= # the tests need looking at
|
||||
#TEST_TARGET= # the tests need looking at
|
||||
|
||||
# XXX: could be improved...
|
||||
post-extract:
|
||||
if [ ! -d ${_PKGSRCDIR}/math/pari/${WRKDIR_BASENAME} ]; then \
|
||||
cd ${_PKGSRCDIR}/math/pari && ${MAKE}; \
|
||||
cd ${_PKGSRCDIR}/math/pari && ${MAKE} configure; \
|
||||
fi
|
||||
${RM} -f ${WRKSRC}/pari-*
|
||||
${LN} -sf ${_PKGSRCDIR}/math/pari/${WRKDIR_BASENAME}/pari-* ${WRKSRC}/
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/07/07 22:07:44 jtb Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/02/22 22:04:54 heinz Exp $
|
||||
|
||||
SHA1 (Math-Pari-2.001804.tar.gz) = adb19ceb2acdf716869a519b0d75923c1276df83
|
||||
Size (Math-Pari-2.001804.tar.gz) = 100492 bytes
|
||||
SHA1 (patch-aa) = 30311d156b407eff4ba282484b45ebc13cfb56bb
|
||||
SHA1 (Math-Pari-2.010501.tar.gz) = 61ba9cde47a624dfae562360b4e16f34409f4024
|
||||
Size (Math-Pari-2.010501.tar.gz) = 96680 bytes
|
||||
SHA1 (patch-ab) = 7ec7307b387685abed22b2bfc2db6a84a0532f55
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/07/07 22:07:45 jtb Exp $
|
||||
|
||||
--- libPARI/Makefile.PL.orig
|
||||
+++ libPARI/Makefile.PL
|
||||
@@ -284,7 +284,7 @@
|
||||
#closedir DIR or die "Cannot closedir . : $!";
|
||||
|
||||
@cfiles = <$main_paridir/src/*/*.c>;
|
||||
-@cfiles = grep !/\/(plot|ix86|version|mpin|dummy|gp_rl|gp\.)/, @cfiles;
|
||||
+@cfiles = grep !/\/(kerntest|plot|ix86|version|mpin|dummy|gp_rl|gp\.)/, @cfiles;
|
||||
%cfiles = map {m,/([^/.]*)\.c,i; ($1,$_)} @cfiles;
|
||||
|
||||
|
||||
@@ -340,7 +340,6 @@
|
||||
$mp_cflags = '\$(CPlPl) \$(NOASM)'; # NOASM seems to be empty
|
||||
} elsif ($machine eq 'port') {
|
||||
push @portfiles, 'mp.c';
|
||||
- $mycflags .= " -D__HAS_NO_ASM__";
|
||||
}
|
||||
|
||||
$cfiles{plotgnuplot} = "$main_paridir/src/graph/plotgnuplot.c";
|
||||
@@ -390,7 +389,7 @@
|
||||
ASFLAGS => $assflags{$machine} || '',
|
||||
},
|
||||
DEFINE => $mycflags,
|
||||
- INC => "-I$main_paridir/src/headers -I$main_paridir/src/graph -I.",
|
||||
+ INC => "-I$main_paridir/src/headers -I$main_paridir/src/graph -I$main_paridir/src/language -I.",
|
||||
C => \@cfiles,
|
||||
SKIP => [qw( distclean test dist makeaperl xs_o static)],
|
||||
clean => {'FILES' =>
|
||||
@@ -460,4 +459,3 @@
|
||||
}
|
||||
return $self->MM::const_config;
|
||||
}
|
||||
-
|
29
math/p5-Math-Pari/patches/patch-ab
Normal file
29
math/p5-Math-Pari/patches/patch-ab
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/02/22 22:04:54 heinz Exp $
|
||||
|
||||
--- utils/Math/PariBuild.pm.orig Sun Feb 1 10:30:06 2004
|
||||
+++ utils/Math/PariBuild.pm
|
||||
@@ -714,6 +714,24 @@ sub find_machine_architecture () {
|
||||
} elsif ((split ' ', $Config{myuname})[3] eq 'sun') {
|
||||
$machine = 'm86k';
|
||||
}
|
||||
+ } elsif ($os eq 'netbsd') {
|
||||
+ chomp($machine = `uname -p`);
|
||||
+ if ($machine =~ 'arm.*') {
|
||||
+ machine='arm';
|
||||
+ } elsif ($machine = 'i386') {
|
||||
+ machine='ix86';
|
||||
+ } elsif ($machine =~ 'mips.*') {
|
||||
+ machine='mips';
|
||||
+ } elsif ($machine = 'powerpc') {
|
||||
+ machine='ppc';
|
||||
+ } elsif ($machine =~ 'sh3.*') {
|
||||
+ machine='sh3';
|
||||
+ } elsif ($machine =~ 'sh5.*') {
|
||||
+ machine='sh5';
|
||||
+ } elsif ($machine = 'sparc64') {
|
||||
+ machine='sparcv9';
|
||||
+ }
|
||||
+ # these can be used verbatim: alpha amd64 m68k sparc vax
|
||||
}
|
||||
|
||||
if ( $machine ne 'alpha'
|
Loading…
Reference in a new issue