Update to PTL-2.1.9

Changes:

* fixed: pthread_kill() does not restore the critical level when given
  signal number is zero.

* New API: POSIX readdir_r.

* fixed: interruption by a signal whose handler is SIG_SIGWAIT_NP may
  cause infinite loop.

* fixed: PTL's internal SIGSEGV handler gets strange arguments on a
  system that has POSIX-based signal facility.
This commit is contained in:
msaitoh 2002-12-12 07:07:05 +00:00
parent a5b52a648c
commit 2cf4f09e3a
10 changed files with 13 additions and 2888 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.40 2002/10/10 18:59:30 tron Exp $
# $NetBSD: Makefile,v 1.41 2002/12/12 07:07:05 msaitoh Exp $
DISTNAME= PTL-2.1.8
PKGNAME= ptl-2.1.8
PKGREVISION= 1
DISTNAME= PTL-2.1.9
PKGNAME= ptl-2.1.9
CATEGORIES= devel
MASTER_SITES= ftp://ftp.media.osaka-cu.ac.jp/pub/PTL/PTL2/

View file

@ -1,6 +1,6 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:26:04 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2002/12/12 07:07:05 msaitoh Exp $
bin/ptlgcc
bin/ptlg++
lib/libPTL.a
lib/libPTL.so
lib/libPTL.so.2.0
lib/libPTL.so.2.1

View file

@ -1,12 +1,6 @@
$NetBSD: distinfo,v 1.10 2002/10/10 18:59:30 tron Exp $
$NetBSD: distinfo,v 1.11 2002/12/12 07:07:05 msaitoh Exp $
SHA1 (PTL-2.1.8.tar.gz) = b62ba82f12dd99e2ff8a20b15c2b02c809c07d16
Size (PTL-2.1.8.tar.gz) = 678474 bytes
SHA1 (patch-aa) = 284228c992244b9465b68741b8e6ad68567c254c
SHA1 (PTL-2.1.9.tar.gz) = 8ad35279a618f639d6fd0556c3053ca192ce50ee
Size (PTL-2.1.9.tar.gz) = 694271 bytes
SHA1 (patch-aa) = 238660e4087b41e296f4048e65f8e54486c97dd8
SHA1 (patch-ab) = 501fa5218757f9e47cc8d9b78f33082019517dcb
SHA1 (patch-ac) = 9f72f1bfdb5b37e834de6494be10781f91d025e9
SHA1 (patch-ad) = c42cb8aa563787f4da73e08bcc7f03189236e480
SHA1 (patch-ae) = b513392a233c126e424164560f6a93d23dc2ae80
SHA1 (patch-af) = 55beff08977e374e37e44188757771f6eeedc999
SHA1 (patch-ag) = 4702253d80a8d35ccf01b1fc23cba3df03281201
SHA1 (patch-ah) = 9ea9e549eac261409b2d62070abe13dca1f6131d

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.2 2000/05/07 11:18:20 msaitoh Exp $
--- Makefile.orig Wed Mar 24 13:33:28 1999
+++ Makefile Thu Mar 25 01:03:04 1999
@@ -7,13 +7,13 @@
$NetBSD: patch-aa,v 1.3 2002/12/12 07:07:05 msaitoh Exp $
--- Makefile.orig Tue Nov 26 21:19:42 2002
+++ Makefile Thu Dec 12 15:26:47 2002
@@ -7,7 +7,7 @@
#
# Install directory
@ -10,10 +10,3 @@ $NetBSD: patch-aa,v 1.2 2000/05/07 11:18:20 msaitoh Exp $
exec_prefix = $(prefix)
# Directory to install ptlgcc
dest_bindir = $(exec_prefix)/bin
# Directory to install libPTL.a and libPTL.so
-dest_libdir = $(exec_prefix)/PTL/lib
+dest_libdir = $(exec_prefix)/lib
# Directory to install include files
# This directory must NOT be /usr/local/include
dest_includedir = $(exec_prefix)/PTL/include

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ac,v 1.5 2001/06/12 10:40:39 tron Exp $
--- src/stack.c.orig Wed Sep 27 23:36:56 2000
+++ src/stack.c Tue Jun 12 11:37:39 2001
@@ -220,7 +220,11 @@
validate_shm,
alloc_shm,
extend_shm,
+#ifdef __NetBSD__
+ NBPG
+#else
SHMLBA
+#endif
}
#endif /* NO_SHM */
#endif /* !__sun4__ */

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.4 2001/07/13 16:06:46 bad Exp $
--- src/spec.h.orig Thu Mar 2 07:06:39 2000
+++ src/spec.h Fri Jul 13 16:44:17 2001
@@ -201,7 +201,7 @@
# define NO_SHM
#endif
-#if defined(__NetBSD__) && defined(sparc)
+#if defined(__NetBSD__) && (defined(sparc) || defined(__sparc__))
# define NO_SHM /* SHMLBA is not constant */
# undef HAVE_SHMGET
#endif

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ag,v 1.1 2002/09/25 15:54:24 tron Exp $
--- Util/mkspecs.in.orig Mon Jun 21 14:36:53 1999
+++ Util/mkspecs.in Wed Sep 25 17:49:05 2002
@@ -17,11 +17,6 @@
$recpathflags .= "$dest_libdir";
}
-if ($cc ne 'gcc') {
- print "Compiler is not gcc\n";
- exit 0;
-}
-
undef $s;
if ($have_libsocket) {
$s = '-lsocket ';
@@ -30,7 +25,7 @@
# get linker option
chop($linker_opt = <>);
-open(SPECS, "gcc -dumpspecs|") || die ("cannot run gcc -dumpspecs: $!\n");
+open(SPECS, "$cc -dumpspecs|") || die ("cannot run $cc -dumpspecs: $!\n");
while (<SPECS>) {
chop;
if (/^\*(.*:)$/) {

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ah,v 1.1 2002/10/10 18:59:31 tron Exp $
--- libaltsys/so/wrap.c.orig Sat Sep 23 00:05:19 2000
+++ libaltsys/so/wrap.c Thu Oct 10 20:27:58 2002
@@ -7,6 +7,7 @@
*/
#include <sys/types.h>
+#include <sys/param.h>
#include <dirent.h>
#include <stdio.h>
#include <dlfcn.h>
@@ -79,7 +80,7 @@
int nread;
int fd;
#endif
- char path[256];
+ char path[MAXPATHLEN];
char *seekdir;
char *dlm;
char *env;