add a patch from upstream to fix a bug which made that fontconfig

support could not be switched off once enabled
(could make a difference for gnuplot but I couldn't find a testcase yet)
This commit is contained in:
drochner 2011-01-06 18:01:21 +00:00
parent 3ea52d8fa6
commit 2d06e1893d
3 changed files with 15 additions and 6 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.85 2010/12/23 11:44:37 dsainty Exp $
# $NetBSD: Makefile,v 1.86 2011/01/06 18:01:21 drochner Exp $
DISTNAME= gd-2.0.35
PKGREVISION= 6
PKGREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.libgd.org/releases/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.31 2009/10/22 15:20:53 taca Exp $
$NetBSD: distinfo,v 1.32 2011/01/06 18:01:21 drochner Exp $
SHA1 (gd-2.0.35.tar.bz2) = ccf34a610abff2dbf133a20c4d2a4aa94939018a
RMD160 (gd-2.0.35.tar.bz2) = f452a2c333b2ba9b7b4c143983ec2af18a335516
Size (gd-2.0.35.tar.bz2) = 1212730 bytes
SHA1 (patch-aa) = 726107579811ce1f33b00bd4dbf13040c48120bb
SHA1 (patch-ab) = 082f5baa2c147fb62381c21ecb3ce11a1891a2aa
SHA1 (patch-ab) = 70bfe427ae1ace5a17090dd158a64addb8d7b964
SHA1 (patch-ac) = d166ed4d0a3510c610e8aa233d312e15d96f4667
SHA1 (patch-ad) = 27631984f613c4c1c6f57cea23c36ae7d48271ac

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.8 2005/06/06 18:38:08 minskim Exp $
$NetBSD: patch-ab,v 1.9 2011/01/06 18:01:21 drochner Exp $
--- gdft.c.orig 2004-11-02 15:00:48.000000000 -0600
--- gdft.c.orig 2007-04-19 12:54:56.000000000 +0000
+++ gdft.c
@@ -25,6 +25,261 @@
#define R_OK 04 /* Needed in Windows */
@ -264,3 +264,12 @@ $NetBSD: patch-ab,v 1.8 2005/06/06 18:38:08 minskim Exp $
/* number of antialised colors for indexed bitmaps */
#define NUMCOLORS 8
@@ -1659,7 +1914,7 @@ static char * font_path(char **fontpath,
BGD_DECLARE(int) gdFTUseFontConfig(int flag)
{
#ifdef HAVE_LIBFONTCONFIG
- fontConfigFlag = 1;
+ fontConfigFlag = flag;
return 1;
#else
return 0;