Update to 1.0.73. Now needs gdbus-codegen and gmake to build.

CHANGES IN V1.0.73

	- cups-browsed: Added missing
          utils/org.cups.cupsd.Notifier.xml file.

CHANGES IN V1.0.72

	- cups-browsed, implicitclass: Added load balancing
          functionality. If there are several remote CUPS printers
          with the same name, they for locally a cluster represented
          by a print queue with this name. This printer prints through
          a special backend (implicitclass) which makes cups-browsed
          find the best destination remote queue (fewest jobs,
          enabled) for this job.
	- cups-browsed: Added protection against accidental deletion of
	  print queues generated by cups-browsed. These queues now get
	  automatically re-created.
	- cups-browsed: Added LDAP support. Appropriately configured via
	  cups-browsed.conf remote printers made available via LDAP will be
	  looked up and local queues pointing to them created. Thanks to
	  Raphael Geissert (atomo64 at gmail dot com) for contributing this
	  patch (Debian bug #795185).
	- cups-browsed: Introduced new handling for the default
	  printer using cache files. So we do not need to keep an auto-generated
	  queue because it is set as default printer. If the auto-generated
	  queue disappears, the old local printer is set as default again and
	  when it re-appears it returns to be the default printer.
	- cups-browsed: Added infrastructure for subscribing to CUPS
	  notifications for things like improved default printer handling,
	  load balancing, ...
	- foomatic-rip: Prevent crash when supplying "media" option with empty
	  value ("media=", Ubuntu bug #1479871).
	- pdftoopvp: Adaptations to API changes on Poppler 0.34.0, note that
	  this patch disables color management in this filter. Thanks to
	  Vincent le Garrec and Andreas K. Huettel for the patch (Bug #1301,
	  Gentoo bug #554782).
	- libcupsfilters, bannertopdf, foomatic-rip, gstoraster, pdftoijs,
	  sys5ippprinter, pdftoopvp, pdftops, pdftoraster, rastertoescpx,
	  urftopdf, texttopdf: Miscellaneous fixes for build compatibility with
	  different platforms, like config.h as very first include and so on.
	  Thanks to Richard Palo for the patch (Bug #1264).
	- texttopdf: Request the generic 'monospace' font alias from fontconfig
	  instead of the hard-coded FreeMono. Thanks to Fabian Greffrath
	  (fabian at debian dot org) for the patch (Debian bug #788048).
This commit is contained in:
wiz 2015-08-26 08:36:48 +00:00
parent 1f80af93ac
commit 2d0f3e2f3d
6 changed files with 28 additions and 54 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.25 2015/07/15 15:09:38 wiz Exp $
# $NetBSD: Makefile,v 1.26 2015/08/26 08:36:48 wiz Exp $
DISTNAME= cups-filters-1.0.71
PKGREVISION= 1
DISTNAME= cups-filters-1.0.73
CATEGORIES= print
MASTER_SITES= http://openprinting.org/download/cups-filters/
EXTRACT_SUFX= .tar.xz
@ -13,16 +12,18 @@ LICENSE= gnu-gpl-v2 AND gnu-gpl-v3 AND gnu-lgpl-v2 AND mit
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= bash:run pkg-config
USE_TOOLS+= bash:run gmake pkg-config
USE_TOOLS+= autoconf
USE_LANGUAGES= c c++
CONFLICTS+= cups<1.6
BUILD_DEPENDS+= gdbus-codegen-[0-9]*:../../devel/gdbus-codegen
DEPENDS+= poppler-utils-[0-9]*:../../print/poppler-utils
PKGCONFIG_OVERRIDE+= libcupsfilters.pc.in
PKGCONFIG_OVERRIDE+= libfontembed.pc.in
CONFLICTS+= cups<1.6
REPLACE_BASH+= filter/textonly
CONFIGURE_ARGS+= --with-rcdir=${PREFIX}/share/examples/rc.d

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2015/06/14 16:08:04 wiz Exp $
@comment $NetBSD: PLIST,v 1.8 2015/08/26 08:36:48 wiz Exp $
bin/foomatic-rip
bin/ttfread
include/cupsfilters/colord.h
@ -15,6 +15,7 @@ lib/libcupsfilters.la
lib/libfontembed.la
lib/pkgconfig/libcupsfilters.pc
lib/pkgconfig/libfontembed.pc
libexec/cups/backend/implicitclass
libexec/cups/backend/parallel
libexec/cups/backend/serial
libexec/cups/filter/bannertopdf

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.20 2015/07/15 12:49:37 wiz Exp $
$NetBSD: distinfo,v 1.21 2015/08/26 08:36:48 wiz Exp $
SHA1 (cups-filters-1.0.71.tar.xz) = c08258c086d4a6edf5869fc29676280ad0c22b27
RMD160 (cups-filters-1.0.71.tar.xz) = c5da92ce803f156b60e8b08bf1251fa1d06c315b
Size (cups-filters-1.0.71.tar.xz) = 1339116 bytes
SHA1 (patch-filter_pdftoopvp_OPVPOutputDev.cxx) = a1f9214bcbc77438cd74310e9483bfb644bbf1da
SHA1 (patch-filter_pdftoopvp_oprs_OPRS.cxx) = 1e5e641f209748105201fac382dd9802615d946e
SHA1 (cups-filters-1.0.73.tar.xz) = 55296ba6104b11520a0490a17455c2f90dc0ad6f
RMD160 (cups-filters-1.0.73.tar.xz) = e36bae34f2fe663944d44f04c863685ae21cf88f
Size (cups-filters-1.0.73.tar.xz) = 1351652 bytes
SHA1 (patch-backend_implicitclass.c) = 20f108e1361a7d691110e9e85ec9c750ad7674b2

View file

@ -0,0 +1,15 @@
$NetBSD: patch-backend_implicitclass.c,v 1.1 2015/08/26 08:36:48 wiz Exp $
For open() and O_RDONLY.
https://bugs.linuxfoundation.org/show_bug.cgi?id=1310
--- backend/implicitclass.c.orig 2015-08-18 23:28:24.000000000 +0000
+++ backend/implicitclass.c
@@ -21,6 +21,7 @@
#include "backend-private.h"
#include <cups/array.h>
#include <ctype.h>
+#include <fcntl.h>
/*
* Local globals...

View file

@ -1,23 +0,0 @@
$NetBSD: patch-filter_pdftoopvp_OPVPOutputDev.cxx,v 1.1 2015/07/15 12:49:37 wiz Exp $
pdftoopvp: Adaptations to API changes on Poppler 0.34.0.
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7371
--- filter/pdftoopvp/OPVPOutputDev.cxx.orig 2015-06-26 15:45:26.000000000 +0000
+++ filter/pdftoopvp/OPVPOutputDev.cxx
@@ -1811,10 +1811,14 @@ void OPVPOutputDev::drawSoftMaskedImage(
#if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
maskSplash->drawImage(&imageSrc, &imgMaskData,
splashModeMono8, gFalse, maskWidth, maskHeight, mat);
-#else
+#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
maskSplash->drawImage(&imageSrc, &imgMaskData,
splashModeMono8, gFalse, maskWidth, maskHeight,
mat,gFalse);
+#else
+ maskSplash->drawImage(&imageSrc, 0, &imgMaskData,
+ splashModeMono8, gFalse, maskWidth, maskHeight,
+ mat,gFalse);
#endif
delete imgMaskData.imgStr;
maskStr->close();

View file

@ -1,19 +0,0 @@
$NetBSD: patch-filter_pdftoopvp_oprs_OPRS.cxx,v 1.1 2015/07/15 12:49:37 wiz Exp $
pdftoopvp: Adaptations to API changes on Poppler 0.34.0.
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7371
--- filter/pdftoopvp/oprs/OPRS.cxx.orig 2015-06-26 15:45:26.000000000 +0000
+++ filter/pdftoopvp/oprs/OPRS.cxx
@@ -240,8 +240,10 @@ SplashError OPRS::drawImage(SplashImageS
if (rasterMode) {
#if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
-#else
+#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
+#else
+ return splash->drawImage(src,0,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
#endif
} else {
return opvpSplash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);