kipi-plugins: update to 19.08.3 qt5/kf5 version
This commit is contained in:
parent
3fd89bc3e8
commit
2d15197fb0
10 changed files with 537 additions and 1810 deletions
|
@ -1,61 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.131 2019/08/22 12:23:19 ryoon Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.132 2019/11/17 08:59:53 markd Exp $
|
||||
|
||||
PKGNAME= kipi-plugins-4.13.0
|
||||
PKGREVISION= 21
|
||||
DISTNAME= digikam-4.13.0
|
||||
DISTNAME= kipi-plugins-${KAPPSVER}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_KDE:=digikam/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://www.digikam.org/
|
||||
COMMENT= Common plugin structure for KDE4 programs
|
||||
#LICENSE= gnu-gpl-v2 AND Adobe DNG SDK license
|
||||
HOMEPAGE= https://userbase.kde.org/KIPI/
|
||||
COMMENT= Collection of plugins extending the KDE graphics and image applications
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
BUILD_DEPENDS+= automoc4>=0.9.83:../../devel/automoc4
|
||||
DEPENDS+= ImageMagick-[0-9]*:../../graphics/ImageMagick
|
||||
DEPENDS+= xdg-utils-[0-9]*:../../misc/xdg-utils
|
||||
.include "../../meta-pkgs/kde/applications.mk"
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= msgfmt pkg-config bison
|
||||
CMAKE_ARGS+= -DENABLE_OPENCV3:BOOL=ON
|
||||
USE_TOOLS+= msgmerge pkg-config
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/extra/kipi-plugins
|
||||
|
||||
post-patch:
|
||||
${ECHO} "FIND_PACKAGE(Msgfmt REQUIRED)" >> ${WRKSRC}/CMakeLists.txt
|
||||
${ECHO} "FIND_PACKAGE(Gettext REQUIRED)" >> ${WRKSRC}/CMakeLists.txt
|
||||
${ECHO} "set_property(GLOBAL PROPERTY ALLOW_DUPLICATE_CUSTOM_TARGETS 1)" >> ${WRKSRC}/CMakeLists.txt
|
||||
${ECHO} "ADD_SUBDIRECTORY(po)" >> ${WRKSRC}/CMakeLists.txt
|
||||
ln -s ../../po ${WRKSRC}/po
|
||||
rm ${WRKSRC}/po/*/digikam.po ${WRKSRC}/po/*/libkipi.po
|
||||
|
||||
SUBST_CLASSES+= xdg
|
||||
SUBST_SED.xdg= -e "s,/usr/bin/env xdg-open,${PREFIX}/bin/xdg-open,"
|
||||
SUBST_FILES.xdg= expoblending/plugin/expoblending.desktop panorama/plugin/panoramagui.desktop
|
||||
SUBST_STAGE.xdg= pre-build
|
||||
SUBST_MESSAGE.xdg= Fixing path in desktop file.
|
||||
|
||||
.include "../../meta-pkgs/kde4/kde4.mk"
|
||||
# for IpodExport
|
||||
.include "../../audio/libgpod/buildlink3.mk"
|
||||
.include "../../graphics/libkdcraw/buildlink3.mk"
|
||||
.include "../../graphics/libkexiv2/buildlink3.mk"
|
||||
.include "../../devel/kio/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../graphics/libkipi/buildlink3.mk"
|
||||
.include "../../graphics/libksane/buildlink3.mk"
|
||||
.include "../../misc/libkgeomap/buildlink3.mk"
|
||||
.include "../../www/libmediawiki/buildlink3.mk"
|
||||
.include "../../misc/libkvkontakte/buildlink3.mk"
|
||||
# for RemoveRedEyes
|
||||
.include "../../graphics/opencv/buildlink3.mk"
|
||||
.include "../../graphics/tiff/buildlink3.mk"
|
||||
# for Calendar
|
||||
.include "../../misc/kdepimlibs4/buildlink3.mk"
|
||||
# for Shwup
|
||||
.include "../../security/qca2/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../textproc/expat/buildlink3.mk"
|
||||
.include "../../x11/kdelibs4/buildlink3.mk"
|
||||
.include "../../www/libmediawiki/buildlink3.mk"
|
||||
.include "../../x11/kxmlgui/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,12 +1,15 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.3 2012/03/31 23:45:58 dholland Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.4 2019/11/17 08:59:53 markd Exp $
|
||||
|
||||
BUILDLINK_TREE+= kipi-plugins
|
||||
|
||||
.if !defined(KIPI_PLUGINS_BUILDLINK3_MK)
|
||||
KIPI_PLUGINS_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.kipi-plugins+= kipi-plugins>=1.1.0
|
||||
BUILDLINK_API_DEPENDS.kipi-plugins+= kipi-plugins>=19.08.3
|
||||
BUILDLINK_PKGSRCDIR.kipi-plugins?= ../../graphics/kipi-plugins
|
||||
.endif # KIPI_PLUGINS_BUILDLINK3_MK
|
||||
|
||||
.include "../../graphics/libkipi/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.endif # KIPI_PLUGINS_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -kipi-plugins
|
||||
|
|
|
@ -1,12 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.35 2015/12/12 19:32:45 markd Exp $
|
||||
$NetBSD: distinfo,v 1.36 2019/11/17 08:59:53 markd Exp $
|
||||
|
||||
SHA1 (digikam-4.13.0.tar.bz2) = d696ac88dcb3bcbd3a5da83b0fbe5e7315a43f92
|
||||
RMD160 (digikam-4.13.0.tar.bz2) = 11d6aa15a94cd38acca79f2a31f65393a01a2b0b
|
||||
SHA512 (digikam-4.13.0.tar.bz2) = 0cadb55f568a34d07f008791ca351428f4cd9e7060ba79aa8acc25e5e38f0bbcd586df764dacbcb9d1dadb56d2fb9160760cc89aeab4d7cef9bdbd26f691752b
|
||||
Size (digikam-4.13.0.tar.bz2) = 69554099 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 84a60e41594a93a619994157529da2656e17e38a
|
||||
SHA1 (patch-README) = 2b01709a03ffa0d74fb20a5b9d6aced552df2c9b
|
||||
SHA1 (patch-removeredeyes_CMakeLists.txt) = b2224f70410e6c767258b751e05bedab4515cbfa
|
||||
SHA1 (patch-removeredeyes_detection_locators_haarclassifier_haarclassifierlocator.cpp) = 7084638db7858c144710e3c18eadef0fcf022d77
|
||||
SHA1 (patch-removeredeyes_plugin_libopencv.h) = 6460c0f62d095372588b1397b337157defb82fe7
|
||||
SHA1 (patch-removeredeyes_test_CMakeLists.txt) = b5ff51e037754a133450f599603811cdd10660a4
|
||||
SHA1 (kipi-plugins-19.08.3.tar.xz) = b7ce05d24b040d739977c2fe53837a49bcc05469
|
||||
RMD160 (kipi-plugins-19.08.3.tar.xz) = cdb5db9f4949de44a9ce075dd9dc5d1af511388b
|
||||
SHA512 (kipi-plugins-19.08.3.tar.xz) = 58901a4c0ba40da99aa2d06381cffd61bacfec5ea040abab73044ab38241460b71421629390c93818c74bfee7f195ed29c423462a057f2b1b990e40edeae5c0a
|
||||
Size (kipi-plugins-19.08.3.tar.xz) = 1629776 bytes
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- CMakeLists.txt.orig 2015-10-16 21:39:14.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -1,4 +1,3 @@
|
||||
-cmake_minimum_required(VERSION 2.8.9)
|
||||
#
|
||||
# Copyright (c) 2010-2015, Gilles Caulier, <caulier dot gilles at gmail dot com>
|
||||
#
|
||||
@@ -11,16 +10,18 @@ project(kipi-plugins)
|
||||
message(STATUS "----------------------------------------------------------------------------------")
|
||||
message(STATUS "Starting CMake configuration for: kipi-plugins")
|
||||
|
||||
+option(ENABLE_OPENCV3 "Build kipi-plugins with OpenCV3 instead OpenCV2 (default=OFF)" OFF)
|
||||
+
|
||||
# =======================================================
|
||||
# Information to update before to release this package.
|
||||
|
||||
# kipi-plugins version
|
||||
set(KIPIPLUGINS_MAJOR_VERSION "4")
|
||||
-set(KIPIPLUGINS_MINOR_VERSION "13")
|
||||
+set(KIPIPLUGINS_MINOR_VERSION "14")
|
||||
set(KIPIPLUGINS_PATCH_VERSION "0")
|
||||
|
||||
# kipi-plugins release date
|
||||
-set(KIPIPLUGINS_RELEASE_DATE "2015-08-30")
|
||||
+set(KIPIPLUGINS_RELEASE_DATE "2015-09-27")
|
||||
|
||||
# Suffix to add at end of version string. Usual values are:
|
||||
# "-git" : alpha code unstable from git. Do not use in production
|
||||
@@ -165,8 +166,14 @@ if(KIPI_FOUND)
|
||||
|
||||
include(MacroUtils)
|
||||
include(MacroOpenCV)
|
||||
- set(OPENCV_MIN_VERSION "2.4.9")
|
||||
- DETECT_OPENCV(${OPENCV_MIN_VERSION} core highgui objdetect contrib legacy imgproc)
|
||||
+
|
||||
+ if (ENABLE_OPENCV3)
|
||||
+ set(OPENCV_MIN_VERSION "3.0.0")
|
||||
+ DETECT_OPENCV(${OPENCV_MIN_VERSION} core face highgui objdetect imgproc)
|
||||
+ else()
|
||||
+ set(OPENCV_MIN_VERSION "2.4.9")
|
||||
+ DETECT_OPENCV(${OPENCV_MIN_VERSION} core highgui objdetect contrib legacy imgproc)
|
||||
+ endif()
|
||||
|
||||
include(MacroOptionalDependPackage)
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-README,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- README.orig 2015-09-03 21:22:45.000000000 +0000
|
||||
+++ README
|
||||
@@ -140,6 +140,12 @@ http://bugs.kde.org/buglist.cgi?product=
|
||||
|
||||
-- INSTALL ------------------------------------------------------------
|
||||
|
||||
+CMake compilation options to custom digiKam:
|
||||
+
|
||||
+Use CMake "-DENABLE_OPENCV3=on" flag to compile kipi-plugins source code using OpenCV3 instead OpenCV2 (disabled by default).
|
||||
+ OpenCV3 support needs extra contrib modules package, especially 'face'
|
||||
+ and 'legacy' components.
|
||||
+
|
||||
In order to compile, especially when QT3/Qt4 are installed at the same time,
|
||||
just use something like that:
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-removeredeyes_CMakeLists.txt,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- removeredeyes/CMakeLists.txt.orig 2015-09-03 21:22:45.000000000 +0000
|
||||
+++ removeredeyes/CMakeLists.txt
|
||||
@@ -1,5 +1,5 @@
|
||||
#
|
||||
-# Copyright (c) 2010-2014, Gilles Caulier, <caulier dot gilles at gmail dot com>
|
||||
+# Copyright (c) 2010-2015, Gilles Caulier, <caulier dot gilles at gmail dot com>
|
||||
#
|
||||
# Redistribution and use is allowed according to the terms of the BSD license.
|
||||
# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-removeredeyes_detection_locators_haarclassifier_haarclassifierlocator.cpp,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- removeredeyes/detection/locators/haarclassifier/haarclassifierlocator.cpp.orig 2015-09-03 21:22:45.000000000 +0000
|
||||
+++ removeredeyes/detection/locators/haarclassifier/haarclassifierlocator.cpp
|
||||
@@ -90,6 +90,15 @@ const QString HaarClassifierLocator::Pri
|
||||
|
||||
// --------------------------------------------------------
|
||||
|
||||
+#if !(OPENCV_TEST_VERSION(2,5,0))
|
||||
+
|
||||
+static void cvFillImage(CvArr* const mat, double color)
|
||||
+{
|
||||
+ cvSet(mat, cvColorToScalar(color, cvGetElemType(mat)), 0);
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
int HaarClassifierLocator::findPossibleEyes(double csf, int ngf, const char* classifierFile)
|
||||
{
|
||||
// eyes sequence will reside in the storage
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-removeredeyes_plugin_libopencv.h,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- removeredeyes/plugin/libopencv.h.orig 2015-09-03 21:22:45.000000000 +0000
|
||||
+++ removeredeyes/plugin/libopencv.h
|
||||
@@ -7,7 +7,7 @@
|
||||
* @date 2010-06-16
|
||||
* @brief Wrapper for OpenCV header files
|
||||
*
|
||||
- * @author Copyright (C) 2012-2014 by Gilles Caulier
|
||||
+ * @author Copyright (C) 2012-2015 by Gilles Caulier
|
||||
* <a href="mailto:caulier dot gilles at gmail dot com">caulier dot gilles at gmail dot com</a>
|
||||
*
|
||||
* This program is free software; you can redistribute it
|
||||
@@ -53,12 +53,13 @@
|
||||
|
||||
#define OPENCV_MAKE_VERSION(major,minor,patch) (((major) << 16) | ((minor) << 8) | (patch))
|
||||
#define OPENCV_VERSION OPENCV_MAKE_VERSION(CV_MAJOR_VERSION,CV_MINOR_VERSION,CV_SUBMINOR_VERSION)
|
||||
-#define OPENCV_TEST_VERSION(major,minor,patch) ( OPENCV_VERSION >= OPENCV_MAKE_VERSION(major,minor,patch) )
|
||||
+#define OPENCV_TEST_VERSION(major,minor,patch) ( OPENCV_VERSION < OPENCV_MAKE_VERSION(major,minor,patch) )
|
||||
|
||||
-#if OPENCV_TEST_VERSION(2,3,0)
|
||||
+#include <opencv2/core/core_c.h>
|
||||
+
|
||||
+#if OPENCV_TEST_VERSION(2,5,0)
|
||||
#include <opencv2/opencv.hpp>
|
||||
#include <opencv2/highgui/highgui_c.h>
|
||||
-#include <opencv2/core/core_c.h>
|
||||
#include <opencv2/legacy/compat.hpp>
|
||||
#include <opencv/cvaux.h>
|
||||
#else
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-removeredeyes_test_CMakeLists.txt,v 1.1 2015/12/12 19:32:45 markd Exp $
|
||||
|
||||
opencv3 support. https://bugs.kde.org/show_bug.cgi?id=349601
|
||||
|
||||
--- removeredeyes/test/CMakeLists.txt.orig 2015-09-03 21:22:45.000000000 +0000
|
||||
+++ removeredeyes/test/CMakeLists.txt
|
||||
@@ -1,10 +1,10 @@
|
||||
#
|
||||
-# Copyright (c) 2010-2014, Gilles Caulier, <caulier dot gilles at gmail dot com>
|
||||
+# Copyright (c) 2010-2015, Gilles Caulier, <caulier dot gilles at gmail dot com>
|
||||
#
|
||||
# Redistribution and use is allowed according to the terms of the BSD license.
|
||||
# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
|
||||
|
||||
-if(NOT WIN32)
|
||||
+if(NOT WIN32 AND (${OpenCV_VERSION} VERSION_LESS 3.0.0))
|
||||
|
||||
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../plugin
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/../libcvblobs
|
Loading…
Reference in a new issue