update to 0.87.2

too many feature additions and fixes to list here

pkgsrc changes:
removed all X11 frontend support, leaving just the ability to create
image files
frontends will be added as separate pkgs
This commit is contained in:
drochner 2006-04-06 16:43:39 +00:00
parent 39a303999a
commit 2d392c750a
6 changed files with 206 additions and 1995 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.10 2006/03/04 21:29:51 jlam Exp $
# $NetBSD: Makefile,v 1.11 2006/04/06 16:43:39 drochner Exp $
#
DISTNAME= matplotlib-0.83
DISTNAME= matplotlib-0.87.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=matplotlib/}
@ -16,7 +15,9 @@ PY_PATCHPLIST= yes
PYDISTUTILSPKG= yes
.include "../../lang/python/extension.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../math/py-Numeric/buildlink3.mk"
.include "../../x11/py-gtk2/buildlink3.mk"
.include "../../x11/py-Tk/buildlink3.mk"
.include "../../math/py-numarray/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,20 @@
# $NetBSD: buildlink3.mk,v 1.1 2006/04/06 16:43:39 drochner Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
PY_MATPLOTLIB_BUILDLINK3_MK:= ${PY_MATPLOTLIB_BUILDLINK3_MK}+
.include "../../lang/python/pyversion.mk"
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= pymatplotlib
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Npymatplotlib}
BUILDLINK_PACKAGES+= pymatplotlib
.if !empty(PY_MATPLOTLIB_BUILDLINK3_MK:M+)
BUILDLINK_API_DEPENDS.pymatplotlib+= ${PYPKGPREFIX}-matplotlib>=0.87.2
BUILDLINK_PKGSRCDIR.pymatplotlib?= ../../graphics/py-matplotlib
.endif # PY_MATPLOTLIB_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2005/12/29 20:29:35 markd Exp $
$NetBSD: distinfo,v 1.5 2006/04/06 16:43:39 drochner Exp $
SHA1 (matplotlib-0.83.tar.gz) = a9ac202e1ad1be4c52769487968fee7bab9ca3e4
RMD160 (matplotlib-0.83.tar.gz) = 94c4b62e57bf713f0422c905393805e951f55c88
Size (matplotlib-0.83.tar.gz) = 2703881 bytes
SHA1 (patch-aa) = b9f154c5d16b231384162bf789cc8d025f22e776
SHA1 (matplotlib-0.87.2.tar.gz) = 9d969da7cf8ecb545f8c3a9030645292f32e1cbb
RMD160 (matplotlib-0.87.2.tar.gz) = 0c913a357e8cec819a5a3f0812ef7854f329fb5c
Size (matplotlib-0.87.2.tar.gz) = 2655790 bytes
SHA1 (patch-aa) = 905b7657ac229a968c50faeee774408fd764ebfc
SHA1 (patch-ab) = 4479168dfb7137e1061a5f19a705e39dbfca6434

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2005/12/29 20:29:35 markd Exp $
$NetBSD: patch-aa,v 1.3 2006/04/06 16:43:39 drochner Exp $
--- setupext.py.orig 2005-07-06 03:36:37.000000000 +1200
--- setupext.py.orig 2006-01-09 14:20:44.000000000 +0100
+++ setupext.py
@@ -95,10 +95,8 @@ def temp_copy(_from, _to):
@@ -99,10 +99,8 @@ def temp_copy(_from, _to):
globals()["_cleanup_"+_to] = CleanUpFile(_to)
def add_base_flags(module):
@ -13,111 +13,5 @@ $NetBSD: patch-aa,v 1.2 2005/12/29 20:29:35 markd Exp $
+ incdirs = os.path.join(os.environ['LOCALBASE'], 'include')
+ libdirs = os.path.join(os.environ['LOCALBASE'], 'lib')
module.include_dirs.extend(incdirs)
module.include_dirs.append('.')
module.library_dirs.extend(libdirs)
@@ -408,22 +406,6 @@ def build_agg(ext_modules, packages, num
'agg_rasterizer_scanline_aa.cpp',
)
- if numerix in ["numarray","both"]: # Build for numarray
- deps = ['%s/src/%s'%(AGG_VERSION,name) for name in agg]
- deps.extend(('src/ft2font.cpp', 'src/mplutils.cpp'))
- deps.extend(glob.glob('CXX/*.cxx'))
- deps.extend(glob.glob('CXX/*.c'))
- temp_copy('src/_backend_agg.cpp', 'src/_na_backend_agg.cpp')
- deps.append('src/_na_backend_agg.cpp')
- module = Extension(
- 'matplotlib.backends._na_backend_agg',
- deps,
- include_dirs=numarray_inc_dirs,
- )
- module.extra_compile_args.append('-DNUMARRAY=1')
- add_agg_flags(module)
- add_ft2font_flags(module)
- ext_modules.append(module)
if numerix in ["Numeric","both"]: # Build for Numeric
deps = ['%s/src/%s'%(AGG_VERSION, name) for name in agg]
deps.extend(('src/ft2font.cpp', 'src/mplutils.cpp'))
@@ -456,21 +438,6 @@ def build_image(ext_modules, packages, n
'agg_bezier_arc.cpp',
)
- if numerix in ["numarray","both"]: # Build for numarray
- temp_copy('src/_image.cpp', 'src/_na_image.cpp')
- deps = ['src/_na_image.cpp', 'src/mplutils.cpp']
- deps.extend(['%s/src/%s'%(AGG_VERSION, name) for name in agg])
- deps.extend(glob.glob('CXX/*.cxx'))
- deps.extend(glob.glob('CXX/*.c'))
- module = Extension(
- 'matplotlib._na_image',
- deps,
- include_dirs=numarray_inc_dirs,
- )
- module.extra_compile_args.append('-DNUMARRAY=1')
- add_agg_flags(module)
- ext_modules.append(module)
-
if numerix in ["Numeric","both"]: # Build for Numeric
temp_copy('src/_image.cpp', 'src/_nc_image.cpp')
deps = ['src/_nc_image.cpp', 'src/mplutils.cpp']
@@ -514,21 +481,6 @@ def build_swigagg(ext_modules, packages)
ext_modules.append(agg)
def build_transforms(ext_modules, packages, numerix):
- if numerix in ["numarray","both"]: # Build for numarray
- cxx = glob.glob('CXX/*.cxx')
- cxx.extend(glob.glob('CXX/*.c'))
- temp_copy("src/_transforms.cpp","src/_na_transforms.cpp")
- module = Extension('matplotlib._na_transforms',
- ['src/_na_transforms.cpp',
- 'src/mplutils.cpp'] + cxx,
- libraries = ['stdc++', 'm'],
- include_dirs = ['src', '.']+numarray_inc_dirs,
- )
-
- module.extra_compile_args.append("-DNUMARRAY=1")
- add_base_flags(module)
- ext_modules.append(module)
-
if numerix in ["Numeric","both"]: # Build for Numeric
cxx = glob.glob('CXX/*.cxx')
cxx.extend(glob.glob('CXX/*.c'))
@@ -563,18 +515,6 @@ def build_contour(ext_modules, packages,
global BUILT_CONTOUR
if BUILT_CONTOUR: return # only build it if you you haven't already
- if numerix in ["numarray","both"]: # Build for numarray
- temp_copy('src/cntr.c', 'src/_na_cntr.c')
- module = Extension(
- 'matplotlib._na_cntr',
- [ 'src/_na_cntr.c',],
- #libraries = ['stdc++'],
- include_dirs=numarray_inc_dirs,
- )
- module.extra_compile_args.append('-DNUMARRAY=1')
- add_base_flags(module)
- ext_modules.append(module)
-
if numerix in ["Numeric","both"]: # Build for Numeric
temp_copy('src/cntr.c', 'src/_nc_cntr.c')
module = Extension(
@@ -593,19 +533,6 @@ def build_gdk(ext_modules, packages, num
global BUILT_GDK
if BUILT_GDK: return # only build it if you you haven't already
- if numerix in ["numarray","both"]: # Build for numarray
- temp_copy('src/_backend_gdk.c', 'src/_na_backend_gdk.c')
- module = Extension(
- 'matplotlib.backends._na_backend_gdk',
- ['src/_na_backend_gdk.c', ],
- libraries = [],
- include_dirs=numarray_inc_dirs,
- )
- module.extra_compile_args.append('-DNUMARRAY=1')
- add_base_flags(module)
- add_pygtk_flags(module)
- ext_modules.append(module)
-
if numerix in ["Numeric","both"]: # Build for Numeric
temp_copy('src/_backend_gdk.c', 'src/_nc_backend_gdk.c')
module = Extension(

View file

@ -0,0 +1,34 @@
$NetBSD: patch-ab,v 1.1 2006/04/06 16:43:39 drochner Exp $
--- setup.py.orig 2006-03-12 01:11:40.000000000 +0100
+++ setup.py
@@ -28,16 +28,16 @@ BUILD_IMAGE = 1
# it. It makes very nice antialiased output and also supports alpha
# blending
BUILD_AGG = 1
-BUILD_GTKAGG = 'auto'
-BUILD_GTK = 'auto'
+BUILD_GTKAGG = 0
+BUILD_GTK = 0
# build TK GUI with Agg renderer ; requires Tkinter Python extension
# and Tk includes
# Use False or 0 if you don't want to build
-BUILD_TKAGG = 'auto'
+BUILD_TKAGG = 0
# build wxPython GUI with Agg renderer ; requires wxPython package
-BUILD_WXAGG = 'auto'
+BUILD_WXAGG = 0
# build a small extension to manage the focus on win32 platforms.
@@ -164,7 +164,7 @@ try: import datetime
except ImportError: havedate = False
else: havedate = True
-if havedate: # dates require python23 datetime
+if 0: # dates require python23 datetime
# only install pytz and dateutil if the user hasn't got them
def add_pytz():
packages.append('pytz')