Don't shadow one local variable with another

This commit is contained in:
joerg 2012-07-03 18:19:53 +00:00
parent b1d33f91a6
commit 2d3fc0582b
2 changed files with 55 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2006/10/10 20:13:48 rillig Exp $
$NetBSD: distinfo,v 1.4 2012/07/03 18:19:53 joerg Exp $
SHA1 (lmms-0.2.0.tar.bz2) = 410647c860d140769ed1c56bb8a794cb2594658b
RMD160 (lmms-0.2.0.tar.bz2) = c3e44e018303ed40d048542a8f66fbb785ea11f2
@ -9,3 +9,4 @@ SHA1 (patch-ac) = f9be78b4c606e80c8b0bad78fafbd8ee07f2e65e
SHA1 (patch-ad) = b62e49823415530354a01c43fc588338212aaf68
SHA1 (patch-ae) = de50ed87888b74a0d3ed0158dda3291af54595c9
SHA1 (patch-af) = c269ade81ba2e9951df18a9a04e2978572376e74
SHA1 (patch-src_tracks_instrument__track.cpp) = 9b1b3df91bd306d5f7d8d7a24b03fe6d2ec13afa

View file

@ -0,0 +1,53 @@
$NetBSD: patch-src_tracks_instrument__track.cpp,v 1.1 2012/07/03 18:19:53 joerg Exp $
--- src/tracks/instrument_track.cpp.orig 2012-07-03 15:40:56.000000000 +0000
+++ src/tracks/instrument_track.cpp
@@ -946,7 +946,7 @@ bool FASTCALL instrumentTrack::play( con
// get all notes from the given pattern...
noteVector & notes = p->notes();
// ...and set our index to zero
- noteVector::iterator it = notes.begin();
+ noteVector::iterator it2 = notes.begin();
// very effective algorithm for playing notes that are
// posated within the current sample-frame
@@ -955,23 +955,23 @@ bool FASTCALL instrumentTrack::play( con
if( cur_start > 0 )
{
// skip notes which are posated before start-tact
- while( it != notes.end() && ( *it )->pos() < cur_start )
+ while( it2 != notes.end() && ( *it2 )->pos() < cur_start )
{
- ++it;
+ ++it2;
}
}
// skip notes before sample-frame
- while( it != notes.end() &&
- ( *it )->pos( cur_start ).frames( frames_per_tact ) <
+ while( it2 != notes.end() &&
+ ( *it2 )->pos( cur_start ).frames( frames_per_tact ) <
_start_frame )
{
- ++it;
+ ++it2;
}
note * cur_note;
- while( it != notes.end() &&
- ( ( cur_note = *it )->pos( cur_start ).frames(
+ while( it2 != notes.end() &&
+ ( ( cur_note = *it2 )->pos( cur_start ).frames(
frames_per_tact ) ) <= end_frame )
{
if( cur_note->length() != 0 )
@@ -1024,7 +1024,7 @@ bool FASTCALL instrumentTrack::play( con
}
played_a_note = TRUE;
}
- ++it;
+ ++it2;
}
}
return( played_a_note );