Add patch to fix gcc-4.8.5.
(at least cross/bossa, bossa-20140109nb2, has a problem) cross/bossa/work/.buildlink/include/wx-2.8/wx/debug.h:194:43: error: typedef 'wxDummyCheckInt' locally defined but not used [-Werror=unused-local-typedefs]
This commit is contained in:
parent
a3ca3ba859
commit
2d530a1102
2 changed files with 20 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.17 2015/11/04 03:28:56 agc Exp $
|
||||
$NetBSD: distinfo,v 1.18 2015/11/22 22:16:04 mef Exp $
|
||||
|
||||
SHA1 (wxGTK-2.8.12-libtool.diff.bz2) = f2c9b8a06c08101325ffe09ad77f4800f7aa8730
|
||||
RMD160 (wxGTK-2.8.12-libtool.diff.bz2) = 05b763aa44a8e8c8ad565af2a188d7c6437f2133
|
||||
|
@ -11,3 +11,4 @@ Size (wxGTK-2.8.12.tar.bz2) = 9292767 bytes
|
|||
SHA1 (patch-aa) = ad2fcc73ffe0db67cb9ef5fe87fb1248f7b7675c
|
||||
SHA1 (patch-ab) = 6f6278ec6b92a39abe29ec09053cd7007cd32fef
|
||||
SHA1 (patch-ac) = 50cf253797f2dee8b9dab08d138d0070e25e7a8c
|
||||
SHA1 (patch-include_wx_debug.h) = bc25a486361194d8d70c69bcd833e085fbcbdec3
|
||||
|
|
18
x11/wxGTK28/patches/patch-include_wx_debug.h
Normal file
18
x11/wxGTK28/patches/patch-include_wx_debug.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-include_wx_debug.h,v 1.1 2015/11/22 22:16:04 mef Exp $
|
||||
|
||||
with gcc-4.8.5:
|
||||
(at least cross/bossa, bossa-20140109nb2, has a problem)
|
||||
cross/bossa/work/.buildlink/include/wx-2.8/wx/debug.h:194:43: error:
|
||||
typedef 'wxDummyCheckInt' locally defined but not used [-Werror=unused-local-typedefs]
|
||||
|
||||
--- include/wx/debug.h.orig 2011-03-22 21:16:46.000000000 +0900
|
||||
+++ include/wx/debug.h 2015-11-22 22:18:12.000000000 +0900
|
||||
@@ -191,7 +191,7 @@
|
||||
/* as wxCHECK2 but with a message explaining why we fail */
|
||||
|
||||
#ifdef __GNUC__
|
||||
- #define wxFORCE_SEMICOLON typedef int wxDummyCheckInt
|
||||
+ #define wxFORCE_SEMICOLON typedef int wxDummyCheckInt __attribute__((unused))
|
||||
/* Note: old gcc versions (e.g. 2.8) give an internal compiler error */
|
||||
/* on a simple forward declaration, when used in a template */
|
||||
/* function, so rather use a dummy typedef which does work... */
|
Loading…
Reference in a new issue