Update to 1.1.24:

- Our patches have been merged upstream.
- One minor fix in a manual page to respect sysconfdir.
This commit is contained in:
jmmv 2010-04-24 15:56:46 +00:00
parent 2317977f4a
commit 2d82412482
5 changed files with 6 additions and 67 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.7 2010/04/23 12:45:01 jmmv Exp $
# $NetBSD: Makefile,v 1.8 2010/04/24 15:56:46 jmmv Exp $
#
DISTNAME= libpaper_1.1.23
DISTNAME= libpaper_1.1.24
PKGNAME= ${DISTNAME:S/_/-/}
PKGREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/libp/libpaper/}

View file

@ -1,8 +1,5 @@
$NetBSD: distinfo,v 1.5 2010/04/23 11:31:57 jmmv Exp $
$NetBSD: distinfo,v 1.6 2010/04/24 15:56:46 jmmv Exp $
SHA1 (libpaper_1.1.23.tar.gz) = e1c03fc0fa708cafe12d00a120685ef566100468
RMD160 (libpaper_1.1.23.tar.gz) = bf407f5e75348abde5b7d3d3c8e2ea695de46cd7
Size (libpaper_1.1.23.tar.gz) = 351153 bytes
SHA1 (patch-aa) = 1ea13f89be2dc0526537d2fc4143ecd255ea5032
SHA1 (patch-ab) = d34307f99914a2eda7b87ce3e917f0eadd106e2d
SHA1 (patch-ac) = 643541a5bbd3b422261c16f48fe86d018f315a82
SHA1 (libpaper_1.1.24.tar.gz) = 6927f75d126373d32d89751d2a7fe3e99cc9b4a1
RMD160 (libpaper_1.1.24.tar.gz) = 12e7234616bfe648337381c7c07e7de7bcfbea28
Size (libpaper_1.1.24.tar.gz) = 355272 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.2 2010/04/23 11:31:57 jmmv Exp $
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578886
--- src/paperconfig.in.orig 2007-09-04 20:59:02.000000000 +0200
+++ src/paperconfig.in
@@ -1,4 +1,4 @@
-#! /bin/bash
+#! /bin/sh
# paperconfig: configuration of system paper name
#
@@ -44,7 +44,7 @@ export @RUNPARTSDIRVAR@
force=0
-if [ "$#" == 0 ]
+if [ "$#" = 0 ]
then
usage
fi

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ab,v 1.2 2010/04/23 11:31:57 jmmv Exp $
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578884
--- lib/paper.c.orig 2007-09-14 11:04:32.000000000 +0000
+++ lib/paper.c
@@ -14,13 +14,12 @@
#include <sys/stat.h>
#include <stdio.h>
-#include <malloc.h>
+#include <stdlib.h>
#include <string.h>
#include <ctype.h>
#include <unistd.h>
-#include <stdlib.h>
#include "paper.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.2 2010/04/23 11:31:57 jmmv Exp $
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578885
--- lib/paper.h.orig 1996-09-24 09:16:07.000000000 +0200
+++ lib/paper.h
@@ -22,7 +22,7 @@
*
*/
-#if __STDC__ - 0 == 0
+#if !defined(__STDC__)
#define __PAPER_CONST
#define __PAPER_PROTO(p) ()