Update ruby-openssl package from 0.1.3.

- ad hoc fix build problem on NetBSD current.
- changes from 0.1.2a:

Tue, 10 Dec 2002 02:32:54 -0900 -- GOTOU Yuuzou <gotoyuzo@notwork.org>
	* ossl-0.1.3 released

Mon,  9 Dec 2002 22:26:15 -0900 -- GOTOU Yuuzou <gotoyuzo@notwork.org>
	* x509name.c: let initialize() give a Array instead of a Hash.
	  to_a is implemented and to_h is deprecated.
	* openssl.rb: X509::Name is refined.

Mon,  9 Dec 2002 20:21:32 -0900 -- GOTOU Yuuzou <gotoyuzo@notwork.org>
	* ossl.c: use ruby_unsetenv() instead of unsetenv().
	* ssl.c: the return value of SSL_read/SSL_write is int (not size_t).
	  This fix is suggested by matz. ([ruby-list:36721])

Mon, 28 Oct 2002 10:39:43 +0100 -- Michal Rokos <m.rokos@sh.cvut.cz>
	* LICENCE: update to latest Ruby's
	* extconf.rb: fix to make it work under Ruby 1.7.3
	* pkey.c: fix MACRO
	* ChangeLog: changed style
This commit is contained in:
taca 2003-07-06 14:22:44 +00:00
parent 02c1a7bc18
commit 2d8c6cc138
3 changed files with 25 additions and 6 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.4 2002/10/25 09:36:24 wiz Exp $
# $NetBSD: Makefile,v 1.5 2003/07/06 14:22:44 taca Exp $
DISTNAME= ossl-0.1.2a
PKGNAME= ${RUBY_PKGNAMEPREFIX}openssl-0.1.2.1
DISTNAME= ossl-0.1.3
PKGNAME= ${RUBY_PKGNAMEPREFIX}openssl-0.1.3
WRKSRC= ${WRKDIR}/ossl
CATEGORIES= security
MASTER_SITES= http://freesoftware.fsf.org/download/rubypki/

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.3 2002/08/30 23:48:22 taca Exp $
$NetBSD: distinfo,v 1.4 2003/07/06 14:22:44 taca Exp $
SHA1 (ruby/ossl-0.1.2a.tar.gz) = dc3382ef0344c7463a4d60454af10e6f894980c6
Size (ruby/ossl-0.1.2a.tar.gz) = 82993 bytes
SHA1 (ruby/ossl-0.1.3.tar.gz) = 1dff416c64f56908f448be76128cf2a1d27f17f2
Size (ruby/ossl-0.1.3.tar.gz) = 83282 bytes
SHA1 (patch-aa) = 43fd0b4e97acb1351c9b9cc032c76388fdad7941

View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.1 2003/07/06 14:22:44 taca Exp $
--- ossl.h.orig 2002-07-23 19:45:25.000000000 +0900
+++ ossl.h
@@ -25,9 +25,11 @@ extern "C" {
#include <openssl/ssl.h>
#include <openssl/hmac.h>
#include <openssl/rand.h>
-#include <openssl/e_os.h>
#if defined(NT)
+# include <openssl/e_os.h>
# undef OpenFile
+#else
+# define MS_CALLBACK
#endif
#include "openssl_missing.h"