Don't hardwire /usr/pkg; use $PREFIX instead. This fixes various

problems with linking and rpaths, such as the NetBSD manifestation of
PR 47187, and probably others; I haven't tried yet but I suspect at
least my manifestation of PR 44985 will be fixed too.
This commit is contained in:
dholland 2013-01-03 10:11:34 +00:00
parent 5e803a050d
commit 2da42d7c1f
3 changed files with 24 additions and 3 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.192 2012/12/12 10:13:47 spz Exp $
# $NetBSD: Makefile,v 1.193 2013/01/03 10:11:34 dholland Exp $
.include "license.mk"
.include "Makefile.common"
COMMENT= Practical Extraction and Report Language
PKGREVISION= 1
PKGREVISION= 2
CONFLICTS= perl-base-[0-9]* perl-thread-[0-9]* \
p5-CGI-2.66{,nb*} p5-CGI-2.75{,nb*} p5-CGI-2.75.[0-2] \

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.89 2012/12/12 10:13:47 spz Exp $
$NetBSD: distinfo,v 1.90 2013/01/03 10:11:34 dholland Exp $
SHA1 (perl-5.16.2.tar.gz) = 9e20e38e3460ebbac895341fd70a02189d03a490
RMD160 (perl-5.16.2.tar.gz) = 84f0233ac48059b4636661b023dd8a3389f9ae64
@ -15,6 +15,7 @@ SHA1 (patch-cn) = d1877383e213a414562b5bb4c1e8aa785926fab7
SHA1 (patch-cp) = 0b22d334df24d128142855464bf6dd61d4d82975
SHA1 (patch-cpan_Sys-Syslog_Syslog.xs) = 4413010d0b55a0ae636bca8ff3ace2ebc99e90ba
SHA1 (patch-dist_Locale-Maketext_lib_Locale_Maketext.pm) = d44647f32d356030c8c2cd6346559f613a7fe459
SHA1 (patch-hints_netbsd.sh) = 8a0656a72e81461f461757712b7fc27ad8928028
SHA1 (patch-hints_solaris_2.sh) = 26f804234c07da04ebd6c33ce7ad54d94c746f1e
SHA1 (patch-ta) = 51a3e02148e78eaab882125f859e59add39a4fbe
SHA1 (patch-zd) = 469602bc04b217f2d9929f5caeab43f77a74076f

View file

@ -0,0 +1,20 @@
$NetBSD: patch-hints_netbsd.sh,v 1.3 2013/01/03 10:11:34 dholland Exp $
--- hints/netbsd.sh~ 2012-10-11 18:20:45.000000000 +0000
+++ hints/netbsd.sh
@@ -186,10 +186,12 @@ esac
EOCBU
# Set sensible defaults for NetBSD: look for local software in
-# /usr/pkg (NetBSD Packages Collection) and in /usr/local.
+# /usr/local, plus the build prefix, which might or might not be
+# /usr/pkg.
#
-loclibpth="/usr/pkg/lib /usr/local/lib"
-locincpth="/usr/pkg/include /usr/local/include"
+loclibpth="/usr/local/lib ${prefix}/lib"
+locincpth="/usr/local/include ${prefix}/include"
+
case "$rpathflag" in
'')
ldflags=