jimtcl: update to 0.80.

Jim Tcl version 0.80:
---------------------

Bugs fixed in version 0.80

    return -level 0 -code xxx now returns the correct result
    regexp - fix an issue with failed optional group
    oo - fix an issue when no class variables are given
    oo - fix super invocation with multiple inheritance levels
    tailcall - fix to avoid growing the C stack frame
    regsub -all with \A now works correctly
    scan - fix an issue with chars vs bytes in utf-8 mode
    aio - fix eventloop and eof for ssl connections
    lsearch -regexp - fix the case where the pattern begins with a dash
    lsearch -command - handle the case with too few args
    Disallow renaming a local proc with upcall to avoid inconsistent behaviour

Features and improvements added in version 0.80

    Dictionaries now preserve insertion order
    string map and string compare now support embedded nulls
    string match and other glob matches now support embedded nulls
    Variable and proc names now support embedded nulls
    Interactive mode now prints results containing embedded nulls
    Generate a build warning if system is non-Y2038 compliant
    package names added as an alias for package list
    file rootname, file dirname are now more consistent with Tcl
    aio - add Server Name Indication (SNI) ssl support
    aio - add socket pty support
    The 0d radix prefix is now supported for decimal (base 10)
    String comparison operators lt, gt, le and ge are now supported
    dict getwithdefault (and the alias dict getdef) are now supported
    Build has coverage support, and test coverage is now over 90%
    Performance improvements in a number of areas


Jim Tcl version 0.79:
---------------------

Bugs fixed in version 0.79

    aio - Fix closing stdin in bootstrap jimsh
    clock scan - Unspecified fields use the current date/time
    Fix linenoise assertion failure on Windows
    file - Improved support for trailing slashes in pathnames
    regexp, regsub - Various fixes in UTF-8 mode
    $(...) syntax now properly returns non-error codes

Features added in version 0.78

    file - Add mtimeus for microsecond resolution
    file - Add missing split subcommand
    lreplace - Implement TIP #505
    aio - Add dgram unix socket support
    aio - Add support for lock -wait
    aio copyto - Significantly improve performance
    aio tty - Allow setting echo
    signal - Add block for blocking signals with SIG_IGN
    Add built-in JSON support with the json extension
    Improve performance when indexing UTF-8 strings

Other changes

    Documentation updates to improve consistency, remove obsolete commands, add some missing commands
    exec no longer forces SIGPIPE disposition to SIG_DFL
    Update autosetup to v0.6.9 with optimised insert/delete


Jim Tcl version 0.78:
---------------------

Bugs fixed in version 0.78

    local - Fix crash when local command is deleted
    history - When creating ~/.jim_history, set permissions to 0600 for security
    exec - Fix windows exec with empty or unset env
    exec - Fix check for | and |&
    jim.c - Fix Object leak in zlib support
    signal - Restore default signal handling on interp exit
    dict - Fix [dict values] with duplicate values
    Fix ‘/’ command, divide by zero
    expr - Replace expression engine to fix a number of problems
    zlib - Various fixes
    lsort -unique - Fix case with no duplicates
    aio tempname - Fix a crash when the template is invalid
    Tcl compatibility - Error on extra characters after close brace
    eventloop - Return from callback is not an error
    oo - Fix methods for superclasses
    Various refcount and edge case fixes found by fuzz testing

Features added in version 0.78

    Add support for utf-8 wide characters
    aio - Add tty for termios settings
    aio - Add sockopt for broadcast, tcp_nodelay, etc.
    utf-8 - Update UnicodeData.txt to 9.0.0
    jimsh - Add support for jimsh -
    jimsh - Scriptable command-line completion support via tcl::autocomplete
    history - Add autocompletion support history completion <cmd>
    Add support for -commands to many commands
    Add pkg-config support - jimtcl.pc
    clock - Add -gmt option to format and scan
    tree - Allow nodes to be deleted
    defer, $jim::defer - Allow scripts to run on proc exit
    eventloop - Support sub-millisecond timer resolution
    Support lambda even if references are disabled
    Performance - Improve a number of common cases through caching
    signal, exec, wait, pid, pipe - Many improvements
    build - Support --silent-rules, and enable by default
    regexp - Implement class shorthand escapes in brackets
    linenoise (jimsh) - Add ^Z (SUSP) support
    linenoise (jismh) - Update to support multiline mode

Other changes

    signal - Remove the signal command from child interpreters
    os.wait is now wait
    aio ssl now upgrades the current channel rather than creating a new channel
    Update autosetup to v0.6.8
This commit is contained in:
fcambus 2021-02-01 10:38:24 +00:00
parent 9734789a48
commit 2db397dd2e
5 changed files with 9 additions and 89 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2017/09/16 19:26:58 wiz Exp $
# $NetBSD: Makefile,v 1.5 2021/02/01 10:38:24 fcambus Exp $
DISTNAME= jimtcl-0.77
PKGREVISION= 1
DISTNAME= jimtcl-0.80
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GITHUB:=msteveb/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2016/10/31 01:15:12 kamil Exp $
@comment $NetBSD: PLIST,v 1.4 2021/02/01 10:38:24 fcambus Exp $
bin/build-jim-ext
bin/jimsh
include/jim-config.h
@ -10,4 +10,5 @@ include/jim.h
lib/jim/README.extensions
lib/jim/tcltest.tcl
lib/libjim.so.${PKGVERSION}
lib/pkgconfig/jimtcl.pc
share/doc/jimtcl/Tcl.html

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.4 2016/10/31 01:15:12 kamil Exp $
$NetBSD: distinfo,v 1.5 2021/02/01 10:38:24 fcambus Exp $
SHA1 (jimtcl-0.77.tar.gz) = 12f921997c140593b2dc82885fb15c2dad8012f0
RMD160 (jimtcl-0.77.tar.gz) = d6004a841d8032b23a81d72b849c37ff3682a1e8
SHA512 (jimtcl-0.77.tar.gz) = 47c50abcb06917ec85c19c3ff553bfc635c9fcc4e9ec707d8454adffade071e1f0051ee24b9a9d1dc7b83f5794229629b2de4eb37d0e3e8d6a1ba6bd72564901
Size (jimtcl-0.77.tar.gz) = 2925776 bytes
SHA1 (patch-auto.def) = 80ceb87a43873cd159486a04256efa60757bca85
SHA1 (patch-autosetup_cc.tcl) = 690c50dc850d09655f002fa72f0a2299a560fa65
SHA1 (jimtcl-0.80.tar.gz) = 3ac6f9ab9c2a6b1203dcfc14e7840b9f6c839226
RMD160 (jimtcl-0.80.tar.gz) = 5348b1849e3244b670dd392c64b5116ffef50101
SHA512 (jimtcl-0.80.tar.gz) = 37f14263f2101caaa632acf5e426dd7f1d6f75143875359c1daed59a039a9c64bbdf7941ce12b76bf9b209521b3967fd2b1d94a6afde7b2a8dd173d160858225
Size (jimtcl-0.80.tar.gz) = 3130592 bytes

View file

@ -1,24 +0,0 @@
$NetBSD: patch-auto.def,v 1.1 2016/10/31 01:15:12 kamil Exp $
Backport upstream patch:
From b7efe69818d2d12c0f004a5aaca70cd2ed2f388a Mon Sep 17 00:00:00 2001
From: Steve Bennett <steveb@workware.net.au>
Date: Wed, 26 Oct 2016 19:50:35 +1000
Subject: [PATCH] build: On NetBSD backtrace is in -lexecinfo
Signed-off-by: Steve Bennett <steveb@workware.net.au>
--- auto.def.orig 2016-10-31 01:07:00.830631530 +0000
+++ auto.def
@@ -106,6 +106,10 @@ cc-check-functions regcomp waitpid sigac
cc-check-functions syslog opendir readlink sleep usleep pipe getaddrinfo utimes
cc-check-functions shutdown socketpair isinf isnan link symlink fsync dup
+if {[cc-check-function-in-lib backtrace execinfo]} {
+ define-append LDLIBS [get-define lib_backtrace]
+}
+
if {[cc-check-functions sysinfo]} {
cc-with {-includes sys/sysinfo.h} {
cc-check-members "struct sysinfo.uptime"

View file

@ -1,54 +0,0 @@
$NetBSD: patch-autosetup_cc.tcl,v 1.1 2016/10/31 01:15:12 kamil Exp $
Backport upstream patch:
From 7d5a6e3b6f19a5c9260c131f428711320da452a0 Mon Sep 17 00:00:00 2001
From: Steve Bennett <steveb@workware.net.au>
Date: Wed, 26 Oct 2016 19:52:06 +1000
Subject: [PATCH] build: update autosetup for LIBS/LDFLAGS fix
343be844 cc tests should use LIBS and LDFLAGS
Signed-off-by: Steve Bennett <steveb@workware.net.au>
--- autosetup/cc.tcl.orig 2016-09-04 04:14:05.000000000 +0000
+++ autosetup/cc.tcl
@@ -210,7 +210,7 @@ proc cc-check-members {args} {
#
# If the function is found, the feature is defined and lib_$function is defined
# to -l$lib where the function was found, or "" if no library required.
-# In addition, -l$lib is added to the LIBS define.
+# In addition, -l$lib is prepended to the LIBS define.
#
# If additional libraries may be needed for linking, they should be specified
# as $extralibs as "-lotherlib1 -lotherlib2".
@@ -232,7 +232,8 @@ proc cc-check-function-in-lib {function
if {[cctest_function $function]} {
msg-result -l$lib
define lib_$function -l$lib
- define-append LIBS -l$lib
+ # prepend to LIBS
+ define LIBS "-l$lib [get-define LIBS]"
incr found
break
}
@@ -498,13 +499,17 @@ proc cctest {args} {
}
}
- if {!$opts(-link)} {
+ if {$opts(-link)} {
+ lappend cmdline {*}[get-define LDFLAGS]
+ } else {
set tmp conftest__.o
lappend cmdline -c
}
lappend cmdline {*}$opts(-cflags) {*}[get-define cc-default-debug ""]
-
lappend cmdline $src -o $tmp {*}$opts(-libs)
+ if {$opts(-link)} {
+ lappend cmdline {*}[get-define LIBS]
+ }
# At this point we have the complete command line and the
# complete source to be compiled. Get the result from cache if