Import of SSLeay, which uses RSAREF 2.0

This commit is contained in:
explorer 1998-09-04 22:00:33 +00:00
parent 9471769d97
commit 2dc72b771c
9 changed files with 401 additions and 0 deletions

36
security/ssleay/Makefile Normal file
View file

@ -0,0 +1,36 @@
# Eric Young's SSL/Crypto Library
# FreeBSD: Makefile,v 1.20 1998/08/27 16:38:02 markm Exp
# $NetBSD: Makefile,v 1.1.1.1 1998/09/04 22:00:33 explorer Exp $
#
DISTNAME= SSLeay-0.9.0b
CATEGORIES= devel security
MASTER_SITES= ftp://psych.psy.uq.oz.au/pub/Crypto/SSL/
MAINTAINER= explorer@netbsd.org
HOMEPAGE= http://www.psy.uq.oz.au/~ftp/Crypto/
DEPENDS= rsaref-2.0:../../security/rsaref
USE_PERL5= yes
RESTRICTED= "Crypto; export-controlled"
MIRROR_DISTFILE= no
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= util/NetBSD.sh
post-extract:
${CP} ${FILESDIR}/NetBSD.sh ${WRKSRC}/util/NetBSD.sh
post-configure:
${CP} ${WRKSRC}/rsaref/rsaref.h ${WRKSRC}/include/rsaref.h
(${PATCH} <${FILESDIR}/Makefile.patch)
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/SSLeay
@${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/SSLeay
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,15 @@
--- work/SSLeay-0.9.0b/Makefile.ssl~ Thu Sep 3 23:42:25 1998
+++ work/SSLeay-0.9.0b/Makefile.ssl Thu Sep 3 23:44:46 1998
@@ -61,9 +61,9 @@
CC= gcc
#CFLAG= -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -Wuninitialized -DMD5_ASM -DSHA1_ASM -DRMD160_ASM
-CFLAG= -DTERMIOS -DBN_ASM -D_ANSI_SOURCE -O3 -fomit-frame-pointer -m486 -Wall
-PEX_LIBS= -L. -L.. -L../.. -L../../..
-EX_LIBS=
+CFLAG= -DTERMIOS -DBN_ASM -DL_ENDIAN -D_ANSI_SOURCE -DRSAref -O3 -fomit-frame-pointer -m486 -Wall # -DSHA1_ASM -DMD5_ASM -DRMD160_ASM
+PEX_LIBS= -L. -L.. -L../.. -L../../.. -L/usr/pkg/lib
+EX_LIBS= -lRSAglue -lrsaref
AR=ar r
# Set BN_MULW to bn_mulw.o if you want to use the C version

20
security/ssleay/files/NetBSD.sh Executable file
View file

@ -0,0 +1,20 @@
#!/bin/sh
perl util/perlpath.pl /usr/pkg/bin
perl util/ssldir.pl /usr/pkg
case `uname -m` in
i386)
conf=NetBSD-x86
;;
sparc)
conf=NetBSD-sparc
;;
m68k)
conf=NetBSD-m86 # yes, this really IS m86, not m68!
;;
*)
echo "Not supported on this architecture, sorry."
;;
esac
perl Configure $conf

View file

@ -0,0 +1 @@
MD5 (SSLeay-0.9.0b.tar.gz) = 41c26258b20af611e9995968cbd89688

View file

@ -0,0 +1,38 @@
diff -udr ../SSLeay-0.8.1.ORIG/apps/ca.c ./apps/ca.c
--- ../SSLeay-0.8.1.ORIG/apps/ca.c Fri Jul 18 20:15:56 1997
+++ ./apps/ca.c Tue Feb 17 20:27:52 1998
@@ -82,7 +82,7 @@
#define PROG ca_main
#define BASE_SECTION "ca"
-#define CONFIG_FILE "lib/ssleay.cnf"
+#define CONFIG_FILE "etc/ssleay.cnf"
#define ENV_DEFAULT_CA "default_ca"
diff -udr ../SSLeay-0.8.1.ORIG/util/ssldir.pl ./util/ssldir.pl
--- ../SSLeay-0.8.1.ORIG/util/ssldir.pl Fri Jul 18 20:15:59 1997
+++ ./util/ssldir.pl Tue Feb 17 20:37:46 1998
@@ -4,7 +4,6 @@
@files=('crypto/cryptlib.h',
'Makefile.ssl',
'tools/c_rehash',
- 'util/mk1mf.pl',
);
%cryptlib=(
@@ -22,14 +21,9 @@
'^DIR=', 'DIR=%s',
);
-%mk1mf=(
- '^$INSTALLTOP=','$INSTALLTOP="%s";',
- );
-
&dofile("crypto/cryptlib.h",$ARGV[0],%cryptlib);
&dofile("Makefile.ssl",$ARGV[0],%Makefile_ssl);
&dofile("tools/c_rehash",$ARGV[0],%c_rehash);
-&dofile("util/mk1mf.pl",$ARGV[0],%mk1mf);
sub dofile
{

View file

@ -0,0 +1,18 @@
--- Makefile.ssl.orig Fri Jun 26 10:25:25 1998
+++ Makefile.ssl Sat Aug 22 13:14:34 1998
@@ -175,7 +175,7 @@
VERSION PROBLEMS MINFO makefile.one e_os.h \
MICROSOFT makevms.com config PATENTS
WDIRS= windows
-LIBS= libcrypto.a libssl.a
+LIBS= libcrypto.a libssl.a libRSAglue.a
GENERAL= Makefile
BASENAME= SSLeay
@@ -327,5 +327,6 @@
sh util/ranlib.sh $(INSTALLTOP)/lib/$$i; \
chmod 644 $(INSTALLTOP)/lib/$$i ); \
done
+ cp apps/ssleay.cnf $(INSTALLTOP)/etc/ssleay.cnf.sample
# DO NOT DELETE THIS LINE -- make depend depends on it.

View file

@ -0,0 +1 @@
SSL and crypto library

22
security/ssleay/pkg/DESCR Normal file
View file

@ -0,0 +1,22 @@
The package includes
libssl.a:
My implementation of SSLv2, SSLv3 and the required code to support
both SSLv2 and SSLv3 in the one server.
libcrypto.a:
General encryption and X509 stuff needed by SSL but not
actually logically part of it. It includes routines for the following:
Ciphers
libdes - My libdes DES encryption.
RC4, RC2, Blowfish, IDEA encryption
Digests
MD5 and MD2 message digest algorithms, fast implementations,
SHA (SHA-0) and SHA-1 message digest algorithms,
MDC2 message digest. A DES based hash that is polular on smart cards.
Public Key
RSA encryption/decryption/generation.
DSA encryption/decryption/generation.
Diffie-Hellman key-exchange/key generation.
There is no limit on the number of bits.
X509v3 certificates
X509 encoding/decoding into/from binary ASN1 and a PEM.
Program to generate RSA and DSA certificate requests and certificates.

250
security/ssleay/pkg/PLIST Normal file
View file

@ -0,0 +1,250 @@
bin/ssleay
@exec ln -sf %D/%F %B/asn1parse
@exec ln -sf %D/%F %B/base64
@exec ln -sf %D/%F %B/bf
@exec ln -sf %D/%F %B/bf-cbc
@exec ln -sf %D/%F %B/bf-cfb
@exec ln -sf %D/%F %B/bf-ecb
@exec ln -sf %D/%F %B/bf-ofb
@exec ln -sf %D/%F %B/ca
@exec ln -sf %D/%F %B/cast
@exec ln -sf %D/%F %B/cast-cbc
@exec ln -sf %D/%F %B/cast5-cbc
@exec ln -sf %D/%F %B/cast5-cfb
@exec ln -sf %D/%F %B/cast5-ecb
@exec ln -sf %D/%F %B/cast5-ofb
@exec ln -sf %D/%F %B/ciphers
@exec ln -sf %D/%F %B/crl
@exec ln -sf %D/%F %B/crl2pkcs7
@exec ln -sf %D/%F %B/des
@exec ln -sf %D/%F %B/des-cbc
@exec ln -sf %D/%F %B/des-cfb
@exec ln -sf %D/%F %B/des-ecb
@exec ln -sf %D/%F %B/des-ede
@exec ln -sf %D/%F %B/des-ede-cbc
@exec ln -sf %D/%F %B/des-ede-cfb
@exec ln -sf %D/%F %B/des-ede-ofb
@exec ln -sf %D/%F %B/des-ede3
@exec ln -sf %D/%F %B/des-ede3-cbc
@exec ln -sf %D/%F %B/des-ede3-cfb
@exec ln -sf %D/%F %B/des-ede3-ofb
@exec ln -sf %D/%F %B/des-ofb
@exec ln -sf %D/%F %B/des3
@exec ln -sf %D/%F %B/desx
@exec ln -sf %D/%F %B/dgst
@exec ln -sf %D/%F %B/dh
@exec ln -sf %D/%F %B/dsa
@exec ln -sf %D/%F %B/dsaparam
@exec ln -sf %D/%F %B/enc
@exec ln -sf %D/%F %B/errstr
@exec ln -sf %D/%F %B/gendh
@exec ln -sf %D/%F %B/genrsa
@exec ln -sf %D/%F %B/idea
@exec ln -sf %D/%F %B/idea-cbc
@exec ln -sf %D/%F %B/idea-cfb
@exec ln -sf %D/%F %B/idea-ecb
@exec ln -sf %D/%F %B/idea-ofb
@exec ln -sf %D/%F %B/md2
@exec ln -sf %D/%F %B/md5
@exec ln -sf %D/%F %B/mdc2
@exec ln -sf %D/%F %B/pkcs7
@exec ln -sf %D/%F %B/rc2
@exec ln -sf %D/%F %B/rc2-cbc
@exec ln -sf %D/%F %B/rc2-cfb
@exec ln -sf %D/%F %B/rc2-ecb
@exec ln -sf %D/%F %B/rc2-ofb
@exec ln -sf %D/%F %B/rc4
@exec ln -sf %D/%F %B/rc5
@exec ln -sf %D/%F %B/rc5-cbc
@exec ln -sf %D/%F %B/rc5-cfb
@exec ln -sf %D/%F %B/rc5-ecb
@exec ln -sf %D/%F %B/rc5-ofb
@exec ln -sf %D/%F %B/req
@exec ln -sf %D/%F %B/rsa
@exec ln -sf %D/%F %B/s_client
@exec ln -sf %D/%F %B/s_server
@exec ln -sf %D/%F %B/s_time
@exec ln -sf %D/%F %B/sess_id
@exec ln -sf %D/%F %B/sha
@exec ln -sf %D/%F %B/sha1
@exec ln -sf %D/%F %B/speed
@exec ln -sf %D/%F %B/verify
@exec ln -sf %D/%F %B/version
@exec ln -sf %D/%F %B/x509
@unexec rm %B/asn1parse
@unexec rm %B/base64
@unexec rm %B/bf
@unexec rm %B/bf-cbc
@unexec rm %B/bf-cfb
@unexec rm %B/bf-ecb
@unexec rm %B/bf-ofb
@unexec rm %B/ca
@unexec rm %B/cast
@unexec rm %B/cast-cbc
@unexec rm %B/cast5-cbc
@unexec rm %B/cast5-cfb
@unexec rm %B/cast5-ecb
@unexec rm %B/cast5-ofb
@unexec rm %B/ciphers
@unexec rm %B/crl
@unexec rm %B/crl2pkcs7
@unexec rm %B/des
@unexec rm %B/des-cbc
@unexec rm %B/des-cfb
@unexec rm %B/des-ecb
@unexec rm %B/des-ede
@unexec rm %B/des-ede-cbc
@unexec rm %B/des-ede-cfb
@unexec rm %B/des-ede-ofb
@unexec rm %B/des-ede3
@unexec rm %B/des-ede3-cbc
@unexec rm %B/des-ede3-cfb
@unexec rm %B/des-ede3-ofb
@unexec rm %B/des-ofb
@unexec rm %B/des3
@unexec rm %B/desx
@unexec rm %B/dgst
@unexec rm %B/dh
@unexec rm %B/dsa
@unexec rm %B/dsaparam
@unexec rm %B/enc
@unexec rm %B/errstr
@unexec rm %B/gendh
@unexec rm %B/genrsa
@unexec rm %B/idea
@unexec rm %B/idea-cbc
@unexec rm %B/idea-cfb
@unexec rm %B/idea-ecb
@unexec rm %B/idea-ofb
@unexec rm %B/md2
@unexec rm %B/md5
@unexec rm %B/mdc2
@unexec rm %B/pkcs7
@unexec rm %B/rc2
@unexec rm %B/rc2-cbc
@unexec rm %B/rc2-cfb
@unexec rm %B/rc2-ecb
@unexec rm %B/rc2-ofb
@unexec rm %B/rc4
@unexec rm %B/rc5
@unexec rm %B/rc5-cbc
@unexec rm %B/rc5-cfb
@unexec rm %B/rc5-ecb
@unexec rm %B/rc5-ofb
@unexec rm %B/req
@unexec rm %B/rsa
@unexec rm %B/s_client
@unexec rm %B/s_server
@unexec rm %B/s_time
@unexec rm %B/sess_id
@unexec rm %B/sha
@unexec rm %B/sha1
@unexec rm %B/speed
@unexec rm %B/verify
@unexec rm %B/version
@unexec rm %B/x509
bin/CA.sh
bin/der_chop
bin/c_hash
bin/c_info
bin/c_issuer
bin/c_name
bin/c_rehash
etc/ssleay.cnf.sample
include/crypto.h
include/cryptall.h
include/md2.h
include/md5.h
include/sha.h
include/mdc2.h
include/hmac.h
include/ripemd.h
include/des.h
include/rc2.h
include/rc4.h
include/rc5.h
include/idea.h
include/blowfish.h
include/cast.h
include/bn.h
include/rsa.h
include/dsa.h
include/dh.h
include/buffer.h
include/bio.h
include/bss_file.c
include/stack.h
include/lhash.h
include/rand.h
include/err.h
include/objects.h
include/evp.h
include/pem.h
include/asn1.h
include/asn1_mac.h
include/x509.h
include/x509_vfy.h
include/conf.h
include/txt_db.h
include/pkcs7.h
include/ssl.h
include/ssl2.h
include/ssl3.h
include/ssl23.h
include/tls1.h
lib/ssleay.cnf
lib/libcrypto.a
@exec ranlib %D/%F
lib/libssl.a
@exec ranlib %D/%F
lib/libRSAglue.a
@exec ranlib %D/%F
share/doc/SSLeay/API.doc
share/doc/SSLeay/a_verify.doc
share/doc/SSLeay/apps.doc
share/doc/SSLeay/asn1.doc
share/doc/SSLeay/bio.doc
share/doc/SSLeay/blowfish.doc
share/doc/SSLeay/bn.doc
share/doc/SSLeay/ca.1
share/doc/SSLeay/callback.doc
share/doc/SSLeay/cipher.doc
share/doc/SSLeay/cipher.m
share/doc/SSLeay/conf.doc
share/doc/SSLeay/des.doc
share/doc/SSLeay/digest.doc
share/doc/SSLeay/encode.doc
share/doc/SSLeay/envelope.doc
share/doc/SSLeay/error.doc
share/doc/SSLeay/idea.doc
share/doc/SSLeay/legal.doc
share/doc/SSLeay/lhash.doc
share/doc/SSLeay/md2.doc
share/doc/SSLeay/md5.doc
share/doc/SSLeay/memory.doc
share/doc/SSLeay/ms3-ca.doc
share/doc/SSLeay/ns-ca.doc
share/doc/SSLeay/obj.doc
share/doc/SSLeay/rand.doc
share/doc/SSLeay/rc2.doc
share/doc/SSLeay/rc4.doc
share/doc/SSLeay/readme
share/doc/SSLeay/ref.doc
share/doc/SSLeay/req.1
share/doc/SSLeay/rsa.doc
share/doc/SSLeay/rsaref.doc
share/doc/SSLeay/s_mult.doc
share/doc/SSLeay/session.doc
share/doc/SSLeay/sha.doc
share/doc/SSLeay/speed.doc
share/doc/SSLeay/ssl-ciph.doc
share/doc/SSLeay/ssl.doc
share/doc/SSLeay/ssl_ctx.doc
share/doc/SSLeay/ssleay.doc
share/doc/SSLeay/ssluse.doc
share/doc/SSLeay/stack.doc
share/doc/SSLeay/threads.doc
share/doc/SSLeay/txt_db.doc
share/doc/SSLeay/verify
share/doc/SSLeay/why.doc
@unexec rm -rf share/doc/SSLeay