Update to 0.5.1

Changes from 0.5.0 to 0.5.1
- monitor the _XAWTV_STATION property on the xawtv window and VPS/PDC (during
  EPG acquisition) to detect channel changes (new source module epgui/xawtv.c;
  communication with xawtv is now done directly via X11 calls, and no longer
  uses the xawtv-remote utility)
- after a channel change, optionally set the programme listing's cursor on
  the programme currently running on this channel and/or display the programme
  title and running time information inside xawtv, either in a popup, as
  overlay (requires xfree4 and the XVideo extension) or window title message.
- improved handling of the network name configuration dialog by addition of
  a "Closest match in xawtv" button.
- fix: during refresh, the cursor now remains on the same start time and network
- fix: short info text view is no longer set to line 1.0 during every update
- fix: possible crash due to reference to freed memory when acq timescale
  popup was open & bad reception (block discarded due to parity errors)
- fix: in cyclic or follow-ui acquisition modes when acquisition was forced
  passive on a non-provider channel (e.g. by a busy video device) acq control
  did not automatically switch to active when the device was freed.
- fix: network name configuration: name selection from the provider listbox
  was handled incorrectly for networks which were not covered by all providers,
  so that another than the selected name was actually used.
- added support for multi-network channel names (e.g. [Arte / Kinderkanal])
  to network name configuration: split xawtv station names around '/' and
  use all resulting segments for matching with Nextview network names.
- added support for Turkish charset in national option table; 6 characters
  which are not in latin-1 are replaced by their ASCII counterparts.
- fixed two memory leaks in the EPG scan and wrong handling of the EPG MIP
  entry, which slowed down the scan on several channels.
- changed Makefile.win32 to use gcc/mingw32 for compilation. The supplied
  Tcl/Tk libraries are compiled with gcc too (on NT using cygwin)
This commit is contained in:
magick 2001-06-09 15:14:25 +00:00
parent 271d5d6def
commit 2de817e9fd
5 changed files with 30 additions and 32 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2001/05/23 21:06:01 jlam Exp $
# $NetBSD: Makefile,v 1.7 2001/06/09 15:14:25 magick Exp $
DISTNAME= nxtvepg-0.5.0
DISTNAME= nxtvepg-0.5.1
CATEGORIES= misc
MASTER_SITES= http://www.nefkom.net/tomzo/prj/nxtvepg/src/

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.4 2001/05/23 21:06:01 jlam Exp $
$NetBSD: distinfo,v 1.5 2001/06/09 15:14:25 magick Exp $
SHA1 (nxtvepg-0.5.0.tar.gz) = a3ed2c251bc1920ff2cf7caea3d02d6bede0343a
Size (nxtvepg-0.5.0.tar.gz) = 310648 bytes
SHA1 (patch-aa) = f495cf6eda409ce414c8df93c28dd7de416aee2d
SHA1 (nxtvepg-0.5.1.tar.gz) = d171ac3ff22d1f2d58447abed8e70688f637b132
Size (nxtvepg-0.5.1.tar.gz) = 337600 bytes
SHA1 (patch-aa) = e7efa2a757405c82d35c36025564551e0e568af6
SHA1 (patch-ab) = 057fd7fc5e08a198e4ea800bfcb1dadf03363ce0
SHA1 (patch-ac) = 2a72e3ea0abdf0ec8e1514c7067576448bc82cdc
SHA1 (patch-ad) = 8c2000b19adb73082de8990a5b15b8ea8ede54b1
SHA1 (patch-ae) = d4e2411277d0e2eab54b1b8d0ee3e86e2deacee3
SHA1 (patch-ad) = bd176db9fedd6c21be8967a577af45956985113c
SHA1 (patch-ae) = e73e5bd9b08f58d7301fa19237861cada6e9b6fe

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2001/03/01 20:52:15 tron Exp $
$NetBSD: patch-aa,v 1.4 2001/06/09 15:14:26 magick Exp $
--- Makefile.orig Mon Feb 26 22:56:48 2001
--- Makefile.orig Mon Jun 4 21:25:11 2001
+++ Makefile
@@ -32,31 +32,31 @@
@@ -32,33 +32,33 @@
include Makefile.win32
else
@ -15,8 +15,8 @@ $NetBSD: patch-aa,v 1.3 2001/03/01 20:52:15 tron Exp $
-PERL = /usr/bin/perl
+PERL = $(LOCALBASE)/bin/perl
-LDLIBS = -ltk8.3 -ltcl8.3 -L/usr/X11R6/lib -lX11 -lm -ldl
+LDLIBS = -ltk83 -ltcl83 -L$(X11BASE)/lib -lX11 -lm
-LDLIBS = -ltk8.3 -ltcl8.3 -L/usr/X11R6/lib -lX11 -lXmu -lm -ldl
+LDLIBS = -ltk83 -ltcl83 -L$(X11BASE)/lib -lX11 -lm -lXmu
# use static libraries for debugging only
#LDLIBS = dbglib/libtk8.3.a dbglib/libtcl8.3.a -lX11 -lm -ldl -L/usr/X11R6/lib
@ -31,23 +31,24 @@ $NetBSD: patch-aa,v 1.3 2001/03/01 20:52:15 tron Exp $
+DEFS += -DTK_LIBRARY_PATH=\"$(LOCALBASE)/lib/tk8.3\"
+DEFS += -DTCL_LIBRARY_PATH=\"$(LOCALBASE)/lib/tcl8.3\"
# path to the directory where the provider database files are kept
-DEFS += -DEPG_DB_DIR=\"/usr/tmp/nxtvdb\"
+DEFS += -DEPG_DB_DIR=_PATH_TMP\"nxtvdb\"
#WARN = -Wall -Wpointer-arith -Wnested-externs \
# -Werror -Wstrict-prototypes -Wmissing-prototypes
WARN = -Wall
-CC = gcc
-CFLAGS = -pipe $(WARN) $(INCS) $(DEFS) -O
+#CC = gcc
CC = gcc
-CFLAGS = -pipe $(WARN) $(INCS) $(DEFS) -O2
+CFLAGS += $(WARN) $(INCS) $(DEFS)
# ----- don't change anything below ------------------------------------------
@@ -81,7 +81,7 @@
test -d $(BINDIR) || mkdirhier $(BINDIR)
@@ -85,7 +85,6 @@
test -d $(MANDIR) || mkdirhier $(MANDIR)
install -c -m 0755 nxtvepg $(BINDIR)
- install -c -m 0644 nxtvepg.1x $(MANDIR)
+ install -c -m 0644 nxtvepg.1x $(MANDIR)/nxtvepg.1
install -c -m 0644 nxtvepg.1 $(MANDIR)
- rm -f $(MANDIR)/nxtvepg.1x
##%.o: %.c
## $(CC) $(CFLAGS) -c *.c -o *.o

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ad,v 1.1.1.1 2001/02/18 19:17:24 tron Exp $
$NetBSD: patch-ad,v 1.2 2001/06/09 15:14:26 magick Exp $
--- nxtvepg.1x.orig Wed Feb 14 22:31:37 2001
+++ nxtvepg.1x Sun Feb 18 20:13:22 2001
--- nxtvepg.1.orig Wed Feb 14 22:31:37 2001
+++ nxtvepg.1 Sun Feb 18 20:13:22 2001
@@ -234,7 +234,7 @@
on Windows nxtvepg.ini in the current directory.
.Ip "\fB\-dbdir\fR \fIdirectory\fR" 4

View file

@ -1,17 +1,14 @@
$NetBSD: patch-ae,v 1.2 2001/04/23 20:37:32 tron Exp $
$NetBSD: patch-ae,v 1.3 2001/06/09 15:14:26 magick Exp $
--- epgui/epgmain.c.orig Sat Apr 21 21:44:48 2001
--- epgui/epgmain.c.orig Sat May 19 16:42:02 2001
+++ epgui/epgmain.c
@@ -104,7 +104,12 @@
@@ -105,6 +105,9 @@
static const char *rcfile = "nxtvepg.ini";
static const char *dbdir = ".";
#else
static const char *rcfile = "~/.nxtvepgrc";
+#ifdef __NetBSD__
+#include <paths.h>
+static const char *dbdir = _PATH_TMP "nxtvdb";
+#else
static const char *dbdir = "/usr/tmp/nxtvdb";
+#endif
static const char *rcfile = "~/.nxtvepgrc";
static const char *dbdir = EPG_DB_DIR;
#endif
static int videoCardIndex = -1;
static bool disableAcq = FALSE;