Add patches to avoid conflict with getline(3).
This commit is contained in:
parent
c27cdc7c9f
commit
2e2d53fb02
4 changed files with 74 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.10 2008/03/14 17:22:49 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.11 2009/08/11 15:26:22 taca Exp $
|
||||
|
||||
SHA1 (freetype1_1.4pre.20030402.orig.tar.gz) = 595d526813e63400b56a5993caa3e2ea18f2f92c
|
||||
RMD160 (freetype1_1.4pre.20030402.orig.tar.gz) = 9db8891cfb348faeb5387fba0b92dcae54cfed7c
|
||||
|
@ -13,3 +13,6 @@ SHA1 (patch-ttf2pk-ac) = 6e80f39b704dcbf06bc25cbc23c3a1ca5f978e74
|
|||
SHA1 (patch-ttf2pk-ad) = 0a4119f58af75cf338766b734ba16f0fc0f061ae
|
||||
SHA1 (patch-ttf2pk-ae) = 8671f5eb1bdc5bf956083cb87eeaa9a15baf2f91
|
||||
SHA1 (patch-ttf2pk-af) = 8a47cd019ad3ae3c503f20818e0a06c91312e858
|
||||
SHA1 (patch-ttf2pk-ag) = 010e74ab520c804b98209e28fc633a4a7e322e12
|
||||
SHA1 (patch-ttf2pk-ah) = 1681256ca085350a2913082aba2940558f95ed8d
|
||||
SHA1 (patch-ttf2pk-ai) = 06d81f0da124be3056a90ec62ebad0b04eb34324
|
||||
|
|
22
graphics/freetype-lib/patches/patch-ttf2pk-ag
Normal file
22
graphics/freetype-lib/patches/patch-ttf2pk-ag
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ttf2pk-ag,v 1.1 2009/08/11 15:26:22 taca Exp $
|
||||
|
||||
Avoid confliction with getline(3).
|
||||
|
||||
--- contrib/ttf2pk/newobj.c.orig 2002-06-21 02:34:37.000000000 +0900
|
||||
+++ contrib/ttf2pk/newobj.c
|
||||
@@ -128,13 +128,13 @@ get_line(FILE *f)
|
||||
|
||||
|
||||
/*
|
||||
- * getline() is a wrapper function for get_line(). It returns `False' in
|
||||
+ * pkgetline() is a wrapper function for get_line(). It returns `False' in
|
||||
* case of error and expects a pointer to a buffer to store the current
|
||||
* line. Additionally, the final newline character is stripped.
|
||||
*/
|
||||
|
||||
Boolean
|
||||
-getline(char **bufferp, FILE *f)
|
||||
+pkgetline(char **bufferp, FILE *f)
|
||||
{
|
||||
size_t l;
|
||||
|
15
graphics/freetype-lib/patches/patch-ttf2pk-ah
Normal file
15
graphics/freetype-lib/patches/patch-ttf2pk-ah
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ttf2pk-ah,v 1.1 2009/08/11 15:26:22 taca Exp $
|
||||
|
||||
Avoid confliction with getline(3).
|
||||
|
||||
--- contrib/ttf2pk/newobj.h.orig 2002-01-08 21:48:27.000000000 +0900
|
||||
+++ contrib/ttf2pk/newobj.h
|
||||
@@ -26,7 +26,7 @@ void *mycalloc(size_t len);
|
||||
void *myrealloc(void *oldp, size_t len);
|
||||
|
||||
char *get_line(FILE *f);
|
||||
-Boolean getline(char **bufferp, FILE *f);
|
||||
+Boolean pkgetline(char **bufferp, FILE *f);
|
||||
char *newstring(char *s);
|
||||
|
||||
ttfinfo *newchar(Font *fnt);
|
33
graphics/freetype-lib/patches/patch-ttf2pk-ai
Normal file
33
graphics/freetype-lib/patches/patch-ttf2pk-ai
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-ttf2pk-ai,v 1.1 2009/08/11 15:26:22 taca Exp $
|
||||
|
||||
Avoid confliction with getline(3).
|
||||
|
||||
--- contrib/ttf2pk/parse.c.orig 2002-03-15 10:33:52.000000000 +0900
|
||||
+++ contrib/ttf2pk/parse.c
|
||||
@@ -63,7 +63,7 @@ gettoken(char **bufferp, size_t *offsetp
|
||||
if (*bufferp)
|
||||
free(*bufferp);
|
||||
|
||||
- if (getline(bufferp, f) == False)
|
||||
+ if (pkgetline(bufferp, f) == False)
|
||||
oops("Premature end in encoding file.");
|
||||
|
||||
curp = *bufferp;
|
||||
@@ -187,7 +187,7 @@ readencoding(char **enc, Font *fnt, Bool
|
||||
"Token 258 in encoding must be make-array (]).");
|
||||
free(p);
|
||||
|
||||
- while (getline(&buffer, enc_file))
|
||||
+ while (pkgetline(&buffer, enc_file))
|
||||
{
|
||||
for (p = buffer; *p; p++)
|
||||
if (*p == '%')
|
||||
@@ -246,7 +246,7 @@ get_replacements(Font *fnt)
|
||||
if (replacement_file == NULL)
|
||||
oops("Cannot open replacement file `%s'.", real_replacement_name);
|
||||
|
||||
- while (getline(&buffer, replacement_file))
|
||||
+ while (pkgetline(&buffer, replacement_file))
|
||||
{
|
||||
for (p = buffer; *p; p++)
|
||||
if (*p == '%')
|
Loading…
Reference in a new issue