clion-bin: update to 2021.2.

Provided by Remy van Elst in PR 56373.

# CLion 2021.1.3 (211.7628.27 build)
- Code: Clangd    Bug CPP-25157   Use of undeclared identificator __cudaPushCallConfiguration
- No Subsystem    Bug CPP-25144   Code completion stops when including .h file in to .cu file
- Bug CPP-25687   Red CUDA code with VS toolchain (2021.1.2)
- Core    Bug IDEA-270078 Windows: Internal Error (./src/hotspot/share/runtime/safepoint.cpp:917), Illegal threadstate encountered
- Core. Installation  Bug IDEA-269591 IDE with Projector crashes on restart
- Core. Plugin Management Bug IDEA-262732 Dynamic plugin and lost settings after unload & load
- Core. Project Settings  Bug IDEA-270137 Project Structure dialog: after changing name of a module-level library it's shown as 'Empty Library'
- Bug IDEA-271303 It's not possible to add multiple sub-facets for a single facet
- Core. Quick Documentation   Exception   IDEA-256001 jpg, svg images aren't rendered in quick doc
- Core. Run. Configurations   Bug IDEA-265622 [new run config UI] Mnemonic tooltips appear above another dialog opened from the RC window
- Bug IDEA-268436 No longer possible to set temporary configurations limit
- Bug IDEA-266369 Don't invoke `RunManagerListener#runConfigurationAdded` with RunManagerImpl write lock
- User Interface  Bug IDEA-266927 Plugins settings page steals the focus from search box
- Bug IDEA-266854 IDE resets Windows File Explorer Recent Files list on start
- Bug IDEA-267018 ComponentPopupBuilder#adText not displayed anymore
- Bug IDEA-271223 Back button in Settings may open unexpected page
- Usability   IDEA-267294 "Stretch to Right"/"Stretch to Left": Ctrl+Shift+Arrow keys resize the dialog instead of text selection
- User Interface. Focus   Bug IDEA-251381 "git => compare branch" looses focus before list of branches can be displayed
- User Interface. Navigation  Bug IDEA-265789 Open in new window keybinding does not work in recent files view
- Bug IDEA-269778 In Quick Definition popup, left/right arrow keys move a caret instead of switching overrides
- User Interface. Plugins Bug IDEA-267878 Update notification from a disabled plugin after the plugin was already updated (Rider, Azure DevOps plugin)
- User Interface. Project View    Bug IDEA-268305 Hide empty middle packages option disables correct tree view of parent and children packages
- Console Bug PY-48157    Cursor in SciView does not move to next cell after execution with Ctrl+Enter
- No subsystem    Bug DBE-13148   Datasource color setting does not override children color settings
- Code Completion Feature DBE-4541    SQL:code completion: grant execute on <procedure> to ... does not suggest users
- Bug DBE-7781    Automatic alias shouldn't appear when not needed
- Bug DBE-2931    MSSQL: bad completion
- Bug DBE-10650   Bad completion for table aliases in INSERT
- Usability   DBE-7913    Computed columns in INSERT suggestion
- Usability   DBE-12479   More priority for sorting direction in completion
- Code Generation Bug DBE-13327   IDE generates trigger chunk in view DDL
- Code Highlighting   Bug DBE-13185   Unsupported option in CREATE MATERIALIZED VIEW
- Bug DBE-13316   False error highlighting in convert() clause
- Bug DBE-13262   Incorrect syntax errors for querying arrays in RedShift SQL
- Bug DBE-9271    PL/SQL: "Unable to resolve column 'sqlerrm'" at exception block
- Bug DBE-13188   Resolving of PL/SQL record type fields does not work in most cases.
- Bug DBE-13296   MSSQL dialect does not recognize Azure SQL command `CREATE DATABASE foo AS COPY OF bar`
- Bug DBE-13324   Wrong 'unresolved' in CREATE TABLE
- Connectivity    Cosmetics   DBE-13230   Data source invalid selection in the list
- Data Editor/Viewer  Bug DBE-13252   Table data editor action panel does not change color
- Bug DBE-13167   Wrong date is returned by Snowflake if session timezone is not UTC
- Usability   DBE-11774   Table is read-only when there is no schema qualifier (unresolved table references)
- Data Import/Export  Performance DBE-11370   import CSV into a HIVE table took forever
- Performance DBE-13139   Import to Redshift is still slow even with batch support. Probably tweak linesPerStatement parameter
- Diagrams    Bug DBE-13046   Data source color setting is not reflected on diagram anymore
- Bug DBE-13283   Adding a diagram note leads to `ClassCastException`
- Introspection   Bug DBE-13325   Better UI for dross-database synonyms
- Cosmetics   DBE-13326   Missing Row Security Policies icon
- DBE-13251   Wrong focus position after first navigation on table.column_name via Search Everywhere
- Bug DBE-12843   tSQLt - java.sql.SQLException when test returns a result set
- SQL Resolve Bug DBE-4531    Completion fails on table synonyms across databases

#  CLion 2020.3.4 (203.8084.11 build)
- Project Model   Bug     CPP-24398   Reloading CompDB project via editor widget doesn't show Build tool window
- Core. Project Settings  Bug     IDEA-259705     Module can't be deleted

# CLion 2020.2.5 (202.8194.17 build)
- Core. Indexing  Performance     IDEA-251642     Indexing dependncies hangs
- Core. SSH   Bug     IDEA-247283     SSH can't juxtapose a public key file with a public key from the agent if there's no private key file
- Editor  Bug     IDEA-248406     External annotations and code vision hints aren't shown if javadoc comment is shown in rendered form
- User Interface. Controls    Bug     IDEA-248210     "Find" and "Replace" don't remember text area size
- User Interface. Embedded Browser (JCEF) Bug     IDEA-250937     forward jcef log to user home
- Version Control Bug     IDEA-252307     Rebase modal no longer stores previously selected ref or options
- Bug     IDEA-249948     New git repositories do not show up in VCS dialog
- Version Control. Git    Bug     IDEA-248795     gitignore is not created during project creation in WebStorm
- Usability   IDEA-253889     Git Rebase dialog: copy the value from upstream to --onto field when it is added
- Usability   IDEA-251554     Pull-dialog: suggests pulling from the last entered branch, instead from tracked branch
- Console Bug     PY-45049    Types and parameters aren't shown in completion in Python Console
- Bug     PY-30650    iPython console gets totally unresponsive when using large Pandas Dataframe
- Debugger    Task    PY-44450    Consider disabling the "Drop into debugger on failed tests" flag by default
- Test Runner Bug     PY-43632    Unittest run configuration has two "Additional Arguments" fields

# CLion 2020.1.3 (201.8743.17 build)
- Unit Testing: Google Test   Bug CPP-20039   CLion 2020.1 - Selecting and running multiple cmake google tests results in "Preparation canceled"
- Core    Bug IDEA-243130 GoLand 2020.1.3 closes main window and can't bring to front if press ESC on `goland --help` window.
- Bug IDEA-241340 Timeout in tests during BaseFixture.disposeRootDisposable caused by LaterInvocator
- Core. File System   Bug IDEA-241524 When I create new files using de Angular CLI, the files are not visible immediately in the Project tab
- Bug IDEA-239947 Deadlock between EDT and Jar file attributes updater
- Core. IDE Settings  Usability   IDEA-240607 Import Settings should warn if user has incorrectly selected a folder without settings
- Core. Indexing  Performance IDEA-238706 Accessing index during PSI events
- Core. Installation  Bug IDEA-242558 Patches for the IDE with 32-bit JDK are not applied
- Bug IDEA-242552 IDEA doesn't start after update to 2020.2 EAP2 (202.5103.13)
- Core. Licensing Bug IDEA-245166 Do not popup license dialog for "optional"-licensed plugins, after license expiration
- Core. Plugin Management Bug IDEA-240538 Theme plugin auto apply after update reseting previous settings
- Exception   IDEA-241872 "Unexpected core classloasder" exception prevents startup
- Core. Project Settings  Bug IDEA-238053 Project Structure dialog does not apply changes when Eclipse project format is used
- Usability   IDEA-240068 error: java: error: release version 15 not supported when compiling project with JDK_X language level in misc.xml
- Editor. Large Files Bug IDEA-243589 IDE freeze / crash when large file is truncated
- Tools. Docker   Bug IDEA-240719 Docker's multi-tab drawing problem
- Bug IDEA-236451 Docker: Exec tabs for a container are closed only from the second time.
- Tools. Terminal Usability   IDEA-244778 Consider renaming 'Smart Command Handling' to 'Run Commands using IDE'
- User Interface  Bug IDEA-240549 Minor: missing space in Reopen Project dialog
- Performance IDEA-238301 Subpixel(LCD) text is slow with UI font in 2020.1, switching to greyscale antialiasing helps
- User Interface. Graphics    Bug IDEA-242042 Some icons are missing and some hardly visible in the Main menu
- User Interface. Project View    Performance IDEA-237974 UI freeze: com.intellij.openapi.module.impl.ModuleGroupersKt.splitByDotsJoiningIncorrectIdentifiers
- Version Control. Log    Bug IDEA-221930 Checkout revision keymap is gone.
- Code Insight    Performance PY-41402    UI freezes when processing references in python scratch files
- Debugger    Bug PY-40654    Switch off shape gathering for on demand variables in the debugger
- Skeletons   Performance PY-41828    PyCharm indexes entire filesystem due to unintended and misconfigured App Engine support
- DB Connectivity Bug DBE-10963   pgpass fails to parse if it has blank lines in it
- DB Console  Bug DBE-10837   Error: invalid identifier in Snowflake
- Bug DBE-9876    Force executing queries in read-only mode runs the wrong query
- DB Diff Bug DBE-10727   Compare schemas does not respect the column order
- DB Refactoring  Usability   DBE-10543   Button layout exactly the wrong way round (Compare DDL with Database)
- Data Views  Feature DBE-2516    Use Data Editor for editable views
- Usability   DBE-10707   Generated filter from Filter By context menu clears MongoDB projection
- Usability   DBE-8336    Shorten tab names in DataGrid with placement on the right/left
- Navigation & Search Bug DBE-11084   'Go to declaration or usages' not working on routines in query console window
- PL & DDL Editor Feature DBE-5756    Database - Adding datasource as DDL - adding whole folders besides files only
- SQL Completion  Feature DBE-11004   SQL Server Does Not Recognize "ADD SENSITIVITY CLASSIFICATION" Statement
- SQL Format and Style    Bug DBE-10779   Wrong indent when a command starts with a comment
- Bug DBE-11093   Formatting rules are ignored when formatting a constructor inside type body
- SQL General Bug DBE-10726   No ability to create a DDL data source if there are no folders attached
- Bug DBE-10999   Index creation with INCLUDE NULL KEYS causes error
- SQL Generation  Bug DBE-10334   Modify table action no more works from the editor
- Bug DBE-10724   Snowflake Table Creation Generates Invalid DDL w/ Comments on Primary Keys
- SQL Highlighting    Bug DBE-11007   ORDER BY ... FOR JSON in subquery
- Bug DBE-10748   Errors in SQL Editor for correct Oracle SQL statements
- Bug DBE-10778   MariaDB Dialect JSON_QUERY not recognized
- SQL Resolve Feature DBE-10457   New quick fix: refresh schema


# CLion 2019.3.6 (193.7288.25 build)
- Code: Clangd    Bug     CPP-18783   clangd crashes on catch.hpp
- Bug     CPP-19696   No concepts support with MSVC toolchain
- Core. Licensing Bug     IDEA-235344     Licence server address is cleared when it's unreachable
- Bug     IDEA-231811     Excessive number of writes to idea.key
- Core. Plugin Management Bug     IDEA-234444     failure to uninstall plugin
- Core. Statistics    Auto-reported Exception     IDEA-231639     Should be called at least in the state CONFIGURATION_STORE_INITIALIZED, the current state is: COMPONENTS_REGISTERED Current violators count: 1
- Exception   IDEA-228826     ERROR when open GoLand 2020.1 with plugin that defines registry key
- Version Control. Subversion Bug     IDEA-228828     IDEA does not propose to delete dir in svn when deleting a dir
- Debugger    Bug     PY-39307    Error prints in Debug Server run configuration cause by misplaced attach to process binaries
- SQL Generation  Bug     DBE-10396   Unable to resolve class com.intellij.database.model.DasObjectWithSource

# CLion 2019.2.5 (192.7142.39 build)
- Core. Diagrams  Exception   IDEA-218015     Attempt to export any diagram to svg image fails with NPE
- Core. File System   Feature     IDEA-152607     Non-destructive "safe write" mode
- Core. IDE Settings  Usability   IDEA-221387     Configure Gutter Icons opens Settings For New Projects
- Core. Installation  Bug     IDEA-223576     Impossible to update Pycharm 2019.1
- Bug     IDEA-215497     jbr/bin/java Access Denied during update from IC-192.4205.45 to IC-192.4488.21
- Core. Password Management   Bug     IDEA-223257     java.lang.NoSuchMethodError: 'void com.intellij.credentialStore.CredentialAttributes.<init>(java.lang.String, java.lang.String, java.lang.Class, boolean, int, kotlin.jvm.internal.DefaultConstructorMarker)'
- Core. Quick Documentation   Bug     IDEA-222946     identifier tooltip - due to scrollbar the tooltip window is not large (height) enough when there is only 1 or 2 lines in the tooltip. So the text is always obscured.
- Core. SSH   Bug     IDEA-222345     Allow users to update known_hosts in a one click
- Bug     IDEA-220958     SSHJ: ConnectTimeout option is being read from config as milliseconds but should be read as seconds
- Cosmetics   IDEA-222955     Error message cannot be fully read
- Core. Task Management   Bug     IDEA-222938     Can't uncheck "Enable Cache" in `Settings -> Tools -> Task`
- Editor. Code Completion Bug     IDEA-221425     Code completion broken and not configurable
- Editor. Editing Text    Bug     IDEA-221667     Pressing Option-Enter on warning while info popup is displayed and previous warning hasn't been cleared causes cursor to jump in editor
- User Interface. Focus   Bug     IDEA-221730     Stop services window from taking focus when opening a database table.
- User Interface. Graphics    Bug     IDEA-220577     Menu icons in Presentation mode are large
- Version Control. Git    Bug     IDEA-220499     Git merge --no-commit still perfroms a commit if conflicts occur
- Bug     IDEA-222125     Update project notification incorrectly considers recents when calculating number of commits matching filter
- Debugger    Bug     PY-37645    Debugger crashes with exit code -1073740791 (PyQt5)
- Bug     PY-37361    Pytest 2: Failed to find debugger in _pytest
- Bug     PY-26541    Changing format doesn't take effect on numpy array
- Bug     PY-37757    Debugging fail in IronPython with: AttributeError: 'module' object has no attribute 'EX_OK'
- Usability   PY-36952    Frightening stacktrace is shown when user stops debugger
- Test Runner Bug     PY-37841    _jb_pytest_runner 2019 fail to run some test
- No subsystem    Bug     DBE-9285    Inspections from commandline: SqlCaseVsCoalesceInspection fails with "registers INFORMATION level problem in batch mode"
- Bug     DBE-9154    No more right click option to refresh materialized view on PostgreSQL
- DB Connectivity Bug     DBE-5559    H2 embedded: mv.db extension as appended to the database file each time
- Bug     DBE-9136    Cannot change session to Azure SQL database after update to 2019.2.4
- Bug     DBE-3272    H2 Data Source: automatic detection of database files for MV_STORE format (.mv.db)
- Usability   DBE-9247    Adding data source via the explorer is confusing
- DB Console  Feature     DBE-2344    DB2: not possible to enable DBMS_OUTPUT
- Bug     DBE-9251    Cannot remove association with console for the once injected sql into a string fragment
- Bug     DBE-9260    Running "Execution Plan" on a recursive SQL results in java.lang.StackOverflowError"
- DB Diff Bug     DBE-9226    Compare tool generates invalid mariadb sql for drop index when generating migration script
- DB General  Bug     DBE-8736    Don't write database model on EDT
- DB Introspection    Feature     DBE-7213    Support System-Versioned Tables introspection and syntax
- Bug     DBE-6627    Sequences are not displayed in database structure for H2 databases
- Bug     DBE-9181    Refresh of external schemas in Redshift is unreliable
- Bug     DBE-9262    Mysql - No autosync - introspect schema doesn't introspect
- Bug     DBE-8000    MS SQL: table or column comments are truncated to 30 characters
- DB Refactoring  Bug     DBE-8776    Modify comment query lost umlauts in encoding mess even though previewed SQL is fine
- Cosmetics   DBE-8364    Edit Comment for DB Table Column Window
- DB Schema Views Feature     DBE-8608    Cannot reassign "drop" database object shortcut key
- Usability   DBE-9195    Schema patterns keep getting reset when I drop and recreate a database
- Usability   DBE-9248    Tables are not loading with the schema selected without refreshing
- Configuration Problem   DBE-9020    Database tool window -> Show intermediate nodes deactivated no longer works in 2019.2
- Data Import & Export    Bug     DBE-9254    PostgreSQL Copy results as SQL Inserts does not Quote Items Properly
- Data Views  Feature     DBE-5970    Transposed table in a table editor don't allow to resize a column name
- Bug     DBE-9157    Quick documentation for database rows produce invalid queries
- Bug     DBE-9217    When I press forward or backward button, Index is increased or decreased. But This can't renew the table. I think it is bug. Please fix this.
- Bug     DBE-8904    Transpose collapses field names
- Bug     DBE-9338    The row number is truncated in table view
- Usability   DBE-9179    Thousands separator in results rows count view
- PL & DDL Editor Bug     DBE-8649    DDL editor should always use UTF-8
- SQL Completion  Feature     DBE-9252    Completion: option to suggest only objects from current database/schema
- Bug     DBE-6024    Database completion/object navigation should not show filtered out objects
- Bug     DBE-7033    Bad completion for subquery
- Bug     DBE-1188    Code completion wrong when data source has many databases MySQL
- Usability   DBE-9070    Option to disable smart join completion
- Usability   DBE-9307    SQL: MySQL: code completion could suggest ALTER TABLE
- Usability   DBE-8957    Misleading icon in a completion list
- Usability   DBE-2234    SQL completion: useless item duplication
- SQL Format and Style    Bug     DBE-9249    PostgreSQL formatting: the "Keep new line after THEN, ELSE" options doesn't work
- Bug     DBE-9185    Unable to format correctly a view creation query that uses a "With query"
- SQL General Bug     DBE-2667    "Quote identifier" should choose correct case
- Bug     DBE-9376    MS SQL parses incorrectly when column alias is "load"
- SQL Generation  Bug     DBE-9366    DataGrip freezes 30 secs after launch
- SQL Highlighting    Bug     DBE-8370    OPENXML WITH clause is not recognized
- Bug     DBE-3688    SQL: MySQL: support correct limitations for CAST and CONVERT arguments
- Bug     DBE-9193    Good code is red when using dots in PostgreSQL CREATE VIEW WITH() option names
- Bug     DBE-5819    Bad SQL is green: MySQL `delete * from`
- Bug     DBE-9210    Inspection ['Delete' statement without 'where' clears all data in the table] should not be shown when selection made by JOIN
- Bug     DBE-9167    Snowflake SQL Dialect parsing error
- Bug     DBE-9317    Add az64 compression encoding support
- Bug     DBE-9264    Named parameters in SQL function calls are marked as syntax errors and broken by auto-format
- Bug     DBE-9353    Inlay hint is strange for VALUES
- Bug     DBE-9160    DataGrip: Error indicated if trying to execute SQL Server procedure using user parameters to pass value
- Bug     DBE-9108    Support SONAME syntax
- Bug     DBE-7426    MariaDB command JSON_VALUE not recognized
- Bug     DBE-9293    Sybase: unable to resolve "GO" symbol
- Bug     DBE-9271    PL/SQL: "Unable to resolve column 'sqlerrm'" at exception block
- Bug     DBE-8924    False warning about number of values when selecting identity column
- SQL Resolve Bug     DBE-6494    rowversion type is not recognized by Datagrip
- Usability   DBE-9261    Unable to select schema in SQL Resolution Scopes dialog

# CLion 2019.1.4 (191.7479.33 build)
- No subsystem	Bug 	CPP-15708 	[Android Studio Freeze] FileSymbolTablesCache trying to invalidate all files recursively
- Bug 	CPP-16313 	Exception occurs when compilation database project is opened not for the first time.
- Bug 	CPP-16044 	clangd doesn't parse cpp files if response files are used to pass arguments to the compiler in MSVC environment
- Bug 	CPP-15707 	[Android Studio Freeze] OCSourceGliderComponent taking too long to initialize
- Code: Highlighting and Inspections	Bug 	CPP-16259 	IllegalStateException: Failed to restart clangd server
- Core. File System	Bug 	IDEA-211677 	Deadlock/freeze on quitting IntelliJ IDEA
- Core. Platform API	Bug 	IDEA-211580 	AvailableSince annotations stopped being included after Kotlin dependency on IntelliJ changed from kotlin.build.custom.deps:intellij-core to kotlin.build:intellij-core
- Core. Quick Documentation	Bug 	IDEA-212079 	QuickDocumentation is unable to load SVG from the jar file
- Core. Run | Debug. Configurations	Bug 	IDEA-208525 	Changes to my Environment Variables in Configurations aren't saving
- Editor. Diff and Merge	Bug 	IDEA-210783 	Couldn't select items in 'Diff Between' window (Deployment/Remote Host Access) with UP/DOWN arrow keyboard keys
- User Interface	Bug 	IDEA-211968 	Recent projects menu/list contains paths with non-native slashes instead of project names
- Bug 	IDEA-211955 	"Open Recent" shows full path for consequently opened projects
- User Interface. Find, Replace, Usages	Bug 	IDEA-196030 	Find in Path | Open in Find Window does not work for current file scope with a scratch file
- Bug 	IDEA-176926 	All Places scope does not include scratch files and consoles
- Bug 	IDEA-204277 	Pinned "Find in Path" dialog is not closed when opening a project in the same window
- User Interface. Navigation	Usability 	IDEA-208718 	Implement the ability to move right/left on Navigation bar using additional shortcuts
- Usability 	IDEA-207554 	Cmd+E/Ctrl+E doesn't work for iterating recent files after Recent/Recent edited files union
- User Interface. Project View	Bug 	IDEA-204446 	Structure sidebar flashing content with frontend (html related) files
- Version Control. Git	Bug 	IDEA-210358 	Incoming/outgoing commits are checked on project opening before any manual git remote operation is done
- Version Control. Log	Bug 	IDEA-211128 	Git Log: commit selected in search results is scrolled away and hidden from view after search is cancelled
- Bug 	IDEA-211583 	Git file history doesn't follow rename if it was made in a merge commit
- Web. Flash and Flex	Bug 	IDEA-207927 	Error when generating configuration for maven project using flexmojos and flex modules
- Console	Bug 	PY-33216 	Pycharm freezes when viewing array
- Debugger	Bug 	PY-35010 	Debugger doesn't attach to Flask reloader when the file is executable
- Interpreters Settings	Bug 	PY-35141 	PyCharm doesn't activate the conda if Anaconda/Miniconda is installed in a non-default location and no other conda available in the system
- Bug 	PY-35914 	Can't install packages with conda interpreter when non-default installation path was used for Anaconda
- Test Runner	Bug 	PY-35062 	Tox output broken for 3.8.3
- DB Introspection	Bug 	DBE-8275 	Snowflake won’t load schemas even if other connections do
- SQL Format and Style	Bug 	DBE-7993 	PLPGSQL missing line break before INTO clause of SELECT commands
- Bug 	DBE-8223 	DataGrip Quote Identifier incorrectly enclosed variables and parameters for SQL Server. This is not correct syntax
- Cosmetics 	DBE-8355 	Different panel height for Generic SQL and Derby settings
- Cosmetics 	DBE-8356 	Extra separator between scheme chooser and option tabs in MS Windows
This commit is contained in:
wiz 2021-09-16 20:43:36 +00:00
parent 64373cc00f
commit 2e39aeac7c
4 changed files with 895 additions and 1817 deletions

View file

@ -1,10 +1,8 @@
# $NetBSD: Makefile,v 1.4 2020/12/04 20:45:07 nia Exp $
# $NetBSD: Makefile,v 1.5 2021/09/16 20:43:36 wiz Exp $
VERSION= 2018.3.4
VERSION= 2021.2
DISTNAME= CLion-${VERSION}
PKGNAME= clion-bin-${VERSION}
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://download.jetbrains.com/cpp/
@ -19,8 +17,8 @@ USE_JAVA2= 8
USE_TOOLS+= pax sed
REPLACE_PYTHON= bin/printenv.py \
bin/restart.py \
REPLACE_PYTHON+= bin/printenv.py
REPLACE_PYTHON+= bin/restart.py
.include "../../mk/bsd.prefs.mk"
@ -39,13 +37,20 @@ REPLACE_BASH+= bin/gdb/linux/bin/gcore
do-install:
cd ${WRKSRC} && \
${RM} -r bin/fsnotifier bin/fsnotifier-arm bin/clion.sh.orig\
bin/fsnotifier64 bin/libdbm64.so \
lib/pty4j-native/linux/x86/libpty.so \
lib/pty4j-native/linux/x86_64/libpty.so \
bin/clang bin/gdb bin/lldb jre64 bin/cmake plugins/tfsIntegration/lib/native \
plugins/python/helpers/pydev/pydevd_attach_to_process \
bin/libyjpagent-linux.so bin/libyjpagent-linux64.so && \
${RM} -r \
bin/clang \
bin/clion.sh.orig \
bin/fsnotifier \
bin/cmake \
bin/gdb \
bin/libdbm64.so \
lib/pty4j-native/ \
plugins/python-ce \
plugins/performanceTesting \
plugins/cwm-plugin \
jbr/lib \
jbr/bin \
bin/lldb && \
${ECHO} "idea.filewatcher.disabled=true" >> bin/idea.properties && \
${SED} -e "s|@@IDEA_HOME@@|${PREFIX}/${PKGNAME}|g" \
${FILESDIR}/clion.desktop > \

File diff suppressed because it is too large Load diff

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1 2019/03/03 17:42:40 youri Exp $
$NetBSD: distinfo,v 1.2 2021/09/16 20:43:36 wiz Exp $
SHA1 (CLion-2018.3.4.tar.gz) = 913e6c963049cc9c3d7e5371438205e3ba71b2e6
RMD160 (CLion-2018.3.4.tar.gz) = 920978275d50c304866b3cc84dbabef9ffa68914
SHA512 (CLion-2018.3.4.tar.gz) = ffe594b2df390cb41cd2c5629a1b8f9a80cf8463c05d22d43af2da3a8db73e9d52ebd70c15771b813c049299ce4b3a3765a4bd6f65fe59cbd904b3536f182d75
Size (CLion-2018.3.4.tar.gz) = 454682485 bytes
SHA1 (patch-bin_clion.sh) = 39563d59f2cab854ffcf1d5e5825082165bd4581
SHA1 (CLion-2021.2.tar.gz) = e91b85c4341ddd2d92a04acf6c9819e3883180f1
RMD160 (CLion-2021.2.tar.gz) = 7b0e71d3fb5123866d579b6c8f0e47229d0044d3
SHA512 (CLion-2021.2.tar.gz) = 9742c29f57ecf2ca4b69fa323241d12bb7660cd64b875d953cbf720bc54daaaf7dab14c487ef113368c8ad7cbb6733d34a4740bb0997d9ceb8ca702f1e30da32
Size (CLion-2021.2.tar.gz) = 750721029 bytes
SHA1 (patch-bin_clion.sh) = 3001ec036c37466ae93f14209508235fa1fd2fb1

View file

@ -1,24 +1,33 @@
$NetBSD: patch-bin_clion.sh,v 1.1 2019/03/03 17:42:40 youri Exp $
$NetBSD: patch-bin_clion.sh,v 1.2 2021/09/16 20:43:36 wiz Exp $
Add JVM options for a typical NetBSD setup.
--- bin/clion.sh.orig 2019-01-31 19:23:02.000000000 +0000
--- bin/clion.sh.orig 2021-07-27 09:48:41.000000000 +0000
+++ bin/clion.sh
@@ -21,6 +21,7 @@ message()
@@ -21,10 +21,10 @@ message()
fi
}
-if [ -z "$(command -v uname)" ] || [ -z "$(command -v realpath)" ] || [ -z "$(command -v dirname)" ] || [ -z "$(command -v cat)" ] || \
+if [ -z "$(command -v uname)" ] || [ -z "$(command -v dirname)" ] || [ -z "$(command -v cat)" ] || \
[ -z "$(command -v egrep)" ]; then
TOOLS_MSG="Required tools are missing:"
- for tool in uname realpath egrep dirname cat ; do
+ for tool in uname egrep dirname cat ; do
test -z "$(command -v $tool)" && TOOLS_MSG="$TOOLS_MSG $tool"
done
message "$TOOLS_MSG (SHELL=$SHELL PATH=$PATH)"
@@ -35,11 +35,12 @@ fi
GREP_OPTIONS=''
OS_TYPE=$(uname -s)
OS_ARCH=$(uname -m)
+CLION_JDK=@PKG_JAVA_HOME@
UNAME=`which uname`
GREP=`which egrep`
GREP_OPTIONS=""
@@ -201,6 +202,9 @@ fi
# ---------------------------------------------------------------------
IFS="$(printf '\n\t')"
"$JAVA_BIN" \
+ -Xmx4096 -Xms4096 \
+ -XX:-UseCompressedClassPointers \
+ -XX:-UseCompressedOops \
-classpath "$CLASSPATH" \
${VM_OPTIONS} \
"-XX:ErrorFile=$HOME/java_error_in_CLION_%p.log" \
# Ensure $IDE_HOME points to the directory where the IDE is installed.
# ---------------------------------------------------------------------
-IDE_BIN_HOME=$(dirname "$(realpath "$0")")
+IDE_BIN_HOME=$(dirname "$0")
IDE_HOME=$(dirname "${IDE_BIN_HOME}")
CONFIG_HOME="${XDG_CONFIG_HOME:-${HOME}/.config}"