add support for mdds and let pkg-config find zlib now.
reduce autotools requirements and make sure pthreads are used. TODO: libixion support (once it is added to pkgsrc)
This commit is contained in:
parent
b667fb3d34
commit
2e8b7a842d
5 changed files with 36 additions and 27 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.3 2013/11/20 20:04:36 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2013/11/30 16:11:15 richard Exp $
|
||||
|
||||
DISTNAME= liborcus-0.5.1
|
||||
PKGNAME= ${DISTNAME:S/lib//}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= http://kohei.us/files/orcus/src/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -14,20 +14,18 @@ LICENSE= mit
|
|||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= aclocal autoconf autoheader automake gmake pkg-config
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-boost-libdir=${BUILDLINK_PREFIX.boost-libs}/lib
|
||||
CONFIGURE_ARGS+= --with-boost-system=boost_system
|
||||
CONFIGURE_ARGS+= --disable-spreadsheet-model
|
||||
CONFIGURE_ARGS+= --disable-werror
|
||||
CONFIGURE_ENV+= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-L/usr/lib -lz"
|
||||
|
||||
PKGCONFIG_OVERRIDE+= liborcus.pc.in
|
||||
|
||||
pre-configure:
|
||||
set -e; cd ${WRKSRC}; \
|
||||
aclocal; autoheader; automake -a --foreign -i; autoconf
|
||||
PTHREAD_AUTO_VARS= yes
|
||||
|
||||
.include "../../devel/boost-libs/buildlink3.mk"
|
||||
.include "../../devel/mdds/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/08/24 16:12:10 jaapb Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/11/30 16:11:15 richard Exp $
|
||||
|
||||
SHA1 (liborcus-0.5.1.tar.bz2) = 9303d513e4b63a1d6e4bce7cfeb13635e568b466
|
||||
RMD160 (liborcus-0.5.1.tar.bz2) = 53c0cc12a3264b970f81ebb5b5c43208cee70688
|
||||
Size (liborcus-0.5.1.tar.bz2) = 1445106 bytes
|
||||
SHA1 (patch-bin_pack-release.sh) = 6eefed463a1bc44ce2cbceb128d347b3096768f0
|
||||
SHA1 (patch-configure) = b6d5ed475a5a5c761494d565d01cd595773650a0
|
||||
SHA1 (patch-src_parser_Makefile.am) = fb4e5b9bb037bec6b2dc55c47f3d4e74c61839c1
|
||||
SHA1 (patch-configure) = ac0fd8f94d5ae154266776b80acd41c3fe96e916
|
||||
SHA1 (patch-src_Makefile.in) = 734abfe6287972d704869a2ccf6534ea094d33ad
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: patch-configure,v 1.1 2013/08/24 16:12:10 jaapb Exp $
|
||||
$NetBSD: patch-configure,v 1.2 2013/11/30 16:11:15 richard Exp $
|
||||
|
||||
non GNU-sed don't seem to like '|' in regular expressions
|
||||
Remove tac linuxism and use tail -r instead
|
||||
--- configure.orig 2013-04-13 01:56:48.000000000 +0000
|
||||
+++ configure
|
||||
|
@ -8,7 +9,7 @@ Remove tac linuxism and use tail -r instead
|
|||
LDFLAGS_SAVE=$LDFLAGS
|
||||
if test "x$ax_boost_user_system_lib" = "x"; then
|
||||
- for libextension in `ls $BOOSTLIBDIR/libboost_system*.a* $BOOSTLIBDIR/libboost_system*.so* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_system.*\)\.\(so\|a\).*$;\1;' | tac` ; do
|
||||
+ for libextension in `ls $BOOSTLIBDIR/libboost_system*.a* $BOOSTLIBDIR/libboost_system*.so* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_system.*\)\.\(so\|a\).*$;\1;' | tail -r` ; do
|
||||
+ for libextension in `ls $BOOSTLIBDIR/libboost_system*.a* $BOOSTLIBDIR/libboost_system*.so* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_system\)\..*$;\1;' | tail -r` ; do
|
||||
ax_lib=${libextension}
|
||||
as_ac_Lib=`$as_echo "ac_cv_lib_$ax_lib''_exit" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for exit in -l$ax_lib" >&5
|
||||
|
@ -17,7 +18,7 @@ Remove tac linuxism and use tail -r instead
|
|||
done
|
||||
if test "x$link_system" != "xyes"; then
|
||||
- for libextension in `ls $BOOSTLIBDIR/boost_system*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_system.*\)\.\(dll\|a\).*$;\1;' | tac` ; do
|
||||
+ for libextension in `ls $BOOSTLIBDIR/boost_system*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_system.*\)\.\(dll\|a\).*$;\1;' | tail -r` ; do
|
||||
+ for libextension in `ls $BOOSTLIBDIR/boost_system*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_system\)\..*$;\1;' | tail -r` ; do
|
||||
ax_lib=${libextension}
|
||||
as_ac_Lib=`$as_echo "ac_cv_lib_$ax_lib''_exit" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for exit in -l$ax_lib" >&5
|
||||
|
|
24
converters/orcus/patches/patch-src_Makefile.in
Normal file
24
converters/orcus/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1 2013/11/30 16:11:15 richard Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2013-04-13 01:56:47.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -437,7 +437,8 @@ orcus_zip_dump_SOURCES = \
|
||||
orcus_zip_dump.cpp
|
||||
|
||||
orcus_zip_dump_LDADD = \
|
||||
- parser/liborcus-parser-@ORCUS_API_VERSION@.la
|
||||
+ parser/liborcus-parser-@ORCUS_API_VERSION@.la \
|
||||
+ $(BOOST_SYSTEM_LIB)
|
||||
|
||||
orcus_zip_dump_CPPFLAGS =
|
||||
|
||||
@@ -449,7 +450,8 @@ orcus_xml_dump_SOURCES = \
|
||||
|
||||
orcus_xml_dump_LDADD = \
|
||||
parser/liborcus-parser-@ORCUS_API_VERSION@.la \
|
||||
- liborcus/liborcus-@ORCUS_API_VERSION@.la
|
||||
+ liborcus/liborcus-@ORCUS_API_VERSION@.la \
|
||||
+ $(BOOST_SYSTEM_LIB)
|
||||
|
||||
orcus_xml_dump_CPPFLAGS = -I$(top_builddir)/lib/liborcus/liborcus.la $(COMMON_CPPFLAGS)
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-src_parser_Makefile.am,v 1.1 2013/08/24 16:12:10 jaapb Exp $
|
||||
|
||||
Link boost library properly
|
||||
--- src/parser/Makefile.am.orig 2013-04-12 14:25:03.000000000 +0000
|
||||
+++ src/parser/Makefile.am
|
||||
@@ -18,7 +18,7 @@ liborcus_parser_@ORCUS_API_VERSION@_la_S
|
||||
zip_archive.cpp \
|
||||
zip_archive_stream.cpp
|
||||
|
||||
-liborcus_parser_@ORCUS_API_VERSION@_la_LDFLAGS = -no-undefined
|
||||
+liborcus_parser_@ORCUS_API_VERSION@_la_LDFLAGS = -no-undefined -lboost_system
|
||||
liborcus_parser_@ORCUS_API_VERSION@_la_LIBADD = \
|
||||
$(ZLIB_LIBS)
|
||||
|
Loading…
Reference in a new issue