multimedia/harvid: patch out broken config tests

We don't need an extra set of config tests in the makefile to make
sure the right deps are installed, especially when they don't use the
right flags or the right syntax and don't work. Instead of trying to
fix them up, just remove them entirely.
This commit is contained in:
dholland 2021-12-27 04:18:59 +00:00
parent 3777e32bc5
commit 2e8d533a65
2 changed files with 22 additions and 13 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2021/10/26 11:01:06 nia Exp $
$NetBSD: distinfo,v 1.6 2021/12/27 04:18:59 dholland Exp $
BLAKE2s (harvid-0.8.3.tar.gz) = 14d5511a81fa537d6a82e3bc8585f42e29487000a897cf8736ae49130c5830a2
SHA512 (harvid-0.8.3.tar.gz) = 748475602c7279f10790523cbd5cbf34c9cd283ca9e959ac0535fbb5b4ee6d2fcab976c5ddba3fa40862552b49d73df7145f36d26c9fe708063505812537a8ac
Size (harvid-0.8.3.tar.gz) = 116446 bytes
SHA1 (patch-libharvid_timecode.h) = dca6192ad3bb7ea2bad3ae69d82fd0e12ec1efd3
SHA1 (patch-src_Makefile) = 84df56465b2f51ff9cd3f368cddb08c1ea7499af
SHA1 (patch-src_Makefile) = b552e41ab2bed2abf7c8057c74c6f003a83cbaf3

View file

@ -1,17 +1,26 @@
$NetBSD: patch-src_Makefile,v 1.1 2021/08/24 11:25:42 nia Exp $
$NetBSD: patch-src_Makefile,v 1.2 2021/12/27 04:18:59 dholland Exp $
echoing escapes considered harmful. Use printf instead.
Fixes build on NetBSD 9.99.x.
We don't need an extra set of config tests in the makefile, especially
ones that don't use the right flags and therefore don't work.
--- src/Makefile.orig 2018-11-30 22:30:41.000000000 +0000
+++ src/Makefile
@@ -16,7 +16,7 @@ ifeq ($(shell PKG_CONFIG_PATH=$(PKG_CONF
$(error "libpng is required - install libpng-dev")
endif
@@ -8,18 +8,6 @@ include ../common.mak
CONFIGTEMP=conf.out
-ifeq ($(shell PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) pkg-config --exists libavcodec libavformat libavutil libswscale || echo no), no)
- $(error "http://ffmpeg.org is required - install libavcodec-dev, libswscale-dev, etc")
-endif
-
-ifeq ($(shell PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) pkg-config --exists libpng || echo no), no)
- $(error "libpng is required - install libpng-dev")
-endif
-
-ifeq ($(shell $(ECHO) "\#include <stdio.h>\n\#include <jpeglib.h>\nint main() { struct jpeg_error_mgr jerr; jpeg_std_error(&jerr); return 0; }" | $(CC) -pipe -x c -o $(CONFIGTEMP) $(ARCHINCLUDES) $(LDFLAGS) - -ljpeg 2>/dev/null || echo no; $(RM) -f $(CONFIGTEMP)), no)
+ifeq ($(shell printf "#include <stdio.h>\n#include <jpeglib.h>\nint main() { struct jpeg_error_mgr jerr; jpeg_std_error(&jerr); return 0; }\n" | $(CC) -x c -o $(CONFIGTEMP) $(ARCHINCLUDES) $(LDFLAGS) - -ljpeg 2>/dev/null || echo no; $(RM) -f $(CONFIGTEMP)), no)
$(error "libjpeg is required - install libjpeg-dev, libjpeg8-dev or libjpeg62-dev")
endif
- $(error "libjpeg is required - install libjpeg-dev, libjpeg8-dev or libjpeg62-dev")
-endif
-
FLAGS=-I../libharvid/
FLAGS+=$(ARCHINCLUDES) $(ARCHFLAGS)
FLAGS+=`pkg-config --cflags libavcodec libavformat libavutil libpng libswscale`