py-test-testmon: updated to 1.2.0

v1.2.0
Failures are always re-executed.

v1.1.2
Another fix for an edge case, refactoring.

v1.1.1
Fixed behaviour when faced with keyboard interrupt or syntax errors

v1.1.0
Tracking external package updates

v1.0.3
pytest 6 support

v1.0.0
Big rewrite of testmon
This commit is contained in:
adam 2021-10-11 13:02:52 +00:00
parent 75e32e53cd
commit 2ea01d6907
4 changed files with 16 additions and 25 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2019/10/25 09:45:35 adam Exp $
# $NetBSD: Makefile,v 1.9 2021/10/11 13:02:52 adam Exp $
DISTNAME= pytest-testmon-0.9.19
DISTNAME= pytest-testmon-1.2.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pytest-testmon/}
@ -11,9 +11,11 @@ COMMENT= Py.test plug-in which selects tests affected by recent changes
LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-coverage>=4.0.0:../../devel/py-coverage
DEPENDS+= ${PYPKGPREFIX}-test>=2.8.0:../../devel/py-test
DEPENDS+= ${PYPKGPREFIX}-test>=5.0.0:../../devel/py-test
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2018/11/27 16:21:15 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2021/10/11 13:02:52 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -8,6 +8,12 @@ ${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/testmon/__init__.py
${PYSITELIB}/testmon/__init__.pyc
${PYSITELIB}/testmon/__init__.pyo
${PYSITELIB}/testmon/configure.py
${PYSITELIB}/testmon/configure.pyc
${PYSITELIB}/testmon/configure.pyo
${PYSITELIB}/testmon/db.py
${PYSITELIB}/testmon/db.pyc
${PYSITELIB}/testmon/db.pyo
${PYSITELIB}/testmon/process_code.py
${PYSITELIB}/testmon/process_code.pyc
${PYSITELIB}/testmon/process_code.pyo

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.10 2021/10/07 13:43:48 nia Exp $
$NetBSD: distinfo,v 1.11 2021/10/11 13:02:52 adam Exp $
RMD160 (pytest-testmon-0.9.19.tar.gz) = 980ee9c0b344200f1d93b631da0cfa58781674c3
SHA512 (pytest-testmon-0.9.19.tar.gz) = 28e5f75265373f5e65d45fc3a26e7926e6095265befa9ba61acfc8a230f5350738074ef11f35c462ba97d08c15a8fbf008e49483f6c9c2b9ab64fe324db94db2
Size (pytest-testmon-0.9.19.tar.gz) = 26805 bytes
SHA1 (patch-setup.py) = 1c10d0a3ba21e3a1aa6504f52b46cd916c4bc334
RMD160 (pytest-testmon-1.2.0.tar.gz) = c6a89795eceb6ccee63b788a299671e8ae2c2f40
SHA512 (pytest-testmon-1.2.0.tar.gz) = f999b681f64c7f54e2dfdcfe9617b7b9f14e3fbf2e2c01c772484ff37152cb1287f3270190d79e7bf04eba11a79110d6518ac174878d5792a1a1ec1104488bb8
Size (pytest-testmon-1.2.0.tar.gz) = 46187 bytes

View file

@ -1,16 +0,0 @@
$NetBSD: patch-setup.py,v 1.1 2020/05/31 20:49:33 joerg Exp $
--- setup.py.orig 2020-05-31 17:59:09.409031695 +0000
+++ setup.py
@@ -1,9 +1,10 @@
+import sys
from setuptools import setup
setup(
name='pytest-testmon',
description='find bugs 10x faster',
- long_description=''.join(open('README.rst').readlines()),
+ long_description=''.join(open('README.rst', **({'encoding': 'UTF-8'} if sys.version_info.major>=3 else {})).readlines()),
version='0.9.19',
license='MIT',
platforms=['linux', 'osx', 'win32'],