Fix return types.
This commit is contained in:
parent
fd3479feb5
commit
2ea03f3f2c
10 changed files with 167 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.14 2010/04/15 06:50:46 dholland Exp $
|
$NetBSD: distinfo,v 1.15 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
SHA1 (elm2.5.8.tar.gz) = bf09df75d0dc9097a1e69591bfb4872f860e00c7
|
SHA1 (elm2.5.8.tar.gz) = bf09df75d0dc9097a1e69591bfb4872f860e00c7
|
||||||
RMD160 (elm2.5.8.tar.gz) = c12dbefd0bf9d47ee4438673507a4693c4a6808c
|
RMD160 (elm2.5.8.tar.gz) = c12dbefd0bf9d47ee4438673507a4693c4a6808c
|
||||||
|
@ -20,3 +20,12 @@ SHA1 (patch-an) = 4f03314d53f8f4a8e120d73ced9eafd22f1fa00b
|
||||||
SHA1 (patch-ao) = 001eee84bc6e6239cfed31d4d9bf571a00220af0
|
SHA1 (patch-ao) = 001eee84bc6e6239cfed31d4d9bf571a00220af0
|
||||||
SHA1 (patch-ap) = 6240a5d8a0d376bc896c3f18e6ed6bed597d758e
|
SHA1 (patch-ap) = 6240a5d8a0d376bc896c3f18e6ed6bed597d758e
|
||||||
SHA1 (patch-aq) = 6821ffff099f9b9281c8dbceebd7b7fad6ac01b7
|
SHA1 (patch-aq) = 6821ffff099f9b9281c8dbceebd7b7fad6ac01b7
|
||||||
|
SHA1 (patch-src_a__sort.c) = 66ffb91e32caf22d438d10ac459a8c2803e95071
|
||||||
|
SHA1 (patch-src_alias.c) = 51cc2f50a4455dbe32a7e7901cdc3289c8d69f42
|
||||||
|
SHA1 (patch-src_calendar.c) = 76a76add2caf85545deb4d6b7e8b95e7fe819c79
|
||||||
|
SHA1 (patch-src_elm.c) = 399696f61d2b364e5b39278f28536d2540ab19b0
|
||||||
|
SHA1 (patch-src_fileio.c) = 601c387f56062bd75a5cbbcd02ed01a6671e2247
|
||||||
|
SHA1 (patch-src_read__rc.c) = 84288f4f4bba35ba0d9aa622a25caaa5a315a1ba
|
||||||
|
SHA1 (patch-src_screen.c) = 93e5f62113cf2ace837aed4822fbeb26f060bf19
|
||||||
|
SHA1 (patch-src_strings.c) = 157a198b18fa7db7e4c1fe86fe084c7b0c256a46
|
||||||
|
SHA1 (patch-utils_answer.c) = afd41f0f435fa00f730b761f9f46d09123e06975
|
||||||
|
|
23
mail/elm/patches/patch-src_a__sort.c
Normal file
23
mail/elm/patches/patch-src_a__sort.c
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
$NetBSD: patch-src_a__sort.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/a_sort.c.orig 2013-02-25 16:39:10.000000000 +0000
|
||||||
|
+++ src/a_sort.c
|
||||||
|
@@ -34,6 +34,8 @@ static char rcsid[] = "@(#)$Id: a_sort.c
|
||||||
|
#include "elm_globals.h"
|
||||||
|
#include "s_aliases.h"
|
||||||
|
|
||||||
|
+static void alias_old_current(long iindex);
|
||||||
|
+
|
||||||
|
char *alias_sort_name();
|
||||||
|
|
||||||
|
sort_aliases(entries, visible, are_in_aliases)
|
||||||
|
@@ -179,8 +181,7 @@ int longname;
|
||||||
|
return("*UNKNOWN-SORT-PARAMETER*");
|
||||||
|
}
|
||||||
|
|
||||||
|
-alias_old_current(iindex)
|
||||||
|
-long iindex;
|
||||||
|
+static void alias_old_current(long iindex)
|
||||||
|
{
|
||||||
|
/** Set current to the message that has "index" as it's
|
||||||
|
index number. This is to track the current message
|
13
mail/elm/patches/patch-src_alias.c
Normal file
13
mail/elm/patches/patch-src_alias.c
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-src_alias.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/alias.c.orig 2013-02-25 16:38:02.000000000 +0000
|
||||||
|
+++ src/alias.c
|
||||||
|
@@ -705,7 +705,7 @@ int num_to_delete;
|
||||||
|
return(0);
|
||||||
|
}
|
||||||
|
|
||||||
|
-alias()
|
||||||
|
+void alias(void)
|
||||||
|
{
|
||||||
|
/*
|
||||||
|
* Work with alias commands...
|
13
mail/elm/patches/patch-src_calendar.c
Normal file
13
mail/elm/patches/patch-src_calendar.c
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-src_calendar.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/calendar.c.orig 2013-02-25 16:39:42.000000000 +0000
|
||||||
|
+++ src/calendar.c
|
||||||
|
@@ -45,7 +45,7 @@ static char rcsid[] = "@(#)$Id: calendar
|
||||||
|
|
||||||
|
#include "s_error.h"
|
||||||
|
|
||||||
|
-scan_calendar()
|
||||||
|
+void scan_calendar(void)
|
||||||
|
{
|
||||||
|
FILE *calendar;
|
||||||
|
int count;
|
22
mail/elm/patches/patch-src_elm.c
Normal file
22
mail/elm/patches/patch-src_elm.c
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
$NetBSD: patch-src_elm.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/elm.c.orig 2013-02-25 16:40:15.000000000 +0000
|
||||||
|
+++ src/elm.c
|
||||||
|
@@ -63,6 +63,8 @@ static char rcsid[] = "@(#)$Id: elm.c,v
|
||||||
|
# include <sys/timeb.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+static void debug_message(void);
|
||||||
|
+
|
||||||
|
long bytes();
|
||||||
|
char *format_long(), *parse_arguments();
|
||||||
|
|
||||||
|
@@ -594,7 +596,7 @@ debug_page()
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-debug_message()
|
||||||
|
+static void debug_message(void)
|
||||||
|
{
|
||||||
|
/**** Spit out the current message record. Include EVERYTHING
|
||||||
|
in the record structure. **/
|
15
mail/elm/patches/patch-src_fileio.c
Normal file
15
mail/elm/patches/patch-src_fileio.c
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
$NetBSD: patch-src_fileio.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/fileio.c.orig 2013-02-25 16:40:58.000000000 +0000
|
||||||
|
+++ src/fileio.c
|
||||||
|
@@ -66,9 +66,7 @@ int err;
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-copy_message(dest_file, msgnum, cm_options)
|
||||||
|
-FILE *dest_file;
|
||||||
|
-int msgnum, cm_options;
|
||||||
|
+void copy_message(FILE *dest_file, int msgnum, int cm_options)
|
||||||
|
{
|
||||||
|
/** Copy selected message to destination file, with optional 'prefix'
|
||||||
|
as the prefix for each line. If remove_header is true, it will
|
23
mail/elm/patches/patch-src_read__rc.c
Normal file
23
mail/elm/patches/patch-src_read__rc.c
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
$NetBSD: patch-src_read__rc.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/read_rc.c.orig 2013-02-25 16:41:35.000000000 +0000
|
||||||
|
+++ src/read_rc.c
|
||||||
|
@@ -82,6 +82,7 @@ extern opts_menu *find_cfg_opts();
|
||||||
|
static int lineno = 0;
|
||||||
|
static int errors = 0;
|
||||||
|
|
||||||
|
+static void do_rc(FILE *file, int lcl);
|
||||||
|
|
||||||
|
static void
|
||||||
|
do_expand_env(descr, dest, src, destlen)
|
||||||
|
@@ -323,9 +324,7 @@ read_rc_file()
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-do_rc(file, lcl)
|
||||||
|
-FILE *file;
|
||||||
|
-int lcl;
|
||||||
|
+static void do_rc(FILE *file, int lcl)
|
||||||
|
{
|
||||||
|
static int prev_type = 0;
|
||||||
|
int x;
|
13
mail/elm/patches/patch-src_screen.c
Normal file
13
mail/elm/patches/patch-src_screen.c
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-src_screen.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/screen.c.orig 2013-02-25 16:42:10.000000000 +0000
|
||||||
|
+++ src/screen.c
|
||||||
|
@@ -252,7 +252,7 @@ show_headers()
|
||||||
|
return(TRUE);
|
||||||
|
}
|
||||||
|
|
||||||
|
-show_current()
|
||||||
|
+void show_current(void)
|
||||||
|
{
|
||||||
|
/** Show the new header, with all the usual checks **/
|
||||||
|
|
14
mail/elm/patches/patch-src_strings.c
Normal file
14
mail/elm/patches/patch-src_strings.c
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
$NetBSD: patch-src_strings.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- src/strings.c.orig 2013-02-25 16:42:37.000000000 +0000
|
||||||
|
+++ src/strings.c
|
||||||
|
@@ -165,8 +165,7 @@ char *string;
|
||||||
|
return string;
|
||||||
|
}
|
||||||
|
|
||||||
|
-split_word(buffer, first, rest)
|
||||||
|
-char *buffer, *first, *rest;
|
||||||
|
+void split_word(char *buffer, char *first, char *rest)
|
||||||
|
{
|
||||||
|
int len;
|
||||||
|
/** Rip the buffer into first word and rest of word, translating it
|
21
mail/elm/patches/patch-utils_answer.c
Normal file
21
mail/elm/patches/patch-utils_answer.c
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
$NetBSD: patch-utils_answer.c,v 1.1 2013/02/26 11:08:17 joerg Exp $
|
||||||
|
|
||||||
|
--- utils/answer.c.orig 2013-02-25 16:43:08.000000000 +0000
|
||||||
|
+++ utils/answer.c
|
||||||
|
@@ -53,6 +53,7 @@ DBZ *hash; /* dbz file for same */
|
||||||
|
char *get_alias_address(), *get_token(), *strip_parens(), *shift_lower();
|
||||||
|
|
||||||
|
static char *quit_word, *exit_word, *done_word, *bye_word;
|
||||||
|
+static void open_alias_file(void);
|
||||||
|
|
||||||
|
main(argc, argv)
|
||||||
|
int argc;
|
||||||
|
@@ -272,7 +273,7 @@ char *fullname, *name;
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-open_alias_file()
|
||||||
|
+static void open_alias_file(void)
|
||||||
|
{
|
||||||
|
/** open the user alias file **/
|
||||||
|
|
Loading…
Reference in a new issue