Add DragonFly. Ensure that StatusBar has a non-inline constructor,
otherwise GCC might not create the type info and bail out during linkage.
This commit is contained in:
parent
34e1a17fd2
commit
2ea4220459
4 changed files with 42 additions and 5 deletions
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/12/18 21:08:55 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.7 2006/03/28 20:42:48 joerg Exp $
|
||||
|
||||
SHA1 (boolean-6.7/boolean_6_7.zip) = c0d5dd7963e2f02be1ebe97eeddfb6a7377feaa3
|
||||
RMD160 (boolean-6.7/boolean_6_7.zip) = 5a1a926dd130312ea8255576993b92f826b2e30d
|
||||
Size (boolean-6.7/boolean_6_7.zip) = 3841104 bytes
|
||||
SHA1 (patch-aa) = d2287a7271b7aa0a50b1ef9d87bf5e5ba8a6db6e
|
||||
SHA1 (patch-ab) = 79e7c998362f0ab6e766207e376b5ff53abd2cab
|
||||
SHA1 (patch-ab) = 19bf76826a67bd640451c558e8e36d830c23ebf5
|
||||
SHA1 (patch-ac) = d76d86f827b745d2cb66c295fcf77eb8e99f7ba1
|
||||
SHA1 (patch-ad) = 1720ef30fa0c284f6eb4f70be0033e5d3a3cf383
|
||||
SHA1 (patch-ae) = 05bc774fe8f4651fa596de28cf7af1fce5868549
|
||||
|
|
|
@ -1,17 +1,25 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/08/24 11:30:18 dmcmahill Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2006/03/28 20:42:48 joerg Exp $
|
||||
|
||||
--- apps/edit/include/valuesvc.h.orig 2005-03-04 14:21:08.000000000 +0000
|
||||
+++ apps/edit/include/valuesvc.h 2005-08-11 01:52:56.000000000 +0000
|
||||
@@ -42,4 +42,5 @@
|
||||
@@ -38,9 +38,10 @@
|
||||
|
||||
#else
|
||||
|
||||
-#if defined(__NetBSD__)
|
||||
+#if defined(__NetBSD__) || defined(__DragonFly__)
|
||||
|
||||
#include <math.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include <float.h>
|
||||
@@ -49,5 +50,5 @@
|
||||
|
||||
@@ -48,7 +49,7 @@
|
||||
#define MAXDOUBLE DBL_MAX
|
||||
#endif
|
||||
#ifndef MAXLONG
|
||||
-#define MAXLONG 0x7fffffff
|
||||
+#define MAXLONG LONG_MAX
|
||||
#endif
|
||||
#else
|
||||
|
||||
|
|
14
cad/boolean/patches/patch-ad
Normal file
14
cad/boolean/patches/patch-ad
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ad,v 1.3 2006/03/28 20:42:48 joerg Exp $
|
||||
|
||||
--- modules/kbool/src/scanbeam.cpp.orig 2006-03-28 17:34:33.000000000 +0000
|
||||
+++ modules/kbool/src/scanbeam.cpp
|
||||
@@ -1417,3 +1417,9 @@ bool ScanBeam::writebeam()
|
||||
|
||||
return true;
|
||||
}
|
||||
+
|
||||
+#include "kbool/include/statusb.h"
|
||||
+
|
||||
+StatusBar::StatusBar()
|
||||
+{
|
||||
+}
|
13
cad/boolean/patches/patch-ae
Normal file
13
cad/boolean/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.3 2006/03/28 20:42:48 joerg Exp $
|
||||
|
||||
--- modules/kbool/include/statusb.h.orig 2006-03-28 17:33:35.000000000 +0000
|
||||
+++ modules/kbool/include/statusb.h
|
||||
@@ -32,7 +32,7 @@ class StatusBar
|
||||
{
|
||||
public:
|
||||
// constructor & destructor
|
||||
- StatusBar(){};
|
||||
+ StatusBar();
|
||||
~StatusBar(){};
|
||||
|
||||
virtual void SetXY(double = 0.0, double = 0.0)=0;
|
Loading…
Reference in a new issue