Fix build with newer boost.
This commit is contained in:
parent
651b6e88c7
commit
2ef2fb6345
15 changed files with 562 additions and 1 deletions
|
@ -1,5 +1,19 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/05/10 14:50:50 hasso Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
SHA1 (xsd-3.2.0+dep.tar.bz2) = d57fd3b326dcfab3af8fdc40fc3cf27fb9d7c7c5
|
||||
RMD160 (xsd-3.2.0+dep.tar.bz2) = da02eb15e607ee9b434f2a729c6f8a3da0981348
|
||||
Size (xsd-3.2.0+dep.tar.bz2) = 1054603 bytes
|
||||
SHA1 (patch-libcult-1.4.2_cult_mm_bits_evptr.hxx) = c0665ef9f6ee3c5ad1714988388d8c92cd9818ae
|
||||
SHA1 (patch-libcult-1.4.2_cult_mm_evptr.hxx) = d7aba021918d29ad5b5f4d5ea23e435b7d908e65
|
||||
SHA1 (patch-libcult-1.4.2_cult_mm_shptr.hxx) = b8f2d82601f43af706a65aedfcd7c1567e061db9
|
||||
SHA1 (patch-libcult-1.4.2_cult_mm_static-ptr.hxx) = 76225963ff8b710eafada502d4c0c918ffef416e
|
||||
SHA1 (patch-libxsd-frontend-1.15.0_xsd-frontend_parser.cxx) = 30a9b0aecf5605b6c37e72f1a3c8fbfce01140da
|
||||
SHA1 (patch-libxsd-frontend-1.15.0_xsd-frontend_semantic-graph_elements.cxx) = 717fca1076c9c4e33a3577cb6c23fa0a9ec1ceab
|
||||
SHA1 (patch-libxsd-frontend-1.15.0_xsd-frontend_semantic-graph_schema.hxx) = cbf09aa1272f6f163ce002db9f4578e5795eaaf3
|
||||
SHA1 (patch-libxsd-frontend-1.15.0_xsd-frontend_transformations_anonymous.cxx) = cfe1f7d86725ef2736e6198f5f8780e3656ce6f4
|
||||
SHA1 (patch-libxsd-frontend-1.15.0_xsd-frontend_transformations_schema-per-type.cxx) = 0ed23703a8f11984dc51e2bbdcc744b32a5be369
|
||||
SHA1 (patch-xsd-3.2.0-2_xsd_cxx_elements.cxx) = 8006dc3a16d945a9c256e0fd2a4c412ad63e8919
|
||||
SHA1 (patch-xsd-3.2.0-2_xsd_cxx_parser_elements.cxx) = 06702b980f04c5718b7c0aefb8d629466501f0d2
|
||||
SHA1 (patch-xsd-3.2.0-2_xsd_cxx_parser_generator.cxx) = b6263becce71dd133a6db5c0c23467c441c8da1e
|
||||
SHA1 (patch-xsd-3.2.0-2_xsd_xsd.cxx) = e89a36f5616416ad31fa47b1bba2018cb3fbaec9
|
||||
SHA1 (patch-xsd-3.2.0-2_xsd_xsd.hxx) = 9e64ecb2e5560bb21b7dcf324c1831a59b26f07d
|
||||
|
|
12
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_bits_evptr.hxx
Normal file
12
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_bits_evptr.hxx
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-libcult-1.4.2_cult_mm_bits_evptr.hxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libcult-1.4.2/cult/mm/bits/evptr.hxx.orig 2013-03-23 19:35:17.000000000 +0000
|
||||
+++ libcult-1.4.2/cult/mm/bits/evptr.hxx
|
||||
@@ -227,6 +227,7 @@ namespace Cult
|
||||
template <typename>
|
||||
friend class Transfer;
|
||||
|
||||
+ protected:
|
||||
mutable X* p_;
|
||||
mutable X const* cp_;
|
||||
mutable Counter* c_;
|
22
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_evptr.hxx
Normal file
22
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_evptr.hxx
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-libcult-1.4.2_cult_mm_evptr.hxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libcult-1.4.2/cult/mm/evptr.hxx.orig 2013-03-23 19:36:25.000000000 +0000
|
||||
+++ libcult-1.4.2/cult/mm/evptr.hxx
|
||||
@@ -70,7 +70,7 @@ namespace Cult
|
||||
Evptr&
|
||||
operator= (Evptr const& ep)
|
||||
{
|
||||
- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
|
||||
+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
|
||||
|
||||
return *this;
|
||||
}
|
||||
@@ -79,7 +79,7 @@ namespace Cult
|
||||
Evptr&
|
||||
operator= (Evptr<Y> const& ep)
|
||||
{
|
||||
- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
|
||||
+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
|
||||
|
||||
return *this;
|
||||
}
|
22
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_shptr.hxx
Normal file
22
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_shptr.hxx
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-libcult-1.4.2_cult_mm_shptr.hxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libcult-1.4.2/cult/mm/shptr.hxx.orig 2013-03-23 19:44:25.000000000 +0000
|
||||
+++ libcult-1.4.2/cult/mm/shptr.hxx
|
||||
@@ -45,7 +45,7 @@ namespace Cult
|
||||
Shptr&
|
||||
operator= (Shptr const& ap)
|
||||
{
|
||||
- assign (ap);
|
||||
+ this->assign (ap);
|
||||
return *this;
|
||||
}
|
||||
|
||||
@@ -53,7 +53,7 @@ namespace Cult
|
||||
Shptr&
|
||||
operator= (Shptr<Y> const& ap)
|
||||
{
|
||||
- assign (ap);
|
||||
+ this->assign (ap);
|
||||
return *this;
|
||||
}
|
||||
|
14
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_static-ptr.hxx
Normal file
14
devel/xsd/patches/patch-libcult-1.4.2_cult_mm_static-ptr.hxx
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-libcult-1.4.2_cult_mm_static-ptr.hxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libcult-1.4.2/cult/mm/static-ptr.hxx.orig 2013-03-23 19:33:43.000000000 +0000
|
||||
+++ libcult-1.4.2/cult/mm/static-ptr.hxx
|
||||
@@ -60,7 +60,8 @@ namespace Cult
|
||||
static X*
|
||||
instance_ ()
|
||||
{
|
||||
- static X* i = new (KeyList ()) X;
|
||||
+ KeyList k;
|
||||
+ static X* i = new (k) X;
|
||||
return i;
|
||||
}
|
||||
|
|
@ -0,0 +1,103 @@
|
|||
$NetBSD: patch-libxsd-frontend-1.15.0_xsd-frontend_parser.cxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libxsd-frontend-1.15.0/xsd-frontend/parser.cxx.orig 2013-03-23 19:50:39.000000000 +0000
|
||||
+++ libxsd-frontend-1.15.0/xsd-frontend/parser.cxx
|
||||
@@ -1126,7 +1126,7 @@ namespace XSDFrontend
|
||||
operator () (SemanticGraph::Path const& x,
|
||||
SemanticGraph::Path const& y) const
|
||||
{
|
||||
- return x.native_file_string () < y.native_file_string ();
|
||||
+ return x.string () < y.string ();
|
||||
}
|
||||
};
|
||||
|
||||
@@ -1446,8 +1446,8 @@ namespace XSDFrontend
|
||||
friend Boolean
|
||||
operator< (SchemaId const& x, SchemaId const& y)
|
||||
{
|
||||
- return x.path_.native_file_string () < y.path_.native_file_string ()
|
||||
- || (x.path_.native_file_string () == y.path_.native_file_string ()
|
||||
+ return x.path_.string () < y.path_.string ()
|
||||
+ || (x.path_.string () == y.path_.string ()
|
||||
&& x.ns_ < y.ns_);
|
||||
}
|
||||
|
||||
@@ -2029,7 +2029,7 @@ namespace XSDFrontend
|
||||
{
|
||||
// Retry as a native path.
|
||||
//
|
||||
- path = Path (loc, boost::filesystem::native);
|
||||
+ path = Path (loc);
|
||||
}
|
||||
|
||||
if (path.is_complete ())
|
||||
@@ -2129,7 +2129,7 @@ namespace XSDFrontend
|
||||
{
|
||||
// Retry as a native path.
|
||||
//
|
||||
- path = Path (loc, boost::filesystem::native);
|
||||
+ path = Path (loc);
|
||||
}
|
||||
|
||||
if (path.is_complete ())
|
||||
@@ -4121,8 +4121,7 @@ namespace XSDFrontend
|
||||
|
||||
|
||||
XSDFrontend::SemanticGraph::Path abs_path (
|
||||
- XML::transcode_to_narrow (e.getLocation ()->getURI ()),
|
||||
- boost::filesystem::native);
|
||||
+ XML::transcode_to_narrow (e.getLocation ()->getURI ()));
|
||||
|
||||
XSDFrontend::SemanticGraph::Path rel_path (ctx_.file (abs_path));
|
||||
|
||||
@@ -4176,7 +4175,7 @@ namespace XSDFrontend
|
||||
ctx_ (ctx)
|
||||
{
|
||||
setSystemId (XML::XMLChString (
|
||||
- String (abs_.native_file_string ())).c_str ());
|
||||
+ String (abs_.string())).c_str ());
|
||||
}
|
||||
|
||||
virtual Xerces::BinInputStream*
|
||||
@@ -4249,8 +4248,7 @@ namespace XSDFrontend
|
||||
|
||||
// base_uri should be a valid path by now.
|
||||
//
|
||||
- Path base (XML::transcode_to_narrow (base_uri),
|
||||
- boost::filesystem::native);
|
||||
+ Path base (XML::transcode_to_narrow (base_uri));
|
||||
|
||||
if (prv_id == 0)
|
||||
{
|
||||
@@ -4274,18 +4272,7 @@ namespace XSDFrontend
|
||||
|
||||
try
|
||||
{
|
||||
- Path path;
|
||||
-
|
||||
- try
|
||||
- {
|
||||
- path = Path (path_str);
|
||||
- }
|
||||
- catch (InvalidPath const&)
|
||||
- {
|
||||
- // Retry as a native path.
|
||||
- //
|
||||
- path = Path (path_str, boost::filesystem::native);
|
||||
- }
|
||||
+ Path path(path_str);
|
||||
|
||||
Path base_dir (base.branch_path ());
|
||||
|
||||
@@ -4307,9 +4294,9 @@ namespace XSDFrontend
|
||||
|
||||
using namespace Xerces;
|
||||
|
||||
- InputSource* is (
|
||||
+ InputSource* is =
|
||||
new (XMLPlatformUtils::fgMemoryManager)
|
||||
- InputSource (abs_path, rel_path, base, ctx_));
|
||||
+ InputSource (abs_path, rel_path, base, ctx_);
|
||||
|
||||
// Note that I can't use XMLPlatformUtils::fgMemoryManager here
|
||||
// since Wrapper4InputSource is-not-an XMemory.
|
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-libxsd-frontend-1.15.0_xsd-frontend_semantic-graph_elements.cxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libxsd-frontend-1.15.0/xsd-frontend/semantic-graph/elements.cxx.orig 2013-03-23 19:39:54.000000000 +0000
|
||||
+++ libxsd-frontend-1.15.0/xsd-frontend/semantic-graph/elements.cxx
|
||||
@@ -324,6 +324,6 @@ namespace XSDFrontend
|
||||
std::wostream&
|
||||
operator<< (std::wostream& os, XSDFrontend::SemanticGraph::Path const& path)
|
||||
{
|
||||
- return os << path.native_file_string ().c_str ();
|
||||
+ return os << path.c_str ();
|
||||
}
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-libxsd-frontend-1.15.0_xsd-frontend_semantic-graph_schema.hxx,v 1.1 2013/03/24 16:58:28 joerg Exp $
|
||||
|
||||
--- libxsd-frontend-1.15.0/xsd-frontend/semantic-graph/schema.hxx.orig 2013-03-23 19:41:18.000000000 +0000
|
||||
+++ libxsd-frontend-1.15.0/xsd-frontend/semantic-graph/schema.hxx
|
||||
@@ -234,7 +234,7 @@ namespace XSDFrontend
|
||||
friend class Bits::Graph<SemanticGraph::Node, Edge>;
|
||||
|
||||
using Scope::add_edge_left;
|
||||
- using Node::add_edge_right;
|
||||
+ using SemanticGraph::Node::add_edge_right;
|
||||
|
||||
Void
|
||||
add_edge_left (Uses& e)
|
|
@ -0,0 +1,52 @@
|
|||
$NetBSD: patch-libxsd-frontend-1.15.0_xsd-frontend_transformations_anonymous.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- libxsd-frontend-1.15.0/xsd-frontend/transformations/anonymous.cxx.orig 2013-03-23 19:45:17.000000000 +0000
|
||||
+++ libxsd-frontend-1.15.0/xsd-frontend/transformations/anonymous.cxx
|
||||
@@ -270,14 +270,7 @@ namespace XSDFrontend
|
||||
// Try to use the portable representation of the path. If that
|
||||
// fails, fall back to the native representation.
|
||||
//
|
||||
- try
|
||||
- {
|
||||
- file_str = file.string ();
|
||||
- }
|
||||
- catch (SemanticGraph::InvalidPath const&)
|
||||
- {
|
||||
- file_str = file.native_file_string ();
|
||||
- }
|
||||
+ file_str = file.string ();
|
||||
}
|
||||
|
||||
String name (
|
||||
@@ -354,14 +347,7 @@ namespace XSDFrontend
|
||||
// Try to use the portable representation of the path. If that
|
||||
// fails, fall back to the native representation.
|
||||
//
|
||||
- try
|
||||
- {
|
||||
- file_str = file.string ();
|
||||
- }
|
||||
- catch (SemanticGraph::InvalidPath const&)
|
||||
- {
|
||||
- file_str = file.native_file_string ();
|
||||
- }
|
||||
+ file_str = file.string ();
|
||||
}
|
||||
|
||||
String name (
|
||||
@@ -555,14 +541,7 @@ namespace XSDFrontend
|
||||
// Try to use the portable representation of the path. If that
|
||||
// fails, fall back to the native representation.
|
||||
//
|
||||
- try
|
||||
- {
|
||||
- file_str = file.string ();
|
||||
- }
|
||||
- catch (SemanticGraph::InvalidPath const&)
|
||||
- {
|
||||
- file_str = file.native_file_string ();
|
||||
- }
|
||||
+ file_str = file.string ();
|
||||
}
|
||||
|
||||
String name (
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-libxsd-frontend-1.15.0_xsd-frontend_transformations_schema-per-type.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- libxsd-frontend-1.15.0/xsd-frontend/transformations/schema-per-type.cxx.orig 2013-03-23 19:49:10.000000000 +0000
|
||||
+++ libxsd-frontend-1.15.0/xsd-frontend/transformations/schema-per-type.cxx
|
||||
@@ -311,7 +311,7 @@ namespace XSDFrontend
|
||||
|
||||
for (Schemas::Iterator i (schemas.begin ()); i != schemas.end (); ++i)
|
||||
{
|
||||
- NarrowString s ((*i)->used_begin ()->path ().leaf ());
|
||||
+ NarrowString s ((*i)->used_begin ()->path ().leaf ().c_str());
|
||||
|
||||
Size p (s.rfind ('.'));
|
||||
file_set.insert (
|
13
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_cxx_elements.cxx
Normal file
13
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_cxx_elements.cxx
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-xsd-3.2.0-2_xsd_cxx_elements.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- xsd-3.2.0-2/xsd/cxx/elements.cxx.orig 2013-03-23 19:59:02.000000000 +0000
|
||||
+++ xsd-3.2.0-2/xsd/cxx/elements.cxx
|
||||
@@ -208,7 +208,7 @@ namespace CXX
|
||||
}
|
||||
catch (SemanticGraph::InvalidPath const&)
|
||||
{
|
||||
- pair = path.native_file_string ();
|
||||
+ pair = path.string ();
|
||||
}
|
||||
}
|
||||
|
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-xsd-3.2.0-2_xsd_cxx_parser_elements.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- xsd-3.2.0-2/xsd/cxx/parser/elements.cxx.orig 2013-03-23 19:59:56.000000000 +0000
|
||||
+++ xsd-3.2.0-2/xsd/cxx/parser/elements.cxx
|
||||
@@ -229,15 +229,7 @@ namespace CXX
|
||||
// Try to use the portable representation of the path. If that
|
||||
// fails, fall back to the native representation.
|
||||
//
|
||||
- NarrowString path_str;
|
||||
- try
|
||||
- {
|
||||
- path_str = path.string ();
|
||||
- }
|
||||
- catch (SemanticGraph::InvalidPath const&)
|
||||
- {
|
||||
- path_str = path.native_file_string ();
|
||||
- }
|
||||
+ NarrowString path_str(path.string());
|
||||
|
||||
String inc_path;
|
||||
|
197
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_cxx_parser_generator.cxx
Normal file
197
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_cxx_parser_generator.cxx
Normal file
|
@ -0,0 +1,197 @@
|
|||
$NetBSD: patch-xsd-3.2.0-2_xsd_cxx_parser_generator.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- xsd-3.2.0-2/xsd/cxx/parser/generator.cxx.orig 2013-03-23 20:02:16.000000000 +0000
|
||||
+++ xsd-3.2.0-2/xsd/cxx/parser/generator.cxx
|
||||
@@ -539,7 +539,7 @@ namespace CXX
|
||||
{
|
||||
try
|
||||
{
|
||||
- Path fs_path (path, boost::filesystem::native);
|
||||
+ Path fs_path (path);
|
||||
ifs.open (fs_path, std::ios_base::in | std::ios_base::binary);
|
||||
|
||||
if (!ifs.is_open ())
|
||||
@@ -623,7 +623,7 @@ namespace CXX
|
||||
{
|
||||
if (NarrowString name = ops.value<CLI::extern_xml_schema> ())
|
||||
{
|
||||
- if (file_path.native_file_string () != name)
|
||||
+ if (file_path.string () != name)
|
||||
generate_xml_schema = false;
|
||||
}
|
||||
}
|
||||
@@ -692,12 +692,12 @@ namespace CXX
|
||||
String char_type (ops.value<CLI::char_type> ());
|
||||
String string_type;
|
||||
|
||||
- if (char_type == L"char")
|
||||
- string_type = L"::std::string";
|
||||
- else if (char_type == L"wchar_t")
|
||||
- string_type = L"::std::wstring";
|
||||
+ if (char_type == "char")
|
||||
+ string_type = "::std::string";
|
||||
+ else if (char_type == "wchar_t")
|
||||
+ string_type = "::std::wstring";
|
||||
else
|
||||
- string_type = L"::std::basic_string< " + char_type + L" >";
|
||||
+ string_type = "::std::basic_string< " + char_type + " >";
|
||||
|
||||
String xns;
|
||||
{
|
||||
@@ -705,7 +705,7 @@ namespace CXX
|
||||
xns = ctx.xs_ns_name ();
|
||||
}
|
||||
|
||||
- String buffer (L"::std::auto_ptr< " + xns + L"::buffer >");
|
||||
+ String buffer ("::std::auto_ptr< " + xns + "::buffer >");
|
||||
TypeMap::Namespace xsd ("http://www\\.w3\\.org/2001/XMLSchema");
|
||||
|
||||
xsd.types_push_back ("string", string_type);
|
||||
@@ -713,29 +713,29 @@ namespace CXX
|
||||
xsd.types_push_back ("token", string_type);
|
||||
xsd.types_push_back ("Name", string_type);
|
||||
xsd.types_push_back ("NMTOKEN", string_type);
|
||||
- xsd.types_push_back ("NMTOKENS", xns + L"::string_sequence");
|
||||
+ xsd.types_push_back ("NMTOKENS", xns + "::string_sequence");
|
||||
xsd.types_push_back ("NCName", string_type);
|
||||
|
||||
xsd.types_push_back ("ID", string_type);
|
||||
xsd.types_push_back ("IDREF", string_type);
|
||||
- xsd.types_push_back ("IDREFS", xns + L"::string_sequence");
|
||||
+ xsd.types_push_back ("IDREFS", xns + "::string_sequence");
|
||||
|
||||
xsd.types_push_back ("language", string_type);
|
||||
xsd.types_push_back ("anyURI", string_type);
|
||||
- xsd.types_push_back ("QName", xns + L"::qname");
|
||||
+ xsd.types_push_back ("QName", xns + "::qname");
|
||||
|
||||
xsd.types_push_back ("base64Binary", buffer, buffer);
|
||||
xsd.types_push_back ("hexBinary", buffer, buffer);
|
||||
|
||||
- xsd.types_push_back ("gDay", xns + L"::gday");
|
||||
- xsd.types_push_back ("gMonth", xns + L"::gmonth");
|
||||
- xsd.types_push_back ("gYear", xns + L"::gyear");
|
||||
- xsd.types_push_back ("gMonthDay", xns + L"::gmonth_day");
|
||||
- xsd.types_push_back ("gYearMonth", xns + L"::gyear_month");
|
||||
- xsd.types_push_back ("date", xns + L"::date");
|
||||
- xsd.types_push_back ("time", xns + L"::time");
|
||||
- xsd.types_push_back ("dateTime", xns + L"::date_time");
|
||||
- xsd.types_push_back ("duration", xns + L"::duration");
|
||||
+ xsd.types_push_back ("gDay", xns + "::gday");
|
||||
+ xsd.types_push_back ("gMonth", xns + "::gmonth");
|
||||
+ xsd.types_push_back ("gYear", xns + "::gyear");
|
||||
+ xsd.types_push_back ("gMonthDay", xns + "::gmonth_day");
|
||||
+ xsd.types_push_back ("gYearMonth", xns + "::gyear_month");
|
||||
+ xsd.types_push_back ("date", xns + "::date");
|
||||
+ xsd.types_push_back ("time", xns + "::time");
|
||||
+ xsd.types_push_back ("dateTime", xns + "::date_time");
|
||||
+ xsd.types_push_back ("duration", xns + "::duration");
|
||||
|
||||
// Fundamental C++ types.
|
||||
//
|
||||
@@ -800,7 +800,7 @@ namespace CXX
|
||||
|
||||
// Generate code.
|
||||
//
|
||||
- NarrowString name (file_path.leaf ());
|
||||
+ NarrowString name (file_path.leaf ().c_str());
|
||||
NarrowString skel_suffix (ops.value <CLI::skel_file_suffix> ());
|
||||
NarrowString impl_suffix (ops.value <CLI::impl_file_suffix> ());
|
||||
|
||||
@@ -906,9 +906,9 @@ namespace CXX
|
||||
cxx_driver_name = cxx_driver_expr.merge (name);
|
||||
}
|
||||
|
||||
- Path hxx_path (hxx_name, boost::filesystem::native);
|
||||
- Path ixx_path (ixx_name, boost::filesystem::native);
|
||||
- Path cxx_path (cxx_name, boost::filesystem::native);
|
||||
+ Path hxx_path (hxx_name);
|
||||
+ Path ixx_path (ixx_name);
|
||||
+ Path cxx_path (cxx_name);
|
||||
|
||||
Path hxx_impl_path;
|
||||
Path cxx_impl_path;
|
||||
@@ -916,16 +916,16 @@ namespace CXX
|
||||
|
||||
if (impl || driver)
|
||||
{
|
||||
- hxx_impl_path = Path (hxx_impl_name, boost::filesystem::native);
|
||||
- cxx_impl_path = Path (cxx_impl_name, boost::filesystem::native);
|
||||
- cxx_driver_path = Path (cxx_driver_name, boost::filesystem::native);
|
||||
+ hxx_impl_path = Path (hxx_impl_name);
|
||||
+ cxx_impl_path = Path (cxx_impl_name);
|
||||
+ cxx_driver_path = Path (cxx_driver_name);
|
||||
}
|
||||
|
||||
if (NarrowString dir = ops.value<CLI::output_dir> ())
|
||||
{
|
||||
try
|
||||
{
|
||||
- Path path (dir, boost::filesystem::native);
|
||||
+ Path path (dir);
|
||||
|
||||
hxx_path = path / hxx_path;
|
||||
ixx_path = path / ixx_path;
|
||||
@@ -978,7 +978,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (hxx_impl_path);
|
||||
- file_list.push_back (hxx_impl_path.native_file_string ());
|
||||
+ file_list.push_back (hxx_impl_path.string ());
|
||||
|
||||
if (!ops.value<CLI::force_overwrite> ())
|
||||
{
|
||||
@@ -1004,7 +1004,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (cxx_impl_path);
|
||||
- file_list.push_back (cxx_impl_path.native_file_string ());
|
||||
+ file_list.push_back (cxx_impl_path.string ());
|
||||
}
|
||||
|
||||
if (driver)
|
||||
@@ -1033,7 +1033,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (cxx_driver_path);
|
||||
- file_list.push_back (cxx_driver_path.native_file_string ());
|
||||
+ file_list.push_back (cxx_driver_path.string ());
|
||||
}
|
||||
|
||||
// Open the skel files.
|
||||
@@ -1049,7 +1049,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (hxx_path);
|
||||
- file_list.push_back (hxx_path.native_file_string ());
|
||||
+ file_list.push_back (hxx_path.string ());
|
||||
|
||||
if (inline_)
|
||||
{
|
||||
@@ -1062,7 +1062,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (ixx_path);
|
||||
- file_list.push_back (ixx_path.native_file_string ());
|
||||
+ file_list.push_back (ixx_path.string ());
|
||||
}
|
||||
|
||||
|
||||
@@ -1077,7 +1077,7 @@ namespace CXX
|
||||
}
|
||||
|
||||
unlinks.add (cxx_path);
|
||||
- file_list.push_back (cxx_path.native_file_string ());
|
||||
+ file_list.push_back (cxx_path.string ());
|
||||
}
|
||||
|
||||
// Print copyright and license.
|
||||
@@ -1136,7 +1136,7 @@ namespace CXX
|
||||
NarrowString guard_prefix (ops.value<CLI::guard_prefix> ());
|
||||
|
||||
if (!guard_prefix)
|
||||
- guard_prefix = file_path.branch_path ().native_directory_string ();
|
||||
+ guard_prefix = file_path.branch_path ().string ();
|
||||
|
||||
if (guard_prefix)
|
||||
guard_prefix += '_';
|
40
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_xsd.cxx
Normal file
40
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_xsd.cxx
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-xsd-3.2.0-2_xsd_xsd.cxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- xsd-3.2.0-2/xsd/xsd.cxx.orig 2013-03-23 19:56:31.000000000 +0000
|
||||
+++ xsd-3.2.0-2/xsd/xsd.cxx
|
||||
@@ -566,7 +566,7 @@ main (Int argc, Char* argv[])
|
||||
|
||||
try
|
||||
{
|
||||
- tu = SemanticGraph::Path (args[i], boost::filesystem::native);
|
||||
+ tu = SemanticGraph::Path (args[i]);
|
||||
}
|
||||
catch (SemanticGraph::InvalidPath const&)
|
||||
{
|
||||
@@ -604,7 +604,7 @@ main (Int argc, Char* argv[])
|
||||
if (NarrowString name =
|
||||
tree_ops->value<CXX::Tree::CLI::extern_xml_schema> ())
|
||||
{
|
||||
- if (tu.native_file_string () != name)
|
||||
+ if (tu.string () != name)
|
||||
gen_xml_schema = false;
|
||||
}
|
||||
}
|
||||
@@ -619,7 +619,7 @@ main (Int argc, Char* argv[])
|
||||
if (NarrowString name =
|
||||
parser_ops->value<CXX::Parser::CLI::extern_xml_schema> ())
|
||||
{
|
||||
- if (tu.native_file_string () != name)
|
||||
+ if (tu.string () != name)
|
||||
gen_xml_schema = false;
|
||||
}
|
||||
}
|
||||
@@ -730,7 +730,7 @@ main (Int argc, Char* argv[])
|
||||
try
|
||||
{
|
||||
paths.push_back (
|
||||
- SemanticGraph::Path (args[i], boost::filesystem::native));
|
||||
+ SemanticGraph::Path (args[i]));
|
||||
}
|
||||
catch (SemanticGraph::InvalidPath const&)
|
||||
{
|
13
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_xsd.hxx
Normal file
13
devel/xsd/patches/patch-xsd-3.2.0-2_xsd_xsd.hxx
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-xsd-3.2.0-2_xsd_xsd.hxx,v 1.1 2013/03/24 16:58:29 joerg Exp $
|
||||
|
||||
--- xsd-3.2.0-2/xsd/xsd.hxx.orig 2013-03-23 19:57:50.000000000 +0000
|
||||
+++ xsd-3.2.0-2/xsd/xsd.hxx
|
||||
@@ -38,7 +38,7 @@ struct AutoUnlink
|
||||
{
|
||||
if (!canceled_)
|
||||
{
|
||||
- std::remove (file_.native_file_string ().c_str ());
|
||||
+ std::remove (file_.string ().c_str ());
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in a new issue