Re-generate these patches because GNU patch doesn't accept them.

This commit is contained in:
tron 2008-12-16 16:49:52 +00:00
parent c3c4e532c6
commit 2f0c9868d2
3 changed files with 14 additions and 12 deletions

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.19 2008/12/05 16:31:52 tron Exp $
$NetBSD: distinfo,v 1.20 2008/12/16 16:49:52 tron Exp $
SHA1 (rtorrent-0.8.2.tar.gz) = 891093c5d600c2e3853eadbbec369a12dfe6ec11
RMD160 (rtorrent-0.8.2.tar.gz) = e86b0082d1788e4e7cd8fcf631f7f857d642c799
Size (rtorrent-0.8.2.tar.gz) = 506015 bytes
SHA1 (patch-ab) = 87873bb32166d00398ab0ef6421a6fe85a55c914
SHA1 (patch-ac) = b62de9ce834aa0422ec173e694d07e88aa1e2f47
SHA1 (patch-ad) = 902a95e7edcd4f1f6c4cebe04c28e5ddefc650cf
SHA1 (patch-ae) = cd24c34d28d1c15f028a3ba7b786e40592c7a395
SHA1 (patch-ad) = 04fafec083c7cb27eb2f5ef7fbc5f6ab2e4e4a55
SHA1 (patch-ae) = 49cb5e84f3759febfc93df874a10c90cafc249d8

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ad,v 1.1 2008/12/05 16:31:52 tron Exp $
$NetBSD: patch-ad,v 1.2 2008/12/16 16:49:52 tron Exp $
--- src/utils/directory.cc.orig 2008-12-05 13:20:16 +0100
+++ src/utils/directory.cc 2008-12-05 13:27:27 +0100
--- src/utils/directory.cc.orig 2008-05-07 13:19:11.000000000 +0100
+++ src/utils/directory.cc 2008-12-16 16:45:58.000000000 +0000
@@ -38,6 +38,7 @@
#include <algorithm>
@ -10,16 +10,17 @@ $NetBSD: patch-ad,v 1.1 2008/12/05 16:31:52 tron Exp $
#include <dirent.h>
#include <rak/path.h>
#include <torrent/exceptions.h>
@@ -63,6 +64,8 @@
@@ -63,7 +64,9 @@
if (m_path.empty())
throw torrent::input_error("Directory::update() tried to open an empty path.");
- DIR* d = opendir(rak::path_expand(m_path).c_str());
+ std::string path=rak::path_expand(m_path);
+
- DIR* d = opendir(rak::path_expand(m_path).c_str());
+ DIR* d = opendir(path.c_str());
if (d == NULL)
return false;
@@ -73,12 +76,18 @@
while ((entry = readdir(d)) != NULL) {
if ((flags & update_hide_dot) && entry->d_name[0] == '.')

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.1 2008/12/05 16:31:52 tron Exp $
$NetBSD: patch-ae,v 1.2 2008/12/16 16:49:52 tron Exp $
--- src/utils/directory.h.orig 2008-12-05 13:22:18 +0100
+++ src/utils/directory.h 2008-12-05 13:22:24 +0100
@@ -49,7 +49,6 @@
--- src/utils/directory.h.orig 2008-05-07 13:19:11.000000000 +0100
+++ src/utils/directory.h 2008-12-16 16:45:58.000000000 +0000
@@ -49,8 +49,7 @@
// The name and types should match POSIX.
uint32_t d_fileno;
@ -11,3 +11,4 @@ $NetBSD: patch-ae,v 1.1 2008/12/05 16:31:52 tron Exp $
+ uint32_t d_type;
std::string d_name;
};