Fix acnlt() return value handling for NetBSD sound device.
From John E. Krokes in PR 41171. Bump PKGREVISION.
This commit is contained in:
parent
f4ea60db27
commit
2f19c13c55
4 changed files with 20 additions and 18 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.66 2009/02/06 19:45:52 shattered Exp $
|
||||
# $NetBSD: Makefile,v 1.67 2009/04/10 18:45:15 wiz Exp $
|
||||
|
||||
DISTNAME= TiMidity++-2.13.2
|
||||
PKGNAME= ${DISTNAME:S/TiMidity++/timidity/}
|
||||
PKGREVISION= 10
|
||||
PKGREVISION= 11
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=timidity/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.13 2007/06/08 17:18:53 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.14 2009/04/10 18:45:15 wiz Exp $
|
||||
|
||||
SHA1 (TiMidity++-2.13.2.tar.bz2) = 8e603146e1164335303a5ac5dff291f369241b4e
|
||||
RMD160 (TiMidity++-2.13.2.tar.bz2) = 0156221846a88abef9312700a050972d85084fd8
|
||||
Size (TiMidity++-2.13.2.tar.bz2) = 1581230 bytes
|
||||
SHA1 (patch-aa) = ccae42f9629b287da55f0b834557d154719f23d3
|
||||
SHA1 (patch-ab) = 6c4938e1b31dc066354aebd364c848bb88b20eb4
|
||||
SHA1 (patch-aa) = 14151d3b036eac740bca40c97a0eff7de059514d
|
||||
SHA1 (patch-ab) = 7bd5c12448970131ee31e16de5952b11a093da23
|
||||
SHA1 (patch-ac) = 56e738ef60dc8040d27bb50722ed5e0294d343e4
|
||||
SHA1 (patch-ae) = 3f55ea58e91bd97ff42fbe67e8c89514c29aa2e9
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.7 2007/06/08 17:18:53 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.8 2009/04/10 18:45:16 wiz Exp $
|
||||
|
||||
--- timidity/sun_a.c.orig 2007-06-08 17:14:22.000000000 +0000
|
||||
--- timidity/sun_a.c.orig 2004-09-26 23:40:14.000000000 +0000
|
||||
+++ timidity/sun_a.c
|
||||
@@ -300,6 +300,18 @@ int output_data(char *buff, int32 nbytes
|
||||
@@ -296,6 +296,18 @@ int output_data(char *buff, int32 nbytes
|
||||
|
||||
|
||||
#if !defined(I_FLUSH) || !defined(FLUSHW)
|
||||
|
@ -21,7 +21,7 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 17:18:53 wiz Exp $
|
|||
static void null_proc(){}
|
||||
static int sun_discard_playing(void)
|
||||
{
|
||||
@@ -312,6 +324,7 @@ static int sun_discard_playing(void)
|
||||
@@ -308,6 +320,7 @@ static int sun_discard_playing(void)
|
||||
signal(SIGALRM, orig_alarm_handler);
|
||||
return open_output();
|
||||
}
|
||||
|
@ -29,7 +29,7 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 17:18:53 wiz Exp $
|
|||
#else
|
||||
static int sun_discard_playing(void)
|
||||
{
|
||||
@@ -332,6 +345,21 @@ static int acntl(int request, void *arg)
|
||||
@@ -328,6 +341,23 @@ static int acntl(int request, void *arg)
|
||||
|
||||
switch(request)
|
||||
{
|
||||
|
@ -37,12 +37,14 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 17:18:53 wiz Exp $
|
|||
+ case PM_REQ_GETQSIZ:
|
||||
+ if(ioctl(audioctl_fd, AUDIO_GETINFO, &auinfo) < 0)
|
||||
+ return -1;
|
||||
+ return auinfo.play.buffer_size;
|
||||
+ *((int *)arg) = auinfo.play.buffer_size;
|
||||
+ return 0;
|
||||
+
|
||||
+ case PM_REQ_GETFRAGSIZ:
|
||||
+ if(ioctl(audioctl_fd, AUDIO_GETINFO, &auinfo) < 0)
|
||||
+ return -1;
|
||||
+ return auinfo.blocksize;
|
||||
+ *((int *)arg) = auinfo.blocksize;
|
||||
+ return 0;
|
||||
+
|
||||
+ case PM_REQ_OUTPUT_FINISH:
|
||||
+ return ioctl(audioctl_fd, AUDIO_DRAIN, NULL);
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.13 2005/11/19 21:21:23 kristerw Exp $
|
||||
$NetBSD: patch-ab,v 1.14 2009/04/10 18:45:16 wiz Exp $
|
||||
|
||||
--- interface/xaw_i.c.orig 2005-11-19 21:56:48.000000000 +0100
|
||||
+++ interface/xaw_i.c 2005-11-19 21:58:44.000000000 +0100
|
||||
@@ -261,7 +261,7 @@
|
||||
--- interface/xaw_i.c.orig 2004-09-26 23:40:14.000000000 +0000
|
||||
+++ interface/xaw_i.c
|
||||
@@ -261,7 +261,7 @@ int amplitude = DEFAULT_AMPLIFICATION;
|
||||
String bitmapdir = XAW_BITMAP_DIR;
|
||||
Boolean arrangetitle,savelist;
|
||||
static char **current_flist = NULL;
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.13 2005/11/19 21:21:23 kristerw Exp $
|
|||
static int maxentry_on_a_menu = 0,submenu_n = 0;
|
||||
#define OPTIONS_WINDOW 1
|
||||
#define FLIST_WINDOW 2
|
||||
@@ -1329,7 +1329,7 @@
|
||||
@@ -1329,7 +1329,7 @@ static void handle_input(XtPointer data,
|
||||
c= *(local_buf+1);
|
||||
n= atoi(local_buf+2);
|
||||
if(c == 'L')
|
||||
|
@ -20,7 +20,7 @@ $NetBSD: patch-ab,v 1.13 2005/11/19 21:21:23 kristerw Exp $
|
|||
else
|
||||
last_voice = n;
|
||||
if(IsTracePlaying()) drawVoices();
|
||||
@@ -2070,7 +2070,7 @@
|
||||
@@ -2070,7 +2070,7 @@ static void drawVoices(void) {
|
||||
XSetForeground(disp, gct, tracecolor);
|
||||
XFillRectangle(disp,XtWindow(trace),gct,voices_num_width +4,
|
||||
MAX_XAW_MIDI_CHANNELS*BAR_SPACE+TRACEV_OFS+1,VOICENUM_WIDTH,TRACE_FOOT);
|
||||
|
|
Loading…
Reference in a new issue