Changes 0.0.23:
* add support for detection of tail and gnu cp, do not hardcode /bin/bash initial value * use those detected binaries instead of previously hardcoded ones * use `type -t` bash shell builtin instead of `which` utility for detection of file availability * new option --noautosize to prevent overriding of user-defined paper sizes Changes 0.0.22: * added experimental support for xhtml1 source format * create tex and xhtml subpackage in spec file to reduce requirements for main package * automated detection of programs path in configure, program/utility path could be passed to configure by variable, allowed selection of default backend and default webbrowser (just for requirements at the moment) * check for missing tools/programs, fail if tool is not available * fixed libpaper cleaning up * xmllint validity check now with noent option * fixed --stringparam option * added some messages to easier detection of troubles, used different error codes for various situations * fixed FSF addresses, xmlif now licensed under GPLv2+
This commit is contained in:
parent
a5e99dbc56
commit
2fa747b6d6
5 changed files with 31 additions and 110 deletions
|
@ -1,15 +1,14 @@
|
||||||
# $NetBSD: Makefile,v 1.17 2010/11/22 05:54:17 dholland Exp $
|
# $NetBSD: Makefile,v 1.18 2011/03/11 09:27:09 adam Exp $
|
||||||
#
|
|
||||||
|
|
||||||
DISTNAME= xmlto-0.0.21
|
DISTNAME= xmlto-0.0.23
|
||||||
PKGREVISION= 2
|
CATEGORIES= textproc
|
||||||
CATEGORIES= textproc
|
MASTER_SITES= # ftp(1) doesn't speak https: https://fedorahosted.org/releases/x/m/xmlto/
|
||||||
MASTER_SITES= # ftp(1) doesn't speak https: https://fedorahosted.org/xmlto/browser
|
EXTRACT_SUFX= .tar.bz2
|
||||||
EXTRACT_SUFX= .tar.bz2
|
|
||||||
|
|
||||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||||
HOMEPAGE= https://fedorahosted.org/xmlto/
|
HOMEPAGE= https://fedorahosted.org/xmlto/
|
||||||
COMMENT= Tool to help transform XML documents into other formats
|
COMMENT= Tool to help transform XML documents into other formats
|
||||||
|
LICENSE= gnu-gpl-v2
|
||||||
|
|
||||||
PKG_DESTDIR_SUPPORT= user-destdir
|
PKG_DESTDIR_SUPPORT= user-destdir
|
||||||
|
|
||||||
|
@ -18,13 +17,15 @@ DEPENDS+= docbook-xsl>=1.67.0nb1:../../textproc/docbook-xsl
|
||||||
DEPENDS+= libxml2>=2.6.2:../../textproc/libxml2
|
DEPENDS+= libxml2>=2.6.2:../../textproc/libxml2
|
||||||
|
|
||||||
USE_PKGLOCALEDIR= yes
|
USE_PKGLOCALEDIR= yes
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
MAKE_ENV+= SGML_CATALOG_FILES=${PREFIX}/share/xml/catalog
|
|
||||||
CONFIGURE_ARGS+= --with-getopt=${PREFIX}/bin/getopt
|
|
||||||
CONFIGURE_ARGS+= --with-bash=${TOOLS_PATH.bash}
|
|
||||||
|
|
||||||
REPLACE_BASH+= xmlif/test/run-test
|
|
||||||
USE_TOOLS+= bash:run mktemp
|
USE_TOOLS+= bash:run mktemp
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
CONFIGURE_ENV+= GETOPT=${PREFIX}/bin/getopt
|
||||||
|
CONFIGURE_ENV+= BASH=${TOOLS_PATH.bash}
|
||||||
|
CONFIGURE_ENV+= GCP=${TOOLS_PATH.cp}
|
||||||
|
CONFIGURE_ENV+= TAIL=${TOOLS_PATH.tail}
|
||||||
|
|
||||||
|
MAKE_ENV+= SGML_CATALOG_FILES=${PREFIX}/share/xml/catalog
|
||||||
|
REPLACE_BASH+= xmlif/test/run-test
|
||||||
TEST_TARGET= check
|
TEST_TARGET= check
|
||||||
|
|
||||||
INSTALLATION_DIRS= share/xmlto/format/docbook share/xmlto/format/fo
|
INSTALLATION_DIRS= share/xmlto/format/docbook share/xmlto/format/fo
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.3 2009/06/14 18:17:35 joerg Exp $
|
@comment $NetBSD: PLIST,v 1.4 2011/03/11 09:27:09 adam Exp $
|
||||||
bin/xmlif
|
bin/xmlif
|
||||||
bin/xmlto
|
bin/xmlto
|
||||||
man/man1/xmlif.1
|
man/man1/xmlif.1
|
||||||
|
@ -27,4 +27,13 @@ share/xmlto/format/fo/pdf
|
||||||
share/xmlto/format/fo/ps
|
share/xmlto/format/fo/ps
|
||||||
share/xmlto/format/fo/svg
|
share/xmlto/format/fo/svg
|
||||||
share/xmlto/format/fo/txt
|
share/xmlto/format/fo/txt
|
||||||
|
share/xmlto/format/xhtml1/awt
|
||||||
|
share/xmlto/format/xhtml1/dvi
|
||||||
|
share/xmlto/format/xhtml1/fo
|
||||||
|
share/xmlto/format/xhtml1/mif
|
||||||
|
share/xmlto/format/xhtml1/pcl
|
||||||
|
share/xmlto/format/xhtml1/pdf
|
||||||
|
share/xmlto/format/xhtml1/ps
|
||||||
|
share/xmlto/format/xhtml1/svg
|
||||||
|
share/xmlto/format/xhtml1/txt
|
||||||
share/xmlto/xmlto.mak
|
share/xmlto/xmlto.mak
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
$NetBSD: distinfo,v 1.6 2010/11/22 05:54:17 dholland Exp $
|
$NetBSD: distinfo,v 1.7 2011/03/11 09:27:09 adam Exp $
|
||||||
|
|
||||||
SHA1 (xmlto-0.0.21.tar.bz2) = 691202620b337d9c35c95c81306ea629248a8850
|
SHA1 (xmlto-0.0.23.tar.bz2) = 69aab42d941089db3edb32987299290e2472f675
|
||||||
RMD160 (xmlto-0.0.21.tar.bz2) = 21d4f82c1e9dcb8617132f097921db722bc901c6
|
RMD160 (xmlto-0.0.23.tar.bz2) = bbf1e1ee8674a7faeb10643f74a6025d4421d66e
|
||||||
Size (xmlto-0.0.21.tar.bz2) = 99554 bytes
|
Size (xmlto-0.0.23.tar.bz2) = 105201 bytes
|
||||||
SHA1 (patch-aa) = 24c15146e9d4a2147b24ab192c5af68af0cabd21
|
|
||||||
SHA1 (patch-ab) = 174184839d52fb170f3b5adf01c9867588cf5be6
|
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
$NetBSD: patch-aa,v 1.2 2008/11/10 23:01:38 wiz Exp $
|
|
||||||
|
|
||||||
This patch makes "xmlto txt" usable on pkgsrc systems, which usually do
|
|
||||||
not have these binaries in /usr/bin.
|
|
||||||
|
|
||||||
--- format/docbook/txt.orig 2008-05-24 17:43:05.000000000 +0000
|
|
||||||
+++ format/docbook/txt
|
|
||||||
@@ -1,16 +1,16 @@
|
|
||||||
case "$USE_BACKEND" in
|
|
||||||
DEFAULT|DBLATEX)
|
|
||||||
- if [ -x /usr/bin/w3m ]
|
|
||||||
+ if (type w3m 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
- CONVERT=/usr/bin/w3m
|
|
||||||
+ CONVERT=w3m
|
|
||||||
ARGS="-T text/html -dump"
|
|
||||||
- elif [ -x /usr/bin/lynx ]
|
|
||||||
+ elif (type lynx 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
- CONVERT=/usr/bin/lynx
|
|
||||||
+ CONVERT=lynx
|
|
||||||
ARGS="-force_html -dump -nolist -width=72"
|
|
||||||
- elif [ -x /usr/bin/links ]
|
|
||||||
+ elif (type links 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
- CONVERT=/usr/bin/links
|
|
||||||
+ CONVERT=links
|
|
||||||
ARGS="-dump"
|
|
||||||
else
|
|
||||||
echo >&2 "No way to convert HTML to text found."
|
|
|
@ -1,57 +0,0 @@
|
||||||
$NetBSD: patch-ab,v 1.3 2010/11/22 05:54:17 dholland Exp $
|
|
||||||
|
|
||||||
- don't hardwire paths
|
|
||||||
- fix obvious bug handling XSLTPARAMS (PR 44126), already fixed upstream
|
|
||||||
- xmllint needs --nonet
|
|
||||||
|
|
||||||
--- xmlto.in.orig 2008-05-30 13:41:31.000000000 +0000
|
|
||||||
+++ xmlto.in
|
|
||||||
@@ -97,7 +97,7 @@ XSLTOPTS=
|
|
||||||
SEARCHPATH=
|
|
||||||
|
|
||||||
# Try to setup papersize using libpaper first ...
|
|
||||||
-if [ -x /usr/bin/paperconf ]
|
|
||||||
+if (type paperconf 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
papername=`paperconf -n`
|
|
||||||
paperheight=`paperconf -mh | sed 's/ //g'`
|
|
||||||
@@ -128,7 +128,7 @@ EOF
|
|
||||||
fi
|
|
||||||
|
|
||||||
# ... or use magic paper size, based on LC_PAPER
|
|
||||||
-elif [ -x /usr/bin/locale ]
|
|
||||||
+elif (type locale 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
# For paper sizes we know about, specify them.
|
|
||||||
h=$(locale LC_PAPER 2>/dev/null | head -n 1)
|
|
||||||
@@ -151,7 +151,7 @@ EOF
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Magic encoding, based on locale
|
|
||||||
-if [ -x /usr/bin/locale ]
|
|
||||||
+if (type locale 1>/dev/null 2>&1)
|
|
||||||
then
|
|
||||||
charmap=$(locale charmap 2>/dev/null)
|
|
||||||
|
|
||||||
@@ -273,8 +273,8 @@ while [ "$#" -gt "0" ]; do
|
|
||||||
;;
|
|
||||||
--stringparam)
|
|
||||||
MYPARAM="$2"
|
|
||||||
- XSLTPARAMS="XSLTPARAMS --stringparam ${MYPARAM%=*}"
|
|
||||||
- XSLTPARAMS="XSLTPARAMS $MYPARAM#*=}"
|
|
||||||
+ XSLTPARAMS="$XSLTPARAMS --stringparam ${MYPARAM%=*}"
|
|
||||||
+ XSLTPARAMS="$XSLTPARAMS $MYPARAM#*=}"
|
|
||||||
shift 2
|
|
||||||
;;
|
|
||||||
--noclean)
|
|
||||||
@@ -427,8 +427,8 @@ if [ "$SKIP_VALIDATION" -eq 0 ] && [ "$S
|
|
||||||
then
|
|
||||||
VALIDATION="${XSLT_PROCESSED_DIR}/validation-errors"
|
|
||||||
[ "$VERBOSE" -ge 1 ] && \
|
|
||||||
- echo >&2 "xmllint >/dev/null --xinclude --postvalid \"$INPUT_FILE\""
|
|
||||||
- xmllint >/dev/null --xinclude --postvalid "$INPUT_FILE" 2>"${VALIDATION}"
|
|
||||||
+ echo >&2 "xmllint >/dev/null --nonet --xinclude --postvalid \"$INPUT_FILE\""
|
|
||||||
+ xmllint >/dev/null --nonet --xinclude --postvalid "$INPUT_FILE" 2>"${VALIDATION}"
|
|
||||||
xmllint_status=$?
|
|
||||||
if [ $xmllint_status -ne 0 ]
|
|
||||||
then
|
|
Loading…
Reference in a new issue