Updating package for Perl5 module Sys::Filesystem from CPAN in

sysutils/p5-Sys-Filesystem from 1.30nb5 to 1.405.

pkgsrc changes:
- remove upstream applied patches
- switch back from Module::Build to ExtUtils::MakeMaker

Upstream changes since 1.30:
1.405 2013-10-28
    - Fix Mswin32 mounted/unmounted support (thanks to Christian "Mithaldu"
      Walde for remote testing support
    - skip format test in case of unmounted device (unmounted devices might
      or might not know in before the fstype)
    - clean up basic tests and BAIL_OUT when unsupported environment
      encountered

1.404 2013-10-26
    - move to Makefile.PL in favour of developer reqs
    - change required perl version to 5.8.1
    - rewrite core routines of Sys::Filesystem
    - don't search for Darwin tools in path, rely on some
      well known paths
    - general, minor code cleanup

1.403 2013-10-23
    - Honor PATH_FSTAB in the environment on a NetBSD system if present
      (Thanks to dholland@NetBSD.org)
    - try improve error handling on Darwin to avoid smoke errors
    - be noisy about where we're running on during tests
    - remove runtime recommends for author tests
    - bump required version of Module::Pluggable to avoid blead whining
    - include p5-toolchain gang recommended way to declare developer
      dependencies
    - use proper indenting for Changes

1.402 2013-09-24
    - remove Makefile.PL passthrough
    - don't prove whether Win32 is supported - we know it (should fix
      RT#88901 - thanks Michiel Beijen)
    - try to improve supported control
    - put Win32::DriveInfo into feature "Win32" (I'd like to get feedback
      whether it helps)

1.401 2013-09-08
    - Fix MacOS X / Darwin without diskutil
    - Changes reformatted as per CPAN::Changes::Spec

1.400 2013-09-03
    - Moving to GitHub for easier contributing
    - Pod typo / encoding fixes (rt#85898, rt#77699), thanks to Slaven
      Rezić, Andreas J. König and Gregor Herrmann
    - Fix MacOS X 10.8 (diskutil vs. disktool)
    - Update requirements / recommendations
    - Fix AIX (rt#79188) - thanks to David Lee
    - Fix Solaris debug leftover (rt#72717) - thanks to Kenneth Ölwing
    - Fix Tests (rt#62248) - thanks to Daphne Pfister
    - Fix configure_requires (rt#62249) - thanks to Daphne Pfister
This commit is contained in:
sno 2014-02-16 11:57:22 +00:00
parent 98dc8cfc86
commit 2fee82c701
3 changed files with 7 additions and 27 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.12 2013/05/31 12:42:03 wiz Exp $
# $NetBSD: Makefile,v 1.13 2014/02/16 11:57:22 sno Exp $
#
DISTNAME= Sys-Filesystem-1.30
DISTNAME= Sys-Filesystem-1.405
PKGNAME= p5-${DISTNAME}
PKGREVISION= 5
CATEGORIES= sysutils devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Sys/}
@ -12,13 +11,12 @@ HOMEPAGE= http://search.cpan.org/dist/Sys-Filesystem/
COMMENT= Retrieve list of filesystems and their properties
LICENSE= apache-2.0
DEPENDS+= {perl>=5.10.1,p5-Module-Pluggable>=3.9}:../../devel/p5-Module-Pluggable
DEPENDS+= p5-Module-Pluggable>=4.8:../../devel/p5-Module-Pluggable
DEPENDS+= p5-Params-Util>=1.00:../../devel/p5-Params-Util
PKG_INSTALLATION_TYPES= overwrite pkgviews
PERL5_PACKLIST= auto/Sys/Filesystem/.packlist
PERL5_MODULE_TYPE= Module::Build
#pre-configure:
# ${FIND} ${WRKSRC} -name '*.orig' -print -type f | ${XARGS} ${RM} -f

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.5 2012/06/30 05:10:51 dholland Exp $
$NetBSD: distinfo,v 1.6 2014/02/16 11:57:22 sno Exp $
SHA1 (Sys-Filesystem-1.30.tar.gz) = f7ef406c2093d0255fb073b72648276a295f8de8
RMD160 (Sys-Filesystem-1.30.tar.gz) = d909253efd74ee25e8d870bd73105e1d1f486b56
Size (Sys-Filesystem-1.30.tar.gz) = 34319 bytes
SHA1 (patch-lib_Sys_Filesystem_Netbsd_pm) = d193631d7034ce84e4b226a102084e2991b8c580
SHA1 (Sys-Filesystem-1.405.tar.gz) = 859b4b234739a9be02ec63eb6a6d557d27ba7619
RMD160 (Sys-Filesystem-1.405.tar.gz) = 2e2bcf12ae30da2934c687d4cb24e1adb518853e
Size (Sys-Filesystem-1.405.tar.gz) = 27314 bytes

View file

@ -1,17 +0,0 @@
$NetBSD: patch-lib_Sys_Filesystem_Netbsd_pm,v 1.1 2012/06/30 05:10:51 dholland Exp $
Honor PATH_FSTAB in the environment if present. Allows this package to
configure in a chroot that doesn't have an fstab file. Cloned from
the freebsd file.
--- lib/Sys/Filesystem/Netbsd.pm~ 2010-07-15 19:33:42.000000000 +0000
+++ lib/Sys/Filesystem/Netbsd.pm
@@ -57,7 +57,7 @@ sub new
my $self = bless( {}, $class );
# Defaults
- $args{fstab} ||= '/etc/fstab';
+ $args{fstab} ||= $ENV{PATH_FSTAB} || '/etc/fstab';
my @mounts = qx( /sbin/mount );
$self->readMounts( $mount_rx, [ 0, 1, 2 ], [qw(fs_spec fs_file fs_vfstype fs_mntops)], \%special_fs, @mounts );