Remove patch that was misapplied probably in 2004. See upstream

bug report.

Bump PKGREVISION.
This commit is contained in:
wiz 2014-05-19 08:21:13 +00:00
parent a8eb2862ac
commit 30503729b0
3 changed files with 3 additions and 19 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.125 2014/05/18 15:39:15 wiz Exp $
# $NetBSD: Makefile,v 1.126 2014/05/19 08:21:13 wiz Exp $
.include "Makefile.common"
COMMENT= Multimedia player library
PKGREVISION= 1
PKGREVISION= 2
CONFLICTS+= xine-xcb-[0-9]*

View file

@ -1,11 +1,10 @@
$NetBSD: distinfo,v 1.93 2014/05/18 20:48:21 wiz Exp $
$NetBSD: distinfo,v 1.94 2014/05/19 08:21:13 wiz Exp $
SHA1 (xine-lib-1.2.5.tar.xz) = c7ef38fa8ee301e44ba28d6549220546d02d053d
RMD160 (xine-lib-1.2.5.tar.xz) = bb9c3a06666f454e8dfda85471eb6605e2dcb685
Size (xine-lib-1.2.5.tar.xz) = 5007012 bytes
SHA1 (patch-ag) = a0edf812dd3fa4baf273950430fa47b7579ae53e
SHA1 (patch-aj) = df1759c9aaedc00fe55ea03aa5a0800efd68b02d
SHA1 (patch-as) = 302acfbd2a9e7651bed428e513a36344e91f204e
SHA1 (patch-at) = 9d83524bef9dacdb889b7d828053a3fef16a1689
SHA1 (patch-cb) = 708ee946dd1708a40baef5ac193a46dc22bff8b5
SHA1 (patch-cd) = 7cdb3c7b09ccb2ae1dd9245f0ab0b88ad753d7f1

View file

@ -1,15 +0,0 @@
$NetBSD: patch-as,v 1.4 2014/05/18 15:38:18 wiz Exp $
https://bugs.xine-project.org/show_bug.cgi?id=533
--- src/video_out/video_out_none.c.orig 2004-09-22 20:29:15.000000000 +0000
+++ src/video_out/video_out_none.c
@@ -64,6 +64,8 @@ typedef struct {
static void free_framedata(none_frame_t* frame) {
+ pthread_mutex_init (&frame->vo_frame.mutex, NULL);
+
if(frame->vo_frame.base[0]) {
free(frame->vo_frame.base[0]);
frame->vo_frame.base[0] = NULL;