net/powerdns: Update to 4.4.0
Security fix: * This release drops GSS/TSIG support, please see PowerDNS Security Advisory 2020-06 https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2020-06.html Changelog: * New features: - the LMDB backend now supports long record content, making it production ready for everybody - the SVCB and HTTPS record types are supported, with limited additional processing transaction handling in the 2136 handler and the HTTP API was again improved a lot, avoiding various spurious issues users may have noticed if they do a lot of changes a new setting (consistent-backends) offers a roughly 30% speedup, subject to conditions - we finally emit Prometheus metrics! * Improvements: - don’t log trusted-notification-proxy notify at error level - Stop using incbin and use od & sed to generate constant string data. * Bug Fixes: - clear the LMDB set state when performing a new lookup or list to prevent corruption cases - SVCB: Correctly parse and print unknown params - fix direct-dnskey in AXFR-out
This commit is contained in:
parent
827e339a96
commit
308735d4ed
4 changed files with 13 additions and 41 deletions
|
@ -1,6 +1,5 @@
|
|||
# $NetBSD: Makefile,v 1.56 2020/11/05 09:08:56 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.57 2020/12/21 00:26:50 otis Exp $
|
||||
|
||||
PKGREVISION= 1
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/pdns/powerdns/}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile.common,v 1.31 2020/09/24 19:09:53 otis Exp $
|
||||
# $NetBSD: Makefile.common,v 1.32 2020/12/21 00:26:51 otis Exp $
|
||||
|
||||
PDNS_VERSION= 4.3.1
|
||||
PDNS_VERSION= 4.4.0
|
||||
DISTNAME= pdns-${PDNS_VERSION}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
|
|
|
@ -1,16 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.42 2020/09/24 19:09:53 otis Exp $
|
||||
$NetBSD: distinfo,v 1.43 2020/12/21 00:26:51 otis Exp $
|
||||
|
||||
SHA1 (pdns-4.3.1.tar.bz2) = ded83a15fbf287979bdc7c85a421cf9aeca66e25
|
||||
RMD160 (pdns-4.3.1.tar.bz2) = 906b919cadac658c9254b1dcb9a7f886e4c780ee
|
||||
SHA512 (pdns-4.3.1.tar.bz2) = e61e23544f1e57c1ec3a85b4edbc3ff3e8e831410237afdc8896e9f34602774c1dc8bd02eb7440e765262fcc988f98e47b6f1b7945427b1f4a59dd6b84b9437e
|
||||
Size (pdns-4.3.1.tar.bz2) = 1216876 bytes
|
||||
SHA1 (patch-configure) = 8e13bf3a1432369052be32a636655ea86a0db75d
|
||||
SHA1 (pdns-4.4.0.tar.bz2) = 48cc9a624a9df5aaf608479b5a6b06badc01d4c4
|
||||
RMD160 (pdns-4.4.0.tar.bz2) = c32aceb73d90518112314a5fc7018e97947db1c1
|
||||
SHA512 (pdns-4.4.0.tar.bz2) = e7f35539915ee7945b537cfedae72e2b83c86b39c5e44a9268b8a086f44b30a33a64e0b65aad140ba02c349cedaa12820226578dea87c9b666dc75f8bd15c1f6
|
||||
Size (pdns-4.4.0.tar.bz2) = 1270854 bytes
|
||||
SHA1 (patch-configure) = 691b4f804f9e72eb18ec895a7b0e685789c78034
|
||||
SHA1 (patch-ext_json11_json11.cpp) = a8ffe67156a836841aef8a6bba134a82283f381e
|
||||
SHA1 (patch-pdns_dnsscope.cc) = b289b750686b25041c3e291fb0d3d562beb36eaf
|
||||
SHA1 (patch-pdns_iputils.cc) = fbd3bb210216bb98c3cd73b702b6dea486c51dec
|
||||
SHA1 (patch-pdns_iputils.hh) = aa90245d84415c98d4af4a57349b812c536446e9
|
||||
SHA1 (patch-pdns_lua-record.cc) = 8cdf7d692ae7ec636c38e9f5cd2f91467364aae3
|
||||
SHA1 (patch-pdns_qtype.hh) = 0f8bca4c0cafea9a5257a08077fa42b4c52127f5
|
||||
SHA1 (patch-pdns_version.cc) = 25917c329dafa34e657fa31c7a9abd99110bb4b0
|
||||
SHA1 (patch-pdns_webserver.cc) = b698338a168066f65a96313eab1bb1292192df94
|
||||
SHA1 (patch-pdns_ws-auth.cc) = fd68549574240a9e99b31f501e40461f0318d1ed
|
||||
|
|
|
@ -1,31 +1,8 @@
|
|||
$NetBSD: patch-configure,v 1.10 2020/07/02 13:01:38 otis Exp $
|
||||
$NetBSD: patch-configure,v 1.11 2020/12/21 00:26:51 otis Exp $
|
||||
|
||||
Do not add default compiler flags.
|
||||
Leave pkgsrc to handle security features.
|
||||
|
||||
--- configure.orig 2020-04-06 12:51:03.000000000 +0000
|
||||
--- configure.orig 2020-12-17 14:49:10.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3738,8 +3738,8 @@ case $host_os in *\ *) host_os=`echo "$h
|
||||
|
||||
|
||||
# Add some default CFLAGS and CXXFLAGS, can be appended to using the environment variables
|
||||
-CFLAGS="-g -O2 -Wall -Wextra -Wshadow -Wno-unused-parameter $CFLAGS"
|
||||
-CXXFLAGS="-g -O2 -Wall -Wextra -Wshadow -Wno-unused-parameter $CXXFLAGS"
|
||||
+CFLAGS="-Wall $CFLAGS"
|
||||
+CXXFLAGS="-Wall $CXXFLAGS"
|
||||
|
||||
ac_ext=c
|
||||
ac_cpp='$CPP $CPPFLAGS'
|
||||
@@ -7901,7 +7901,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $gl_cv_warn_cxx__fstack_protector" >&5
|
||||
$as_echo "$gl_cv_warn_cxx__fstack_protector" >&6; }
|
||||
-if test "x$gl_cv_warn_cxx__fstack_protector" = xyes; then :
|
||||
+if test "x$gl_cv_warn_cxx__fstack_protector" = xDISABLED; then :
|
||||
|
||||
CFLAGS="-fstack-protector $CFLAGS"
|
||||
CXXFLAGS="-fstack-protector $CXXFLAGS"
|
||||
@@ -22582,7 +22582,7 @@ fi
|
||||
@@ -22688,7 +22688,7 @@ fi
|
||||
|
||||
if test "x$PG_CONFIG" != "x" -o "x$PGSQL_LIBS" = "x"; then :
|
||||
|
||||
|
@ -34,7 +11,7 @@ Leave pkgsrc to handle security features.
|
|||
|
||||
# Extract the first word of "pg_config", so it can be a program name with args.
|
||||
set dummy pg_config; ac_word=$2
|
||||
@@ -22626,7 +22626,7 @@ fi
|
||||
@@ -22732,7 +22732,7 @@ fi
|
||||
|
||||
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue