Always add PREFIX/lib to libpth. When building as normal user, it often
exists already. This is not the case for bulk builds though. This fixes p5-MARC-Charset, since p5-gdbm ended up without rpath to PREFIX/lib. Fix some Perl interpreter paths while here. Bump revision.
This commit is contained in:
parent
7e33b380cd
commit
313b61abcd
3 changed files with 20 additions and 6 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.176 2011/10/16 20:43:56 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.177 2011/11/27 19:47:50 joerg Exp $
|
||||
|
||||
.include "license.mk"
|
||||
.include "Makefile.common"
|
||||
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
@ -279,10 +279,10 @@ SUBST_SED.rm= -e "s!^rm_try='/.*/\\.tools/bin/rm -f!rm_try='/bin/rm -f!"
|
|||
|
||||
# Replace our perl as the interpreter
|
||||
REPLACE_PERL+= lib/File/DosGlob.pm
|
||||
REPLACE_PERL+= lib/version.pm
|
||||
REPLACE_PERL+= cpan/bignum/lib/Math/BigFloat/Trace.pm
|
||||
REPLACE_PERL+= cpan/bignum/lib/Math/BigInt/Trace.pm
|
||||
REPLACE_PERL+= lib/unicore/mktables
|
||||
REPLACE_PERL+= lib/version.pm
|
||||
REPLACE_PERL+= dist/bignum/lib/Math/BigFloat/Trace.pm
|
||||
REPLACE_PERL+= dist/bignum/lib/Math/BigInt/Trace.pm
|
||||
|
||||
# And replace a perl interpreter during the pre-install stage
|
||||
# I think this may be a bootstrap script, so can't use REPLACE_PERL
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.79 2011/10/16 20:09:42 spz Exp $
|
||||
$NetBSD: distinfo,v 1.80 2011/11/27 19:47:50 joerg Exp $
|
||||
|
||||
SHA1 (perl-5.14.2.tar.gz) = df1549d65cdef2b20023af83ecaa2a024109a5ad
|
||||
RMD160 (perl-5.14.2.tar.gz) = bed043edbebd69e1279e9a70424e2552389bea79
|
||||
Size (perl-5.14.2.tar.gz) = 15223598 bytes
|
||||
SHA1 (patch-Configure) = cc3a55187827ebb16326198fd9b262dfae931653
|
||||
SHA1 (patch-aa) = 4c8197cdc0595a17ba377a28c7457f923c2d9bf9
|
||||
SHA1 (patch-ab) = b6104a02aa6fbeda2340042a93c2382d1a1965bb
|
||||
SHA1 (patch-ac) = c1893ea4cf4b89b03b3acc5dec9b5828d50c5dad
|
||||
|
|
13
lang/perl5/patches/patch-Configure
Normal file
13
lang/perl5/patches/patch-Configure
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-Configure,v 1.1 2011/11/27 19:47:50 joerg Exp $
|
||||
|
||||
--- Configure.orig 2011-11-27 18:47:43.000000000 +0000
|
||||
+++ Configure
|
||||
@@ -4799,7 +4799,7 @@ esac
|
||||
libpth=''
|
||||
for xxx in $dlist
|
||||
do
|
||||
- if $test -d $xxx; then
|
||||
+ if $test -d $xxx -o "$xxx" = "$PREFIX/lib"; then
|
||||
case " $libpth " in
|
||||
*" $xxx "*) ;;
|
||||
*) libpth="$libpth $xxx";;
|
Loading…
Reference in a new issue