simgear: Fix SunOS and missing dependencies.
This commit is contained in:
parent
cca166e65a
commit
316206cca2
7 changed files with 87 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.71 2018/08/04 04:04:28 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.72 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
DISTNAME= simgear-2018.2.2
|
||||
CATEGORIES= games devel
|
||||
|
@ -20,6 +20,7 @@ LDFLAGS.SunOS+= -lsocket -lnsl
|
|||
.include "../../devel/boost-headers/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../graphics/osg/buildlink3.mk"
|
||||
.include "../../www/curl/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
|
|
|
@ -1,9 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.7 2018/08/04 04:04:28 nia Exp $
|
||||
$NetBSD: distinfo,v 1.8 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
SHA1 (simgear-2018.2.2.tar.bz2) = ba24275236aa461c4b0fee3e37e4fb6877734a1c
|
||||
RMD160 (simgear-2018.2.2.tar.bz2) = ecb7005d1fcae8b76cb1d18df7924fe89a594152
|
||||
SHA512 (simgear-2018.2.2.tar.bz2) = 2052c8e42bda751bc7c9429525b7acb733d5c0dd32dd4adea078718f89296c635abc956b464887fe67202dcc07a81fbade443a84fe8206648e473fd0f64d9365
|
||||
Size (simgear-2018.2.2.tar.bz2) = 1313890 bytes
|
||||
SHA1 (patch-simgear_canvas_ShivaVG_src_shConfig.h) = f38988911197efc56cb6eb170274a04961aa198d
|
||||
SHA1 (patch-simgear_canvas_ShivaVG_src_shConfig.h) = d9e8befec2e7ecb8c79a1edddf74bea4e759d656
|
||||
SHA1 (patch-simgear_canvas_ShivaVG_src_shDefs.h) = 0da1544fecec002fb874fcb7df1155ad2889ba4d
|
||||
SHA1 (patch-simgear_io_test__repository.cxx) = 4369ea0b3eab47bed5b2b08ba8a56f86f83f77a0
|
||||
SHA1 (patch-simgear_io_test__untar.cxx) = b3625254f9410411b30a8c3e30845c3d1509a993
|
||||
SHA1 (patch-simgear_io_untar.cxx) = 2cc21468bd0319aae012fb7c16e9e279888e34e3
|
||||
SHA1 (patch-simgear_misc_strutils.cxx) = a72f601803ca285c778ccf12bfe25ff886a182cb
|
||||
SHA1 (patch-simgear_package_md5.h) = 91dc8741ed547c26a6de8ab8bd25ee441e0e5e92
|
||||
|
|
|
@ -1,9 +1,18 @@
|
|||
$NetBSD: patch-simgear_canvas_ShivaVG_src_shConfig.h,v 1.1 2018/08/04 04:04:28 nia Exp $
|
||||
$NetBSD: patch-simgear_canvas_ShivaVG_src_shConfig.h,v 1.2 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
Support NetBSD.
|
||||
Support NetBSD and SunOS.
|
||||
|
||||
--- simgear/canvas/ShivaVG/src/shConfig.h.orig 2018-06-03 18:56:36.000000000 +0000
|
||||
+++ simgear/canvas/ShivaVG/src/shConfig.h
|
||||
@@ -16,7 +16,7 @@
|
||||
#define NOMINMAX
|
||||
#endif
|
||||
|
||||
-#elif defined(linux) || defined(__linux)
|
||||
+#elif defined(linux) || defined(__linux) || defined(__sun)
|
||||
|
||||
// Linux
|
||||
#define VG_API_LINUX
|
||||
@@ -31,6 +31,11 @@
|
||||
// FreeBSD
|
||||
#define VG_API_FREEBSD
|
||||
|
|
17
games/simgear/patches/patch-simgear_io_test__repository.cxx
Normal file
17
games/simgear/patches/patch-simgear_io_test__repository.cxx
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-simgear_io_test__repository.cxx,v 1.1 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
SunOS needs alloca.h
|
||||
|
||||
--- simgear/io/test_repository.cxx.orig 2018-06-03 18:56:36.000000000 +0000
|
||||
+++ simgear/io/test_repository.cxx
|
||||
@@ -5,6 +5,10 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
+#ifdef __sun
|
||||
+#include <alloca.h>
|
||||
+#endif
|
||||
+
|
||||
#include <boost/algorithm/string/case_conv.hpp>
|
||||
|
||||
#include <simgear/simgear_config.h>
|
17
games/simgear/patches/patch-simgear_io_test__untar.cxx
Normal file
17
games/simgear/patches/patch-simgear_io_test__untar.cxx
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-simgear_io_test__untar.cxx,v 1.1 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
SunOS needs alloca.h
|
||||
|
||||
--- simgear/io/test_untar.cxx.orig 2018-06-03 18:56:36.000000000 +0000
|
||||
+++ simgear/io/test_untar.cxx
|
||||
@@ -7,6 +7,10 @@
|
||||
|
||||
#include <iostream>
|
||||
|
||||
+#ifdef __sun
|
||||
+#include <alloca.h>
|
||||
+#endif
|
||||
+
|
||||
#include "untar.hxx"
|
||||
|
||||
#include <simgear/misc/test_macros.hxx>
|
17
games/simgear/patches/patch-simgear_io_untar.cxx
Normal file
17
games/simgear/patches/patch-simgear_io_untar.cxx
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-simgear_io_untar.cxx,v 1.1 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
SunOS needs alloca.h
|
||||
|
||||
--- simgear/io/untar.cxx.orig 2018-06-03 18:56:36.000000000 +0000
|
||||
+++ simgear/io/untar.cxx
|
||||
@@ -17,6 +17,10 @@
|
||||
|
||||
#include <simgear_config.h>
|
||||
|
||||
+#ifdef __sun
|
||||
+#include <alloca.h>
|
||||
+#endif
|
||||
+
|
||||
#include "untar.hxx"
|
||||
|
||||
#include <cstdlib>
|
17
games/simgear/patches/patch-simgear_package_md5.h
Normal file
17
games/simgear/patches/patch-simgear_package_md5.h
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-simgear_package_md5.h,v 1.1 2018/08/06 11:03:18 jperkin Exp $
|
||||
|
||||
Add non-standard typedefs.
|
||||
|
||||
--- simgear/package/md5.h.orig 2018-06-03 18:56:36.000000000 +0000
|
||||
+++ simgear/package/md5.h
|
||||
@@ -23,6 +23,10 @@
|
||||
typedef unsigned char u_int8_t;
|
||||
typedef unsigned int u_int32_t;
|
||||
typedef unsigned __int64 u_int64_t;
|
||||
+#elif defined(__sun)
|
||||
+typedef uint8_t u_int8_t;
|
||||
+typedef uint32_t u_int32_t;
|
||||
+typedef uint64_t u_int64_t;
|
||||
#endif
|
||||
|
||||
#define MD5_BLOCK_LENGTH 64
|
Loading…
Reference in a new issue