qt5-qtbase: avoid using semaphores as mutexes on netbsd.

they're quite constrained: the max number of semaphores is limited.

bump PKGREVISION
This commit is contained in:
maya 2019-04-28 12:46:31 +00:00
parent 89e7671cfc
commit 316640de32
4 changed files with 22 additions and 4 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.76 2019/04/25 19:43:15 adam Exp $
# $NetBSD: Makefile,v 1.77 2019/04/28 12:46:31 maya Exp $
DISTNAME= qtbase-everywhere-src-${QTVERSION}
PKGNAME= qt5-qtbase-${QTVERSION}
PKGREVISION= 1
COMMENT= C++ X GUI toolkit
.include "../../x11/qt5-qtbase/Makefile.common"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.30 2019/03/26 11:14:16 adam Exp $
# $NetBSD: Makefile.common,v 1.31 2019/04/28 12:46:31 maya Exp $
# used by x11/qt5-mysql/Makefile
# used by x11/qt5-odbc/Makefile
# used by x11/qt5-psql/Makefile
@ -30,7 +30,7 @@
.include "options.mk"
.include "../../mk/dlopen.buildlink3.mk"
BUILDLINK_TRANSFORM+= opt:-ldl:${BUILDLINK_LDADD.dl:M*}
BUILDLINK_TRANSFORM+= opt:-ldl:${BUILDLINK_LDADD.dl:Q}
USE_LANGUAGES= c c++11
USE_TOOLS+= gmake perl:build pkg-config

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.48 2019/04/25 19:43:15 adam Exp $
$NetBSD: distinfo,v 1.49 2019/04/28 12:46:31 maya Exp $
SHA1 (qtbase-everywhere-src-5.12.3.tar.xz) = dbe6ed4779998f757473a727b7ff3300c7d31155
RMD160 (qtbase-everywhere-src-5.12.3.tar.xz) = aebc6473c64d287fe7ea861c449b094b823225c3
@ -16,6 +16,7 @@ SHA1 (patch-src_corelib_global_qconfig-bootstrapped.h) = c52c811a44d965cf9d42074
SHA1 (patch-src_corelib_io_io.pri) = b2c1057e20c3150162695947bab958a2644df7dc
SHA1 (patch-src_corelib_io_qstandardpaths_unix.cpp) = de4b6c6be89524763e40698bcf5e8f413abdb938
SHA1 (patch-src_corelib_io_qstorageinfo_unix.cpp) = 9919194e9f6b47f1f311b8f8223a6a7519152073
SHA1 (patch-src_corelib_thread_qmutex__p.h) = 093089b8a37baa3071257c99bbde5f6295bd2eec
SHA1 (patch-src_corelib_thread_qwaitcondition__unix.cpp) = 9dffdbfc81bc7d3259020cd32b4039b7be6ee2bd
SHA1 (patch-src_network_kernel_qnetworkinterface__unix.cpp) = 2c5569eb2ba19999eb62e4fdb54f347c88f6e6a5
SHA1 (patch-src_openglextensions_openglextensions.pro) = 575d31c3a48f36d82dc1f342078e636f4c25e33f

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_corelib_thread_qmutex__p.h,v 1.1 2019/04/28 12:46:31 maya Exp $
Avoid using semaphores on netbsd. they're flimsy and sem_init fails
if you use too many semaphores.
--- src/corelib/thread/qmutex_p.h.orig 2019-04-09 09:51:26.000000000 +0000
+++ src/corelib/thread/qmutex_p.h
@@ -65,7 +65,7 @@
#elif defined(Q_OS_LINUX) && !defined(QT_LINUXBASE)
// use Linux mutexes everywhere except for LSB builds
# define QT_LINUX_FUTEX
-#elif defined(Q_OS_UNIX)
+#elif defined(Q_OS_UNIX) && !defined(__NetBSD__)
# if _POSIX_VERSION-0 >= 200112L || _XOPEN_VERSION-0 >= 600
# include <semaphore.h>
# define QT_UNIX_SEMAPHORE