geography/geos: Update to 3.8.1

Changes in 3.8.1
2020-xx-xx

- Bug fixes / improvements
  - Stack allocate line segments in OverlapUnion (Paul Ramsey)
  - Avoid returning non-empty CoordinateSequence from empty Point
    (#1001, Dan Baston)
  - Avoid assertion failure with MSVC 2017 / 2019 (#1002, Dan Baston)
  - Remove whitespace from end of GEOSversion() output (azhi)
  - Improve performance of GEOSisValid (#1008, Dan Baston)
  - Avoid changing MultiLineString component order in GEOSReverse
    (#1013, Dan Baston)
  - Fix missing vtable for LineString and CoordinateArraySequenceFactory
    (#299 and #1016, Evgen Bodunov)
  - Reduce performance regression in GEOSBuffer (#1020)

Changes in 3.8.0
2019-10-10

- New things:
  - CAPI: GEOSBuildArea (#952, Even Rouault)
  - CAPI: GEOSMakeValid (#952, Even Rouault)
  - CAPI: GEOSPolygonize_valid (#727, Dan Baston)
  - CAPI: GEOSCoverageUnion (Dan Baston)
  - CAPI: GEOSCoordSeq_setXY, GEOSCoordSeq_setXYZ,
          GEOSCoordSeq_getXY, GEOSCoordSeq_getXYZ (Dan Baston)
  - CAPI: GEOSMinimumBoundingCircle (#735)
  - CAPI: GEOSGeom_createPointFromXY (Dan Baston)

- Improvements:
  - Improve overall performance by reducing of heap allocations (Dan Baston)
  - Improve performance and robustness of GEOSPointOnSurface (Martin Davis)
  - Improve performance of GEOSPolygonize for cases with many potential
    holes (#748, Dan Baston)
  - Support extended precision calculations (ttmath) and port JTS
    improvements related to extended precision (Paul Ramsey, Mateusz Loskot)
  - Improve performance of GEOSPolygonize for cases with many or complex
    shells (Dan Baston, Martin Davis)
  - Improve performance of Delaunay triangulations / Voronoi Diagrams
    (Dan Baston)
  - Improve performance of prepared geometry operations (Dan Baston)
  - Improve robustness of Delaunay triangulations (Paul Ramsey, Martin Davis)
  - Improve performance of unary union for lines (Dan Baston)
  - Improve general predicate, overlay, and buffer performance (Dan Baston, Paul Ramsey)
  - Improve cascaded union performance (Paul Ramsey, Martin Davis)
  - Allocate default GeometryFactory singleton on the stack (Sandro Mani)
  - Harmonize XML tests with JTS and harmonize cmake/autoconf
    test running (Paul Ramsey)
  - CMake modernization (Mateusz Loskot, Paul Ramsey, Dan Baston)
  - Return unique_ptr from most methods that produce a new geometry (Dan Baston)

- Changes:
  - Constructive geometry functions in CAPI now preserve SRID
    of input arguments in output (#896)
This commit is contained in:
gdt 2020-03-11 12:52:06 +00:00
parent 0b3d00715e
commit 316fdf9c1f
5 changed files with 84 additions and 56 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.34 2019/10/08 23:42:55 gdt Exp $
# $NetBSD: Makefile,v 1.35 2020/03/11 12:52:06 gdt Exp $
DISTNAME= geos-3.7.3
DISTNAME= geos-3.8.1
CATEGORIES= geography
MASTER_SITES= http://download.osgeo.org/geos/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,30 +1,31 @@
@comment $NetBSD: PLIST,v 1.15 2018/09/11 16:13:29 gdt Exp $
@comment $NetBSD: PLIST,v 1.16 2020/03/11 12:52:06 gdt Exp $
bin/geos-config
include/geos.h
include/geos/algorithm/Angle.h
include/geos/algorithm/Area.h
include/geos/algorithm/BoundaryNodeRule.h
include/geos/algorithm/CGAlgorithms.h
include/geos/algorithm/CGAlgorithmsDD.h
include/geos/algorithm/CentralEndpointIntersector.h
include/geos/algorithm/Centroid.h
include/geos/algorithm/CentroidArea.h
include/geos/algorithm/CentroidLine.h
include/geos/algorithm/CentroidPoint.h
include/geos/algorithm/ConvexHull.h
include/geos/algorithm/ConvexHull.inl
include/geos/algorithm/Distance.h
include/geos/algorithm/HCoordinate.h
include/geos/algorithm/InteriorPointArea.h
include/geos/algorithm/InteriorPointLine.h
include/geos/algorithm/InteriorPointPoint.h
include/geos/algorithm/Intersection.h
include/geos/algorithm/Length.h
include/geos/algorithm/LineIntersector.h
include/geos/algorithm/MCPointInRing.h
include/geos/algorithm/MinimumBoundingCircle.h
include/geos/algorithm/MinimumDiameter.h
include/geos/algorithm/NotRepresentableException.h
include/geos/algorithm/PointInRing.h
include/geos/algorithm/Orientation.h
include/geos/algorithm/PointLocation.h
include/geos/algorithm/PointLocator.h
include/geos/algorithm/RayCrossingCounter.h
include/geos/algorithm/RayCrossingCounterDD.h
include/geos/algorithm/RobustDeterminant.h
include/geos/algorithm/SIRtreePointInRing.h
include/geos/algorithm/SimplePointInRing.h
include/geos/algorithm/distance/DiscreteFrechetDistance.h
include/geos/algorithm/distance/DiscreteHausdorffDistance.h
include/geos/algorithm/distance/DistanceToPoint.h
@ -32,6 +33,21 @@ include/geos/algorithm/distance/PointPairDistance.h
include/geos/algorithm/locate/IndexedPointInAreaLocator.h
include/geos/algorithm/locate/PointOnGeometryLocator.h
include/geos/algorithm/locate/SimplePointInAreaLocator.h
include/geos/algorithm/ttmath/ttmath.h
include/geos/algorithm/ttmath/ttmathbig.h
include/geos/algorithm/ttmath/ttmathdec.h
include/geos/algorithm/ttmath/ttmathint.h
include/geos/algorithm/ttmath/ttmathmisc.h
include/geos/algorithm/ttmath/ttmathobjects.h
include/geos/algorithm/ttmath/ttmathparser.h
include/geos/algorithm/ttmath/ttmaththreads.h
include/geos/algorithm/ttmath/ttmathtypes.h
include/geos/algorithm/ttmath/ttmathuint.h
include/geos/algorithm/ttmath/ttmathuint_noasm.h
include/geos/algorithm/ttmath/ttmathuint_x86.h
include/geos/algorithm/ttmath/ttmathuint_x86_64.h
include/geos/algorithm/ttmath/ttmathuint_x86_64_msvc.asm
include/geos/constants.h
include/geos/export.h
include/geos/geom.h
include/geos/geom/BinaryOp.h
@ -45,9 +61,11 @@ include/geos/geom/CoordinateList.h
include/geos/geom/CoordinateSequence.h
include/geos/geom/CoordinateSequenceFactory.h
include/geos/geom/CoordinateSequenceFilter.h
include/geos/geom/DefaultCoordinateSequenceFactory.h
include/geos/geom/Dimension.h
include/geos/geom/Envelope.h
include/geos/geom/Envelope.inl
include/geos/geom/FixedSizeCoordinateSequence.h
include/geos/geom/Geometry.h
include/geos/geom/GeometryCollection.h
include/geos/geom/GeometryCollection.inl
@ -59,7 +77,6 @@ include/geos/geom/IntersectionMatrix.h
include/geos/geom/LineSegment.h
include/geos/geom/LineSegment.inl
include/geos/geom/LineString.h
include/geos/geom/Lineal.h
include/geos/geom/LinearRing.h
include/geos/geom/Location.h
include/geos/geom/MultiLineString.h
@ -69,10 +86,8 @@ include/geos/geom/MultiPolygon.h
include/geos/geom/MultiPolygon.inl
include/geos/geom/Point.h
include/geos/geom/Polygon.h
include/geos/geom/Polygonal.h
include/geos/geom/PrecisionModel.h
include/geos/geom/PrecisionModel.inl
include/geos/geom/Puntal.h
include/geos/geom/Triangle.h
include/geos/geom/prep/AbstractPreparedPolygonContains.h
include/geos/geom/prep/BasicPreparedGeometry.h
@ -89,6 +104,7 @@ include/geos/geom/prep/PreparedPolygonIntersects.h
include/geos/geom/prep/PreparedPolygonPredicate.h
include/geos/geom/util/ComponentCoordinateExtracter.h
include/geos/geom/util/CoordinateOperation.h
include/geos/geom/util/Densifier.h
include/geos/geom/util/GeometryCombiner.h
include/geos/geom/util/GeometryEditor.h
include/geos/geom/util/GeometryEditorOperation.h
@ -102,6 +118,7 @@ include/geos/geom/util/SineStarFactory.h
include/geos/geomUtil.h
include/geos/geomgraph.h
include/geos/geomgraph/Depth.h
include/geos/geomgraph/Depth.inl
include/geos/geomgraph/DirectedEdge.h
include/geos/geomgraph/DirectedEdge.inl
include/geos/geomgraph/DirectedEdgeStar.h
@ -117,18 +134,22 @@ include/geos/geomgraph/GeometryGraph.h
include/geos/geomgraph/GeometryGraph.inl
include/geos/geomgraph/GraphComponent.h
include/geos/geomgraph/Label.h
include/geos/geomgraph/Label.inl
include/geos/geomgraph/Node.h
include/geos/geomgraph/NodeFactory.h
include/geos/geomgraph/NodeMap.h
include/geos/geomgraph/PlanarGraph.h
include/geos/geomgraph/Position.h
include/geos/geomgraph/Quadrant.h
include/geos/geomgraph/Quadrant.inl
include/geos/geomgraph/TopologyLocation.h
include/geos/geomgraph/TopologyLocation.inl
include/geos/geomgraph/index/EdgeSetIntersector.h
include/geos/geomgraph/index/MonotoneChain.h
include/geos/geomgraph/index/MonotoneChainEdge.h
include/geos/geomgraph/index/MonotoneChainIndexer.h
include/geos/geomgraph/index/SegmentIntersector.h
include/geos/geomgraph/index/SegmentIntersector.inl
include/geos/geomgraph/index/SimpleEdgeSetIntersector.h
include/geos/geomgraph/index/SimpleMCSweepLineIntersector.h
include/geos/geomgraph/index/SimpleSweepLineIntersector.h
@ -164,6 +185,7 @@ include/geos/index/strtree/AbstractNode.h
include/geos/index/strtree/AbstractSTRtree.h
include/geos/index/strtree/Boundable.h
include/geos/index/strtree/BoundablePair.h
include/geos/index/strtree/EnvelopeUtil.h
include/geos/index/strtree/GeometryItemDistance.h
include/geos/index/strtree/Interval.h
include/geos/index/strtree/ItemBoundable.h
@ -206,6 +228,7 @@ include/geos/linearref/LocationIndexOfPoint.h
include/geos/linearref/LocationIndexedLine.h
include/geos/noding.h
include/geos/noding/BasicSegmentString.h
include/geos/noding/BasicSegmentString.inl
include/geos/noding/FastNodingValidator.h
include/geos/noding/FastSegmentSetIntersectionFinder.h
include/geos/noding/GeometryNoder.h
@ -218,6 +241,7 @@ include/geos/noding/MCIndexSegmentSetMutualIntersector.h
include/geos/noding/NodableSegmentString.h
include/geos/noding/NodedSegmentString.h
include/geos/noding/Noder.h
include/geos/noding/NodingIntersectionFinder.h
include/geos/noding/NodingValidator.h
include/geos/noding/Octant.h
include/geos/noding/OrientedCoordinateArray.h
@ -231,7 +255,6 @@ include/geos/noding/SegmentSetMutualIntersector.h
include/geos/noding/SegmentString.h
include/geos/noding/SegmentStringUtil.h
include/geos/noding/SimpleNoder.h
include/geos/noding/SingleInteriorIntersectionFinder.h
include/geos/noding/SinglePassNoder.h
include/geos/noding/snapround/HotPixel.h
include/geos/noding/snapround/HotPixel.inl
@ -295,7 +318,9 @@ include/geos/operation/overlay/snap/GeometrySnapper.h
include/geos/operation/overlay/snap/LineStringSnapper.h
include/geos/operation/overlay/snap/SnapIfNeededOverlayOp.h
include/geos/operation/overlay/snap/SnapOverlayOp.h
include/geos/operation/polygonize/BuildArea.h
include/geos/operation/polygonize/EdgeRing.h
include/geos/operation/polygonize/HoleAssigner.h
include/geos/operation/polygonize/PolygonizeDirectedEdge.h
include/geos/operation/polygonize/PolygonizeEdge.h
include/geos/operation/polygonize/PolygonizeGraph.h
@ -314,13 +339,17 @@ include/geos/operation/relate/RelateOp.h
include/geos/operation/sharedpaths/SharedPathsOp.h
include/geos/operation/union/CascadedPolygonUnion.h
include/geos/operation/union/CascadedUnion.h
include/geos/operation/union/CoverageUnion.h
include/geos/operation/union/GeometryListHolder.h
include/geos/operation/union/OverlapUnion.h
include/geos/operation/union/PointGeometryUnion.h
include/geos/operation/union/UnaryUnionOp.h
include/geos/operation/valid/ConnectedInteriorTester.h
include/geos/operation/valid/ConsistentAreaTester.h
include/geos/operation/valid/IsValidOp.h
include/geos/operation/valid/MakeValid.h
include/geos/operation/valid/QuadtreeNestedRingTester.h
include/geos/operation/valid/RepeatedPointRemover.h
include/geos/operation/valid/RepeatedPointTester.h
include/geos/operation/valid/SimpleNestedRingTester.h
include/geos/operation/valid/SweeplineNestedRingTester.h
@ -335,7 +364,6 @@ include/geos/planargraph/NodeMap.h
include/geos/planargraph/PlanarGraph.h
include/geos/planargraph/Subgraph.h
include/geos/planargraph/algorithm/ConnectedSubgraphFinder.h
include/geos/platform.h
include/geos/precision.h
include/geos/precision/CommonBits.h
include/geos/precision/CommonBitsOp.h
@ -355,7 +383,6 @@ include/geos/simplify/TaggedLineStringSimplifier.h
include/geos/simplify/TaggedLinesSimplifier.h
include/geos/simplify/TopologyPreservingSimplifier.h
include/geos/spatialIndex.h
include/geos/timeval.h
include/geos/triangulate/DelaunayTriangulationBuilder.h
include/geos/triangulate/IncrementalDelaunayTriangulator.h
include/geos/triangulate/VoronoiDiagramBuilder.h

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.30 2019/10/08 23:42:55 gdt Exp $
$NetBSD: distinfo,v 1.31 2020/03/11 12:52:06 gdt Exp $
SHA1 (geos-3.7.3.tar.bz2) = 61ce1ac73781d070a49a09c17a4a46dbb2cf5058
RMD160 (geos-3.7.3.tar.bz2) = 13677800b921025698badfd0481de95122f2429c
SHA512 (geos-3.7.3.tar.bz2) = 3799d36ed6a56f049446429a879cb06d59f2d0b5abd1810866f6c296fd534034bfbe61330928c6ee8728b47678133065b8057c4315666ae36a41eb4d1c98faf6
Size (geos-3.7.3.tar.bz2) = 2000211 bytes
SHA1 (patch-ae) = bcc9e39928dca6c3e78326c0bfb7dcf96e4bcf10
SHA1 (patch-capi_geos__ts__c.cpp) = bde78fc0ef30e0d75ccba5f89c6f62d957783d03
SHA1 (geos-3.8.1.tar.bz2) = dbd165752dd4c48d81a84aa51c99d04410d96c67
RMD160 (geos-3.8.1.tar.bz2) = 16b9b4dba1c772c561bace8e3e7c514f78fd4037
SHA512 (geos-3.8.1.tar.bz2) = 1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056
Size (geos-3.8.1.tar.bz2) = 2505407 bytes
SHA1 (patch-ae) = d566a7cc7fdbb29cb7f39d6e0e4adf525213f62c
SHA1 (patch-capi_geos__ts__c.cpp) = ca838fe4a0897739f700c5d1e3ccb231df794705

View file

@ -1,17 +1,17 @@
$NetBSD: patch-ae,v 1.6 2018/09/11 16:13:29 gdt Exp $
$NetBSD: patch-ae,v 1.7 2020/03/11 12:52:07 gdt Exp $
TODO: explain what's in LDFLAGS.
TODO: explain why --libs has -L in the first place (vs --ldflags).
TODO: report upstream.
--- tools/geos-config.in.orig 2018-08-19 10:49:14.000000000 +0000
--- tools/geos-config.in.orig 2019-10-03 17:32:04.000000000 +0000
+++ tools/geos-config.in
@@ -58,7 +58,7 @@ case $1 in
echo -L${libdir} -lgeos -lm
echo -L@libdir@ -lgeos -lm
;;
--ldflags)
- echo -L${libdir}
+ echo -L${libdir} @LDFLAGS@
- echo -L@libdir@
+ echo -L@libdir@ @LDFLAGS@
;;
--includes)
echo ${prefix}/include
echo @prefix@/include

View file

@ -1,45 +1,46 @@
$NetBSD: patch-capi_geos__ts__c.cpp,v 1.2 2018/09/11 16:13:29 gdt Exp $
$NetBSD: patch-capi_geos__ts__c.cpp,v 1.3 2020/03/11 12:52:07 gdt Exp $
\todo Document this patch. It appears to be that passing non-POD types
to variadic functions is UB.
Passing non-POD types like std::string to variadic functions is UB.
To avoid this, change functions to take const char * rather than
std::string.
\todo File a bug upstream
\todo File a bug upstream, if appropriate.
--- capi/geos_ts_c.cpp.orig 2015-09-08 16:31:02.000000000 +0000
--- capi/geos_ts_c.cpp.orig 2020-03-10 17:19:40.000000000 +0000
+++ capi/geos_ts_c.cpp
@@ -214,7 +214,7 @@ typedef struct GEOSContextHandle_HS
@@ -233,7 +233,7 @@ typedef struct GEOSContextHandle_HS {
}
void
- NOTICE_MESSAGE(string fmt, ...)
+ NOTICE_MESSAGE(const char *fmt, ...)
{
if (NULL == noticeMessageOld && NULL == noticeMessageNew) {
return;
@@ -222,7 +222,7 @@ typedef struct GEOSContextHandle_HS
if(NULL == noticeMessageOld && NULL == noticeMessageNew) {
return;
@@ -241,7 +241,7 @@ typedef struct GEOSContextHandle_HS {
va_list args;
va_start(args, fmt);
- int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt.c_str(), args);
+ int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt, args);
va_end(args);
va_list args;
va_start(args, fmt);
- int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt.c_str(), args);
+ int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt, args);
va_end(args);
if (result > 0) {
@@ -235,7 +235,7 @@ typedef struct GEOSContextHandle_HS
if(result > 0) {
@@ -255,7 +255,7 @@ typedef struct GEOSContextHandle_HS {
}
void
- ERROR_MESSAGE(string fmt, ...)
+ ERROR_MESSAGE(const char *fmt, ...)
{
if (NULL == errorMessageOld && NULL == errorMessageNew) {
return;
@@ -243,7 +243,7 @@ typedef struct GEOSContextHandle_HS
if(NULL == errorMessageOld && NULL == errorMessageNew) {
return;
@@ -263,7 +263,7 @@ typedef struct GEOSContextHandle_HS {
va_list args;
va_start(args, fmt);
- int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt.c_str(), args);
+ int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt, args);
va_end(args);
va_list args;
va_start(args, fmt);
- int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt.c_str(), args);
+ int result = vsnprintf(msgBuffer, sizeof(msgBuffer) - 1, fmt, args);
va_end(args);
if (result > 0) {
if(result > 0) {