Office pkg with text processor, spreadsheat and presentation generator

This commit is contained in:
hubertf 1998-12-04 03:48:34 +00:00
parent 8762dd8182
commit 3171621e70
7 changed files with 432 additions and 0 deletions

30
misc/siag/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1.1.1 1998/12/04 03:48:34 hubertf Exp $
DISTNAME= siag-3.1.0
CATEGORIES= misc textproc math
MASTER_SITES= ftp://ftp.edu.stockholm.se/pub/siag/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.edu.stockholm.se/siag/
DEPENDS+= Xaw3d-1.5:../../x11/Xaw3d
DEPENDS+= gv-3.5.8:../../print/gv
DEPENDS+= gnuplot-3.5:../../graphics/gnuplot
DEPENDS+= guile-1.3:../../lang/guile
GNU_CONFIGURE= yes
USE_GMAKE= yes
CFLAGS+= -Dunix
STRIPFLAG=
pre-configure:
cd ${WRKSRC} ; \
[ -f topdir.mk.BAK ] || ${MV} topdir.mk topdir.mk.BAK ; \
${SED} \
-e 's|^\(SIAG_HOME\)=.*$$|\1="${PREFIX}/lib/siag"|g' \
-e 's|^\(SIAG_DOCS\)=.*$$|\1=${PREFIX}/share/siag|g' \
-e 's|^\(CURSES\)=.*$$|\1=-lcurses -ltermcap|g' \
<topdir.mk.BAK >topdir.mk
.include "../../mk/bsd.pkg.mk"

3
misc/siag/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1998/12/04 03:48:34 hubertf Exp $
MD5 (siag-3.1.0.tar.gz) = 8fe84f1b418192bd981b092e2d730ce0

View file

@ -0,0 +1,71 @@
$NetBSD: patch-aa,v 1.1.1.1 1998/12/04 03:48:34 hubertf Exp $
--- siod/slibu.c.orig Thu Dec 3 04:26:29 1998
+++ siod/slibu.c Thu Dec 3 05:04:41 1998
@@ -15,13 +15,15 @@
#endif
#endif
+#ifndef __NetBSD__
#ifndef _XOPEN_SOURCE /* and another */
-#define _XOPEN_SOURCE
+#define _XOPEN_SOURCE 2
#endif
#ifndef _POSIX_SOURCE
#define _POSIX_SOURCE
#endif
+#endif /* __NetBSD__ */
#ifndef _BSD_SOURCE
#define _BSD_SOURCE
@@ -89,6 +91,10 @@
#define PATH_MAX MAXPATHLEN
#endif
+#if defined(__NetBSD__)
+#include <sys/syslimits.h>
+#endif
+
#if defined(VMS)
#include <unixlib.h>
#include <stat.h>
@@ -276,6 +282,7 @@
return(NIL);}
#endif
+#ifndef __NetBSD__
LISP lputpwent(LISP alist,LISP file)
{int iflag = no_interrupt(1);
int status;
@@ -284,6 +291,7 @@
status = putpwent(&p,get_c_file(file,NULL));
no_interrupt(iflag);
return(NIL);}
+#endif
LISP laccess_problem(LISP lfname,LISP lacc)
{char *fname = get_c_string(lfname);
@@ -995,7 +1003,7 @@
else
return(NIL);}
-LISP lchmod(LISP path,LISP mode)
+LISP _lchmod(LISP path,LISP mode)
{if (chmod(get_c_string(path),get_c_long(mode)))
return(err("chmod",llast_c_errmsg(-1)));
else
@@ -1954,10 +1962,12 @@
#if defined(__osf__)
init_subr_1("setpwfile",lsetpwfile);
#endif
+#ifndef __NetBSD__
init_subr_2("putpwent",lputpwent);
+#endif
init_subr_2("access-problem?",laccess_problem);
init_subr_3("utime",lutime);
- init_subr_2("chmod",lchmod);
+ init_subr_2("chmod",_lchmod);
init_subr_2("fchmod",lfchmod);
#endif
init_subr_1("random",lrandom);

View file

@ -0,0 +1,48 @@
$NetBSD: patch-ab,v 1.1.1.1 1998/12/04 03:48:34 hubertf Exp $
--- xcommon/DragAndDrop.c.BAK Thu Dec 3 04:51:21 1998
+++ xcommon/DragAndDrop.c Thu Dec 3 04:57:07 1998
@@ -22,7 +22,11 @@
#include <X11/Xmu/WinUtil.h>
#include <stdio.h>
#include <stdlib.h>
+#ifdef __NetBSD__
+#include <machine/limits.h>
+#else
#include <values.h>
+#endif
/* Local variables */
static Display *dpy; /* current display */
@@ -463,13 +467,13 @@
/* Set the data */
AuxData = Data;
- AuxSize = ( Size <= MAXINT ? (int)Size : MAXINT );
+ AuxSize = ( Size <= INT_MAX ? (int)Size : INT_MAX );
XChangeProperty(dpy,root,DndSelection,XA_STRING,8,
PropModeReplace,Data,AuxSize);
for(Size-=(unsigned long)AuxSize;Size;Size-=(unsigned long)AuxSize)
{
Data+=AuxSize;
- AuxSize = ( (Size<=(MAXINT)) ? (int)Size : (MAXINT) );
+ AuxSize = ( (Size<=(INT_MAX)) ? (int)Size : (INT_MAX) );
XChangeProperty(dpy,root,DndSelection,XA_STRING,8,
PropModeAppend,Data,AuxSize);
}
@@ -477,13 +481,13 @@
/* Set the data for old DND version */
Size = BackSize;
AuxData = Data;
- AuxSize = ( Size <= MAXINT ? (int)Size : MAXINT );
+ AuxSize = ( Size <= INT_MAX ? (int)Size : INT_MAX );
XChangeProperty(dpy,root,OldDndSelection,XA_STRING,8,
PropModeReplace,Data,AuxSize);
for(Size-=(unsigned long)AuxSize;Size;Size-=(unsigned long)AuxSize)
{
Data+=AuxSize;
- AuxSize = ( (Size<=(MAXINT)) ? (int)Size : (MAXINT) );
+ AuxSize = ( (Size<=(INT_MAX)) ? (int)Size : (INT_MAX) );
XChangeProperty(dpy,root,OldDndSelection,XA_STRING,8,
PropModeAppend,Data,AuxSize);
}

1
misc/siag/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
Poor man's Office with spreadsheet, word processor and presentation generator

4
misc/siag/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
egon: Egon Animator, presentation generator, similar to MS PowerPoint
siag: Scheme In A Grid, spreadsheet, similar to MS Excel
pw: Pathetic Writer, text processor, similar to MS Word (well... :-)

275
misc/siag/pkg/PLIST Normal file
View file

@ -0,0 +1,275 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1998/12/04 03:48:34 hubertf Exp $
bin/siag
bin/pw
bin/egon
man/man1/siod.1
man/man1/siag.1
man/man1/pw.1
man/man1/egon.1
man/man1/dummy_plugin.1
share/siag/siod/docs/siod.html
share/siag/common/docs/siaghelp
share/siag/common/docs/COPYING.LIB
share/siag/common/docs/Copyright
share/siag/common/docs/credits.html
share/siag/common/docs/embedding.html
share/siag/common/docs/form.html
share/siag/common/docs/interpreters.html
share/siag/common/docs/office.html
share/siag/common/docs/plugins.html
share/siag/common/docs/search.html
share/siag/common/docs/siaghelp.html
share/siag/common/bitmaps/bold.gif
share/siag/common/bitmaps/borders.gif
share/siag/common/bitmaps/copyright.gif
share/siag/common/bitmaps/egon_fg.gif
share/siag/common/bitmaps/fld_open.gif
share/siag/common/bitmaps/floppy3.gif
share/siag/common/bitmaps/grid.gif
share/siag/common/bitmaps/hcenter.gif
share/siag/common/bitmaps/hleft.gif
share/siag/common/bitmaps/hright.gif
share/siag/common/bitmaps/info.gif
share/siag/common/bitmaps/italic.gif
share/siag/common/bitmaps/new.gif
share/siag/common/bitmaps/next.gif
share/siag/common/bitmaps/none.gif
share/siag/common/bitmaps/play.gif
share/siag/common/bitmaps/plotter.gif
share/siag/common/bitmaps/preview.gif
share/siag/common/bitmaps/previous.gif
share/siag/common/bitmaps/printer.gif
share/siag/common/bitmaps/pw_fg.gif
share/siag/common/bitmaps/siag_fg.gif
share/siag/common/bitmaps/sigma.gif
share/siag/common/bitmaps/stop.gif
share/siag/common/bitmaps/uchar.gif
share/siag/common/bitmaps/uline.gif
share/siag/common/bitmaps/vbottom.gif
share/siag/common/bitmaps/vtop.gif
share/siag/xcommon/docs/CHANGES
share/siag/xcommon/docs/TODO
share/siag/xcommon/docs/filesel.html
share/siag/xcommon/form.scm
share/siag/siag/docs/BUGS
share/siag/siag/docs/CHANGES
share/siag/siag/docs/COPYING
share/siag/siag/docs/Makefile.am
share/siag/siag/docs/README
share/siag/siag/docs/TODO
share/siag/siag/docs/c-expr.html
share/siag/siag/docs/commands.html
share/siag/siag/docs/concepts.html
share/siag/siag/docs/fileformats.html
share/siag/siag/docs/form.html
share/siag/siag/docs/gnuplot.html
share/siag/siag/docs/howto.html
share/siag/siag/docs/intro.html
share/siag/siag/docs/invocation.html
share/siag/siag/docs/keys.html
share/siag/siag/docs/mouse.html
share/siag/siag/docs/scheme.html
share/siag/siag/docs/scrollbars.html
share/siag/siag/docs/siag.gif
share/siag/siag/docs/siag.html
share/siag/siag/docs/strings.html
share/siag/siag/docs/toolbar.html
share/siag/siag/data.scm
share/siag/examples/siag/allfuncs.wk1
share/siag/examples/siag/cheeses.siag
share/siag/examples/siag/emprestimo.wk1
share/siag/examples/siag/example.wk1
share/siag/examples/siag/fibonacci-c.siag
share/siag/examples/siag/fibonacci.siag
share/siag/examples/siag/fonts.siag
share/siag/examples/siag/foo.siag
share/siag/examples/siag/foo.wk1
share/siag/examples/siag/formtest.siag
share/siag/examples/siag/group.siag
share/siag/examples/siag/heaven-c.siag
share/siag/examples/siag/heaven-guile.siag
share/siag/examples/siag/heaven-tcl.siag
share/siag/examples/siag/heaven.siag
share/siag/examples/siag/hyperhelp.siag
share/siag/examples/siag/image_plugin.siag
share/siag/examples/siag/kalkyl.siag
share/siag/examples/siag/mailaddr.csv
share/siag/examples/siag/morefonts.siag
share/siag/examples/siag/multtabl-c.siag
share/siag/examples/siag/multtabl.siag
share/siag/examples/siag/obras.wk1
share/siag/examples/siag/passwd.siag
share/siag/examples/siag/plot.siag
share/siag/examples/siag/prestacao.wk1
share/siag/examples/siag/property.siag
share/siag/examples/siag/sincos.siag
share/siag/examples/siag/strfib.siag
share/siag/examples/siag/strings.siag
share/siag/examples/siag/surface1.siag
share/siag/examples/siag/surface2.siag
share/siag/examples/siag/tables.wk1
share/siag/examples/siag/tcltest.siag
share/siag/examples/pw/changes.pw
share/siag/examples/pw/chead.doc
share/siag/examples/pw/chead.html
share/siag/examples/pw/chead.pw
share/siag/examples/pw/chead.rtf
share/siag/examples/pw/chead.txt
share/siag/examples/pw/color.pw
share/siag/examples/pw/egon.pw
share/siag/examples/pw/egon.rtf
share/siag/examples/pw/morefonts.pw
share/siag/examples/pw/newpw.pw
share/siag/examples/pw/rtfex.rtf
share/siag/examples/pw/rtftest.rtf
share/siag/examples/pw/rtftest2.rtf
share/siag/examples/pw/rtftest3.rtf
share/siag/examples/pw/standard.bmk
share/siag/examples/pw/styles.html
share/siag/examples/pw/styles.pw
share/siag/examples/pw/styles2.pw
share/siag/examples/pw/svenska.pw
share/siag/examples/pw/svenska.rtf
share/siag/examples/egon/bounce.egon
share/siag/examples/egon/ms.egon
share/siag/examples/egon/propeller.egon
share/siag/examples/egon/rondo.egon
share/siag/pw/docs/BUGS
share/siag/pw/docs/CHANGES
share/siag/pw/docs/COPYING
share/siag/pw/docs/TODO
share/siag/pw/docs/commands.html
share/siag/pw/docs/concepts.html
share/siag/pw/docs/fileformats.html
share/siag/pw/docs/intro.html
share/siag/pw/docs/invocation.html
share/siag/pw/docs/keys.html
share/siag/pw/docs/mouse.html
share/siag/pw/docs/pw.gif
share/siag/pw/docs/pw.html
share/siag/pw/docs/scheme.html
share/siag/pw/docs/scrollbars.html
share/siag/pw/docs/spell.html
share/siag/pw/docs/strings.html
share/siag/pw/docs/toolbar.html
share/siag/egon/docs/BUGS
share/siag/egon/docs/CHANGES
share/siag/egon/docs/COPYING
share/siag/egon/docs/TODO
share/siag/egon/docs/commands.html
share/siag/egon/docs/concepts.html
share/siag/egon/docs/egon.gif
share/siag/egon/docs/egon.html
share/siag/egon/docs/fileformats.html
share/siag/egon/docs/intro.html
share/siag/egon/docs/invocation.html
share/siag/egon/docs/keys.html
share/siag/egon/docs/mouse.html
share/siag/egon/docs/scheme.html
share/siag/egon/docs/scrollbars.html
share/siag/egon/docs/strings.html
share/siag/egon/docs/toolbar.html
lib/siag/siod/siod.scm
lib/siag/common/bitmaps/blank.xpm
lib/siag/common/bitmaps/bold.xpm
lib/siag/common/bitmaps/borders.xpm
lib/siag/common/bitmaps/copy.xpm
lib/siag/common/bitmaps/copyright.xpm
lib/siag/common/bitmaps/cut.xpm
lib/siag/common/bitmaps/egon_fg.xpm
lib/siag/common/bitmaps/fld_open.xpm
lib/siag/common/bitmaps/floppy3.xpm
lib/siag/common/bitmaps/grid.xpm
lib/siag/common/bitmaps/hcenter.xpm
lib/siag/common/bitmaps/hleft.xpm
lib/siag/common/bitmaps/hright.xpm
lib/siag/common/bitmaps/info.xpm
lib/siag/common/bitmaps/italic.xpm
lib/siag/common/bitmaps/new.xpm
lib/siag/common/bitmaps/next.xpm
lib/siag/common/bitmaps/none.xpm
lib/siag/common/bitmaps/paste.xpm
lib/siag/common/bitmaps/play.xpm
lib/siag/common/bitmaps/plotter.xpm
lib/siag/common/bitmaps/preview.xpm
lib/siag/common/bitmaps/previous.xpm
lib/siag/common/bitmaps/printer.xpm
lib/siag/common/bitmaps/pw_fg.xpm
lib/siag/common/bitmaps/redo.xpm
lib/siag/common/bitmaps/siag_fg.xpm
lib/siag/common/bitmaps/sigma.xpm
lib/siag/common/bitmaps/sortaz.xpm
lib/siag/common/bitmaps/sortza.xpm
lib/siag/common/bitmaps/spell.xpm
lib/siag/common/bitmaps/stop.xpm
lib/siag/common/bitmaps/uchar.xpm
lib/siag/common/bitmaps/uline.xpm
lib/siag/common/bitmaps/undo.xpm
lib/siag/common/bitmaps/vbottom.xpm
lib/siag/common/bitmaps/vtop.xpm
lib/siag/common/any2xpm
lib/siag/common/colors.scm
lib/siag/common/fonts.scm
lib/siag/common/tools.scm
lib/siag/common/dictionary.sv
lib/siag/xcommon/StringDefs.scm
lib/siag/xcommon/form.scm
lib/siag/siag/123.scm
lib/siag/siag/data.scm
lib/siag/siag/external.load
lib/siag/siag/external.save
lib/siag/siag/filemgr.scm
lib/siag/siag/find.scm
lib/siag/siag/keytable.scm
lib/siag/siag/mailto.scm
lib/siag/siag/menu.scm
lib/siag/siag/plot.scm
lib/siag/siag/siag-http.scm
lib/siag/siag/siag-net.scm
lib/siag/siag/siag.scm
lib/siag/siag/sort.scm
lib/siag/siag/splot.scm
lib/siag/siag/styles.scm
lib/siag/siag/usermgr.scm
lib/siag/pw/external.load
lib/siag/pw/external.save
lib/siag/pw/menu.scm
lib/siag/pw/pw.scm
lib/siag/pw/styles.scm
lib/siag/egon/animator.scm
lib/siag/egon/egon.scm
lib/siag/egon/menu.scm
lib/siag/egon/external.load
lib/siag/egon/external.save
lib/siag/plugins/dummy
lib/siag/plugins/image
lib/siag/plugins/hello
lib/siag/plugins/dummy.scm
lib/siag/plugins/plugin.scm
@dirrm lib/siag/common/bitmaps
@dirrm lib/siag/common
@dirrm lib/siag/xcommon
@dirrm lib/siag/siag
@dirrm lib/siag/siod
@dirrm lib/siag/pw
@dirrm lib/siag/egon
@dirrm lib/siag/plugins
@dirrm lib/siag
@dirrm share/siag/egon/docs
@dirrm share/siag/egon
@dirrm share/siag/pw/docs
@dirrm share/siag/pw
@dirrm share/siag/examples/siag
@dirrm share/siag/examples/pw
@dirrm share/siag/examples/egon
@dirrm share/siag/examples
@dirrm share/siag/siag/docs
@dirrm share/siag/siag
@dirrm share/siag/xcommon/docs
@dirrm share/siag/xcommon
@dirrm share/siag/common/docs
@dirrm share/siag/common/bitmaps
@dirrm share/siag/common
@dirrm share/siag/siod/docs
@dirrm share/siag/siod
@dirrm share/siag