Remove workaround for 'pkg_add -f' bug, now that it is fixed in pkg_install.
Bump PKGREVISION.
This commit is contained in:
parent
ca1dc26c90
commit
319c043093
3 changed files with 20 additions and 2 deletions
|
@ -1,9 +1,10 @@
|
||||||
# $NetBSD: Makefile,v 1.38 2013/06/16 14:37:33 imil Exp $
|
# $NetBSD: Makefile,v 1.39 2013/09/02 10:38:04 jperkin Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
GHCOMMIT= 3859170568fbe4fe21b5660dbaeca8d65ac10f1b
|
GHCOMMIT= 3859170568fbe4fe21b5660dbaeca8d65ac10f1b
|
||||||
DISTNAME= ${GHCOMMIT}
|
DISTNAME= ${GHCOMMIT}
|
||||||
PKGNAME= pkgin-0.6.4
|
PKGNAME= pkgin-0.6.4
|
||||||
|
PKGREVISION= 1
|
||||||
CATEGORIES= pkgtools
|
CATEGORIES= pkgtools
|
||||||
MASTER_SITES= https://github.com/NetBSDfr/pkgin/archive/
|
MASTER_SITES= https://github.com/NetBSDfr/pkgin/archive/
|
||||||
FETCH_USING= curl
|
FETCH_USING= curl
|
||||||
|
|
|
@ -1,5 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.28 2013/06/16 14:37:33 imil Exp $
|
$NetBSD: distinfo,v 1.29 2013/09/02 10:38:04 jperkin Exp $
|
||||||
|
|
||||||
SHA1 (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = 58d06c5884dd490508f609c5320542c919afe0c7
|
SHA1 (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = 58d06c5884dd490508f609c5320542c919afe0c7
|
||||||
RMD160 (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = e783457044af3b41a784012f4d0961ed87e8c4af
|
RMD160 (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = e783457044af3b41a784012f4d0961ed87e8c4af
|
||||||
Size (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = 187873 bytes
|
Size (3859170568fbe4fe21b5660dbaeca8d65ac10f1b.tar.gz) = 187873 bytes
|
||||||
|
SHA1 (patch-actions.c) = 5ce6ac2051c0f9e7048926b3b5f41d8c17d98252
|
||||||
|
|
16
pkgtools/pkgin/patches/patch-actions.c
Normal file
16
pkgtools/pkgin/patches/patch-actions.c
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
$NetBSD: patch-actions.c,v 1.1 2013/09/02 10:38:04 jperkin Exp $
|
||||||
|
|
||||||
|
No need to work-around 'pkg_add -f' bug any more.
|
||||||
|
|
||||||
|
--- actions.c.orig 2013-09-02 10:32:50.000000000 +0000
|
||||||
|
+++ actions.c
|
||||||
|
@@ -139,9 +139,6 @@ analyse_pkglog(long int filepos)
|
||||||
|
/* Warning: [...] was built for a platform */
|
||||||
|
if (strstr(err_line, "Warning") != NULL)
|
||||||
|
warn_count++;
|
||||||
|
- /* A different version [...] is already installed */
|
||||||
|
- if (strstr(err_line, "already installed") != NULL)
|
||||||
|
- err_count--;
|
||||||
|
/* 1 package addition failed */
|
||||||
|
if (strstr(err_line, "addition failed") != NULL)
|
||||||
|
err_count++;
|
Loading…
Reference in a new issue