use ${PYTHON} instead of python to use python
patch provided by: FUKAUMI Naoki fun at naobsd dot org
This commit is contained in:
parent
2df1c922f3
commit
31a1bdfc13
2 changed files with 28 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1 2004/05/08 18:24:00 cl Exp $
|
||||
$NetBSD: distinfo,v 1.2 2004/05/08 18:50:09 cl Exp $
|
||||
|
||||
SHA1 (xeno-1.2-src-040418.tgz) = d19f627dc40416f369f6728fcd86e4364e1713ee
|
||||
Size (xeno-1.2-src-040418.tgz) = 2960238 bytes
|
||||
|
@ -17,3 +17,4 @@ SHA1 (patch-aj) = 3d567c5497b09e1b5980fe75d2bb38a23e39621d
|
|||
SHA1 (patch-ak) = d4e0d09f232f9d37ab4ab93fc389b07de4d9a5da
|
||||
SHA1 (patch-al) = 3ab650d2608455c603046afe46375ff3fa219703
|
||||
SHA1 (patch-am) = 90e31b894191b2a8df23344bc6997fa874f555e9
|
||||
SHA1 (patch-an) = 0351b1941ca85c016a8a09bb94ad9c126cb4af91
|
||||
|
|
26
sysutils/xentools12/patches/patch-an
Normal file
26
sysutils/xentools12/patches/patch-an
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-an,v 1.1 2004/05/08 18:50:09 cl Exp $
|
||||
|
||||
--- xc/py/Makefile.orig 2004-04-18 04:29:16.000000000 +0200
|
||||
+++ xc/py/Makefile
|
||||
@@ -1,17 +1,17 @@
|
||||
|
||||
all: ../lib/libxc.so.1.2.0 ../lib/xc.h
|
||||
- python setup.py build
|
||||
+ ${PYTHON} setup.py build
|
||||
|
||||
install: all
|
||||
- if [ "$(prefix)" = "" ]; then python setup.py install; \
|
||||
- else python setup.py install --root "$(prefix)"; fi
|
||||
+ if [ "$(prefix)" = "" ]; then ${PYTHON} setup.py install; \
|
||||
+ else ${PYTHON} setup.py install --root "$(prefix)"; fi
|
||||
|
||||
dist: all
|
||||
mkdir -p ../../../../install/lib/python
|
||||
for i in `find . -name 'Xc.so'` ; do \
|
||||
install --mode=755 $$i ../../../../install/lib/python/`basename $$i` ; \
|
||||
done
|
||||
- python -c 'import py_compile, sys; py_compile.compile("XenoUtil.py")'
|
||||
+ ${PYTHON} -c 'import py_compile, sys; py_compile.compile("XenoUtil.py")'
|
||||
install --mode=444 XenoUtil.py ../../../../install/lib/python
|
||||
install --mode=644 XenoUtil.pyc ../../../../install/lib/python
|
||||
clean:
|
Loading…
Reference in a new issue