If MIN() is undefined, just define one instead of including utility.h
on SunOS, which presumes a version of eti.h that has some extras over what is provided in ncurses/eti.h, causing unnecessary build errors.
This commit is contained in:
parent
1b36d4204b
commit
31bf601935
2 changed files with 22 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.13 2015/11/04 00:35:43 agc Exp $
|
$NetBSD: distinfo,v 1.14 2016/03/24 13:36:52 richard Exp $
|
||||||
|
|
||||||
SHA1 (vino-2.32.2.tar.bz2) = e457d1c5705607c3cd18b7e6fbb8776b7483c733
|
SHA1 (vino-2.32.2.tar.bz2) = e457d1c5705607c3cd18b7e6fbb8776b7483c733
|
||||||
RMD160 (vino-2.32.2.tar.bz2) = 1de0923ef33a73dd6a9c4e761291728c552708e8
|
RMD160 (vino-2.32.2.tar.bz2) = 1de0923ef33a73dd6a9c4e761291728c552708e8
|
||||||
|
@ -7,3 +7,4 @@ Size (vino-2.32.2.tar.bz2) = 856440 bytes
|
||||||
SHA1 (patch-aa) = d240f809769fee144ce0a6057327107ade82ef6c
|
SHA1 (patch-aa) = d240f809769fee144ce0a6057327107ade82ef6c
|
||||||
SHA1 (patch-ab) = 0c09812fc98bced9938a0460305c7dbcbed40ad3
|
SHA1 (patch-ab) = 0c09812fc98bced9938a0460305c7dbcbed40ad3
|
||||||
SHA1 (patch-ad) = 0e1b226e8c5ac5f9e3d3c7270b9a19a2314ef737
|
SHA1 (patch-ad) = 0e1b226e8c5ac5f9e3d3c7270b9a19a2314ef737
|
||||||
|
SHA1 (patch-server_miniupnp_miniwget.c) = 6612c1a16d955c0e60546209d0e2f47546a976ff
|
||||||
|
|
20
net/vino/patches/patch-server_miniupnp_miniwget.c
Normal file
20
net/vino/patches/patch-server_miniupnp_miniwget.c
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
$NetBSD: patch-server_miniupnp_miniwget.c,v 1.1 2016/03/24 13:36:52 richard Exp $
|
||||||
|
|
||||||
|
If MIN() is undefined, just define one instead of including utility.h
|
||||||
|
on SunOS, which presumes a version of eti.h that has some extras over
|
||||||
|
what is provided in ncurses/eti.h, causing unnecessary build errors.
|
||||||
|
|
||||||
|
--- server/miniupnp/miniwget.c.orig 2011-02-23 20:29:05.000000000 +0000
|
||||||
|
+++ server/miniupnp/miniwget.c
|
||||||
|
@@ -26,9 +26,8 @@
|
||||||
|
#include <arpa/inet.h>
|
||||||
|
#define closesocket close
|
||||||
|
#endif
|
||||||
|
-/* for MIN() macro : */
|
||||||
|
-#if defined(__sun) || defined(sun)
|
||||||
|
-#include <utility.h>
|
||||||
|
+#ifndef MIN
|
||||||
|
+#define MIN(x, y) ((x) < (y) ? (x) : (y))
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* miniwget2() :
|
Loading…
Reference in a new issue